Sharing audio file across layers

I have several question banks that play an audio file, as the participant to select a free from answer, then goes to a correct/incorrect layer. I would like to have the audio play again in the feedback layer, but don't want to have to attach the audio file 3 times (thereby tripling the size of the overall project). Is there a way to call this same audio file from the base layer to the feedback layers?

8 Replies
Christine Hendrickson

Hi Virginia,

One option that comes to mind is to create an "Audio" layer for your audio file(s). If you change set the options for this and other layers so that no layers are hidden, the audio should play through all layers. 

You could even add triggers to your audio so that it starts when the layer timeline is started, then close the layer when a learner clicks outside of a placeholder in that layer. 

I created a very quick example for you, if you'd like to take a look:

Example For Virginia

In the example, you'll see that the same audio plays on the base layer, on the "Try Again" layer (I have it set to unlimited attempts) and on the "Correct" layer. 

I'm also attaching the file, just in case you'd like to take a closer look at how I set this up.

If you have any questions, or need any help with this, just let me know.

Thanks!

Virginia Driscoll

Hi Christine, 
Thank you for your assistance; however, the slide layers won't recall the sound when I attempt to run the project. I get an initial audio, but follow-up clicks don't produce any sound. I like the idea of having an audio layer, but I have been hiding the base layer so that there is less visual interference.

Virginia Driscoll

Okay, Christine,
Here goes. On one set of question banks,  Singer, I have the stimulus play on the base layer, then again on the feedback layer. No problem. On the Pitch question banks, I'm trying to do the same thing. No luck. My only thought on a reason, is that the Audio layer for Pitch has 3 stimuli whereas the Singer Audio only has one. This is a huge file (20+ MB) because of the audio and sheer number of slides.

Thank you!
Ginny 

Christine Hendrickson

Hi Ginny! :)

Thanks very much for sharing your project file - this is pretty cool :D

There are actually a couple of things that I want to suggest for you, but first the solution to the audio not playing in your "Pitch" question bank. 

To get these working, you'll want to change the revisiting setting for the Audio layer to Reset to initial state. This is because the layer keeps opening where it left off - in this case, the audio has already finished playing. 

The second suggestion is to add a trigger that will close the layer. The reason for this is that even though the layer is set to close when the layer's timeline ends, if a learner clicks on one of your numbers in the slide before it finishes, the layer won't start over again. 

I'd recommend applying these to both of your question banks, just to ensure you don't have any other trouble with it. 

I've already made the changes to your Pitch question bank for you :) I'm attaching it to this response.

Please let me know if you have any questions, or any other trouble.

Thanks!