SL1 - issues importing video?

Greetings,

I am trying to place a video from a website in my Storyline 1 module. I first used Insert > video > video from website, but I got an error message that said "storyline could not insert a video from this embed code. Verify that the embed code is correct, and then try again."

The video is housed on my client's server, so I'm guessing that SL as some problem with that. When I paste the URL into any web browser, the video plays just fine. It is an Mp4 format. Unfortunately, I cannot share the video's URL as it has sensitive client information.

Next, I tried inserting a web object with the video's URL. This did play the video when published, however it only played at full size, which is much bigger than what the module can accommodate. I tried to resize the web object, but it just cropped the video rather than resizing it.

So, my question is:  is there any way to resize the web object so that it does not just crop the video? If not, I suppose I will either have to see if there is an alternate place to store the video, or download and embed the video locally, which would vastly increase the module's file size.

Any advice is greatly appreciated! Thank you!

11 Replies
Ashley Terwilliger-Pollard

Hi John,

Without seeing the embed code, it's hard to determine if there was an issue within that itself - but you can see when inserting any link as a web object, and if you resize the overall shape of the web object it'll crop it or add scroll bars to help the user navigate the content and doesn't change the overall size or resolution of the original. Are you able to allow the web object to display in a new window? 

Vic Bishop

I can't import YouTube videos either, it gives me the same error.

However I know embed codes from other sites do work as I was successfully imported a Vimeo video! If any one can help the embed code is below. 

<iframe src="https://w.kontiki.com/nestle/player/eec7b3b4-5470-4842-a5ee-496599cb128d?params=MD1mYWxzZTsxPTE2OTsxMj1mYWxzZQ==" style="border:none;width:100%;height:100%" scrolling='no' allowfullscreen></iframe>

Ashley Terwilliger-Pollard

Hi Linh,

There are two ways to insert Youtube videos as described here. Please make sure you're copying all of the embed code as listed on the Youtube video and if you're still having difficulty can you share it here so that we can take a look? 

Vic, in regards to your video embed code, it looks to be coming from Kontiki - not YouTube. This has been reported to our QA team in regards to kontiki videos, and it seems that SL2 is requiring height and width attributes rather than allowing the CSS styling supplied. 

Ashley Terwilliger-Pollard

Hi Vic, 

I just grabbed a random embed code from YouTube here. (It's the Tonight Show with Jimmy Fallon - one of my favs). You'll want to make sure you use the "Share - Embed code" and capture all of it, and then insert it into Storyline using the "Insert Video from Website" to be able to insert that code. 

I uploaded a copy of it to Tempshare and it all works fine for me. 

Can you share the YouTube embed code you're working with? As I mentioned we're aware of an issue with the Kontiki code, and how it's determining the height and width attributes. 

Vic Bishop

So when I paste the below embed code code into SL2 I get the attached error.

<iframe width="560" height="315" src="//www.youtube.com/embed/GCqbbaIK_yU" frameborder="0" allowfullscreen></iframe>

If I use the code below from Vimeo it works fine!

<iframe src="//player.vimeo.com/video/116582567" width="500" height="281" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe> <p><a href="http://vimeo.com/116582567">Fibonacci Zoetrope Sculptures</a> from <a href="http://vimeo.com/pier9">Pier 9</a> on <a href="https://vimeo.com">Vimeo</a>.</p>

I thought if I could work out why one was working and the other was not then I could get the Kontiki (internal video host) videos to work. But from what you say and show me the YT videos should not give me an error, so perhaps there are more things wrong with my version of SL2

What do you think?
(thanks for the help)

Ashley Terwilliger-Pollard

Hi, Vic 

I took both of the codes you shared here, and embedded them into Storyline 2. I didn't receive an error message for either of them. I've attached a copy of the .story file

Since it seems it's something more specific to your Storyline - can you confirm that you're working on local project files as described here and look into conducting the repair of Storyline. 

Vic Bishop

Hi Ashley,

Great thanks for this confirmation. I have checked with someone else in the office and their version of SL does import videos from YT. So it is an issue with my version of SL.

Have you got any news from the QA team on how to format the "Kontiki" embed code to make SL accept it?