SL2 Bug: Hide objects on base layer ALSO pauses base layer

Here's the setup:

A base layer is doing normal base layer stuff-- there's some audio; after 1 second, an object appears; after a few seconds, there's a trigger on the timeline to show another layer. Now, depending on the properties of this new layer, things get weird:

If (as is the case on slide 2 of the attached file)

Hide objects on base layer = ENABLED

Pause timeline of base layer = DISABLED

Then it SHOULD:

Hide the objects on the base layer but continue playing the base layer's audio.

What it actually DOES:

Hide the objects on the base layer AND pause the base layer timeline and audio.

Does anyone know whether this is by design? I thought maybe the audio on the base layer is an object, but "hiding" an audio object should mean muting it, not pausing it. 

I discovered this in Storyline 2. I have not tested to see whether it exists in Storyline 1.

6 Replies
Greg Faust

I haven't had reason to test it lately, but if you're saying Storyline still deactivates everything about the layer, I can suggest a couple workarounds. There are ways to hide the objects on a layer without hiding the layer.

  1. Use triggers ("Change State of [object] to Hidden"). Depending on what all the slide does, you may also need "Change State of [object] to Normal" triggers for when you want them to reappear.
  2. With the eyeball icon to the left of an object's timeline. I haven't used this method enough to know what quirks it has, but I believe you can set particular objects on the base layer to auto-hide any time Layer1 is active. With Layer1 selected, Base Layer objects are at the bottom of your timeline; click the eyeball there, and I think that will hide those objects only when Layer1 is active.
  3. Cover them up. Put a big rectangle covering the entire screen at the bottom of Layer1, and set its Fill to "Slide background fill". This method feels kind of cheap, but it should be fast, and it allows you to let the base layer timeline advance (in case that's what you want to do). The caveat is that people will still be able to select the covered objects by pushing "tab" repeatedly (unless you disable this in the objects' properties-- select the object; right-click; size and position; Alt Text tab; uncheck the box).
  4. Put the objects that need to be hidden on a different layer; hide that layer instead of the base layer (where you can still have your audio).