SL360 Video Does Not Autoplay in Safari 11

Hey everyone,

We've stumbled upon an issue with Safari 11's default setting that prevents videos from auto playing in HTML5 output (MacOS High Sierra). Any videos inserted from a file, that are set to autoplay do not play when initially loaded—but they do play on slide revisit.

Can anyone test a course with video in Safari 11 to confirm?

This is a huge bug that we're running into at the 11th hour on a huge deliverable. For the community admins, I've already reported it as a bug (Case 01162172)—just trying to confirm we're not the only ones impacted.

36 Replies
Michael Jones

Yeah, and one that’s going to cause major headaches for anything that is set to auto play and has a transparent ovet lay that was previously meant to prevent learners from accidentally pausing a video that’s synced with the rest of the timeline.

I know that the setting can be adjusted for specific domains to not block auto play, but that’s really going to be difficult to roll out for all of our clients that are impacted. Especially those that have an IT department that prevents users from adjusting settings.

Such a headache!

Ashley Terwilliger

Hi all,

With the changes to Safari and how it no longer allows for autoplay, we've implemented a new fix for this in Update 11 of Articulate 360. Take a look at the information here:

We added a workaround for Safari's new default behavior to Storyline 360 and Studio 360. Just install the latest software update and republish your course.

Learners using Safari 11 now see a play button when they launch or resume a course with a video on the first slide. Clicking the play button allows the video to play as expected.

Videos on other slides in the course should autoplay as expected.

Storyline 3, Storyline 2, and Studio '13

Safari 11 users will need to change their browser permissions or switch to a different browser to allow videos to autoplay. Here's how to change Safari 11 permissions:

  • Launch your course or the website where it’s hosted in Safari 11.
  • Click Safari on the menu bar and choose Settings for this Website.
  • When the settings appear, click Auto-Play and select Allow All Auto-Play from the drop-down list.
  • You can send these instructions to learners when you invite them to view your course, or you could add instructions to the first slide of your course for Safari 11 users.
Dave Sherman

Thanks, Ashley.

I use Storyline 360 and installed the update. True to form, I saw the play button and it worked the first time. When I closed the tab and reopened the course, the play button did not appear and the video did not play.

I added an intro slide with a next button and the same thing happened. the video played fine the first time, but not afterwards.

Both approaches worked after clearing my cache, however, my concern is for users who won't know to do this. Any insights or thoughts on this would be greatly appreciated.

Dave

Crystal Horn

Hi there, Dave.  Thanks for sharing your experience.  I tested a mockup course with 2 identical slides that have automatically playing videos.  The play button appeared the first time before the first slide only, and upon refreshing the browser, the play button did not appear, but the videos still played automatically.  

Can you test my course here and let me know what you see?

Did you have your course hosted at the same URL prior to the update?  If so, do you have learners who might have viewed the previous version at the same URL?

Paul Gustafson

I know you don't have control of what Safari does but putting a big play button up is not a very elegant fix.  Our courses uses an external shell so every topic will have the big play button...not very user friendly...  And we have SL3 (not 360).  We start all our topics with a slate.  So with SL2 I put a little 1 sec video in a layer that is triggered when the user clicks next.  And then I used that SL2 hack that removes the PLAY button and everything worked.  So I wondered if anyone has a hack for SL3 (and knows where to place it) or if there is another solution.

Joseph Ferraro

I tested this on Safari and the video did not play automatically (seekbar continued moving though). 

My team is experiencing this issue in a big way, and it's super frustrating being locked out of a reasonable solution due to SL3 not receiving 360's update. The workarounds are very time consuming and inconsistent.

Ashley Terwilliger

Hi Joseph,

Storyline 3's next update is scheduled for release within the coming weeks after our team finishing up some additional testing. That will include all the fixes you've seen release in Storyline 360, so you'll have those shortly! We'll let you know here in ELH once that is ready and released! 

Alyssa Gomez

Hi there Paul,

Are you having trouble with Storyline 3 videos auto-playing in Safari 11?

We're still working through this issue in Storyline 3, and we'll let you know as soon as we get an update. For now, you'll want to follow these steps:

  1. Launch your course or the website where it’s hosted in Safari 11.
  2. Click Safari on the menu bar and choose Settings for this Website.
  3. When the settings appear, click Auto-Play and select Allow All Auto-Play from the drop-down list.

You can send these instructions to learners when you invite them to view your course, or you could add instructions to the first slide of your course for Safari 11 users.

Paul Gustafson

Thanks but we have thousands of users and it is impractical to send this info .  Luckily we haven't opened up to mobile completely yet...cause this is isolated to mobile.    With SL2, on the opening slate, I put a little 1 sec video in a layer that is triggered when the user clicks next.  And then I used that SL2 hack that removes the PLAY button and everything worked!  But not in SL3...so I'm really hoping your team comes up with a more elegant way to handle this.  thanks

Ashley Terwilliger

Hi Paul,

I'm sorry you're not able to go through those steps. Safari (and soon Chrome) have changed the way they handle the auto-play of media. We've already pushed a fix for this into Storyline 360, and we're still pending that same update for Storyline 3 - so we'll let you know as soon as it's ready. 

Ashley Terwilliger

Looks like I just posted a reply in this other discussion you are in too.

Storyline 360 does have a fix in place for this, so I'd want to make sure you're using the latest update (update 14) and testing a new copy uploaded to your server/LMS. To confirm that it's not a cached copy, try accessing it incognito or using another hosting site such as Amazon S3, upload to Tempshare, or SCORM Cloud. 

Since you also have a case going with Eloisa, I'll give her a heads up too - and you can share a copy of your Storyline 360 file with her. She can help test too. 

Oscar Gagliardi, Jr.

I am currently running Storyline 360 version 3.14.15225.0. I just published a brand new module that has 32 slides and includes a total of 7 videos. All the videos are configured to automatically play. The first slide with a video is slide 8 which auto-plays. Slide 11 is the next slide with a video and it also auto-plays. When the program reaches slide 14 which has the next video, this one doesn't auto-play and neither any other video after that one.

If I press on any of the videos that don't auto-play, nothing happens. If I press a second time, the video starts playing.

I am using Safari running IOS 11.3 on the latest iPad (6th Generation) and this is where I am experiencing the problems.

The same module runs well from beginning to end on Chrome and Safari on a Mac, but that doesn't help us because we are making this program to exclusively run on iPads.

Thank you.

Krista Shannon

Hi Oscar,

The particular issue you just described sounds like the same issue that we experienced with Storyline 3 update 3.3.15007.0 and Storyline 360 updates 3.13.15006.0 and 3.14.15225.0 with videos sometimes not auto-playing on iPad iOS 10.3.3 (in this case). A case was raised with Articulate: #01293964, and the last update I received was that the issue has been raised as a possible software bug by Articulate.

To work around this, we have had to rebuild courses to require the learner to select a button to play each video.

I reported this via this particular forum post so you can see all the details there:

https://community.articulate.com/discussions/articulate-storyline/storyline-3-crashes-on-ipad-safari-and-chrome?page=6

Crystal Horn

Hi there, Oscar.  I used a quick mockup with a content slide and 5 video slides, hosted in SCORM Cloud.  My videos autoplayed on my iPad with iOS 11.3.

Can you share a copy of your file here for me to test?  I'd like to see if we can match it to the issue that Krista described for SL3.  Thanks!

Ashley Terwilliger

Hi all, 

We added support for Safari's new default behavior to the May 8, 2018 update for Storyline 3. Install the latest update and republish your course.

Learners using Safari 11 now see a play button when they launch or resume a course with a video on the first slide. Clicking the play button starts the course and allows the video to play. Videos on other slides in the course should autoplay as expected.

Please let us know if you have any other questions! 

Paul Gustafson

Is the big play button a server side fix.  Meaning when the course starts  up, I see dots and it seems like it is hitting your servers before putting up the play button.  We have hundreds of courses each with individual storyline topics (we don't use the menu) and we don't want to republish everything to make old courses work (most have autoplay), and then there is the added inconvenience of users selecting play for every topic.

Paul Gustafson

BTW...we already have a slate at the beginning of each of our topics.  It has no audio.  We've tried both having the Next button (user selected) trigger an offscreen video (to initialize the video) and we've tried to put a button on the slate that a user must select to initialize video.  Both still produce the Play button.  What would you recommend we put on our slates to get user interaction, avoid your play button, and audio issues.?  thanks!