Slide Duration and Video Duration

I am currently working on a course that is almost exclusively comprised of short videos. I am noticing a strange behavior on some of the slides.

The slide duration seems to match the video duration (I start with a new slide and insert the video file), but when I preview or publish, the slide continues after the end of the video.

Then (maybe after publish?), I notice that some of the problem slides are now showing a duration of 61 seconds, even though they were previously, say, 30 seconds.

Has anyone encountered this? Many thanks!

8 Replies
Alison Martin

I have still not resolved the actual issue, but I have found a workaround!

I have added a trigger to jump to next slide when media (video) completes. It is not perfect because the seekbar does not go to the end. If that is a concern, then hide the seekbar and show video controls in the slide (below the video).

Lauren Connelly

Hello Allison!

The timeline should end with the media unless there is an object displayed after the video. I'm happy to dig deeper into the file to see what is going on.

Would you mind sharing the file with us? You can do so by using the "add attachment" button in this discussion. Or you can share the file privately with our Support Engineers by using this link.

Kim Soon NG

I'm facing the same issue. the slide duration is double the video duration when I preview.

I was created a video using the record screen and inserted a text boxes started and ended in different timing. When viewing using the play button at the bottom of the timeline, it seem working correctly. All the text boxes were appeared at the correct timing. But when I preview, the slide duration and longer than the video duration and all the text boxes were appeared incorrect timing.

I tried the created a layers for each of the text boxes and trigger it to show and hide the layers in different timing. Hope can make some changes. Unfortunately, the result was same when I preview.

As you said and logically, the timeline should end with the media if there isn't any activities after the video. So is it the software bug?

Please advise.

Thank you.

Kim Soon

Lauren Connelly

Hi Kim!

Sorry you've hit this snag! It sounds like you've tried to troubleshoot the issue with brilliant steps. It's hard to say it's a bug without seeing the file. Are you able to share your file with us?

You can do so by using the "add attachment" button in this discussion. Or you can share the file privately with our Support Engineers by using this link.

Kim Soon NG

I found out the reason caused this issue.

All the while I'm working on a wide-screen monitor connecting onto my laptop. So I set the story size following my wide-screen monitor resolution (1920x1080) setting and I set the player size to "scale player to fill browser window".

When I preview on my laptop screen, it is working fine. But when I preview on the wide-screen monitor, the issue happened.

When I connect a 4:3 external monitor and preview on this monitor, it is working fine.

When I set the story size to 720x405 (16:9) and 1024x576, it is working fine on the wide-screen monitor.

So the story size setting is the cause of the issue. When even the width setting of the story size is set higher than 1024, the issue will happen on my wide-screen monitor.

Is it the software issue/limitation or there is other setting I didn't set properly? Please advise.

Kim Soon