Slider initial state doesn't appear

Hope someone can help me.  I am building an interactive menu using 12 layers, each one is revealed as the slider progresses from 0-12.  However, I can't get the initial layer to appear at value 0 when the slide begins, even though I set the start and initial state at 0 and tell the variable to show that layer when the slider value is equal or greater than 0 and less than 1.  Once the slider is moved forward and then back to 0 the initial layer shows.  Sometimes the slide simply locks up and nothing happens.

I've tried setting a trigger to show the layer when the timeline begins and then disappear when the slider is moved (value >0, <1) but when I do that and preview the slide the slider doesn't work at all!

Any ideas?

I've attached the author file.

11 Replies
Michael Hinze

I added a slider trigger that shows layer 0 when the timeline starts. The images on your layers (although they are transparent) overlap the slider on the baselayer and that's why it doesn't seem to work. On layer 0, I moved the image up and then the slider works. You'll need to move or crop the images on the other layers as well. See attached a revised file.

Guy Armstrong

Thanks for your help, Michael, I made the modification you suggested, adding a trigger showing layer 0 when the timeline starts.  I also cropped the images within the frame and moved them up to avoid the slider.

However, there is still a problem.  When I preview my project (and yours) within Storyline 2 it works fine.  But when I publish it (and yours) and then launch it - the slider doesn't work. Hmmm....

I also see that the footprint for the slider is huge, much beyond the control stripe vertically, which can't help but overlap images within the frame. When I reduce the size of the slider the control area gets very thin.  Is there anyway to reduce the footprint of the slider?

Attached my latest author file.


Michael Hinze

@Guy: Hm, I published and uploaded your file to my server and everything seems to work as expected. See here: Are you saying, there is a vertical scrollbar on the browser window when you run the published content? In the Player Properties, I set the player size, sot hat it scales with the size of the browser window. 

I noticed that you publish for LMS. Maybe your LMS launches courses in a fixed-size browser window, which may cut off your content?

Guy Armstrong


When I tried to run it from your site I was prompted to update my Flash player. I did the Flash update and it ran fine from your link as well as from my SCORM Cloud site.

I’ve since sent a link to my client of the most recent version on my SCORM Cloud site and she can’t get it to work. Egg on my face.

Is it possible that we all need the latest version of Flash to make this run? If so, I’m a little disappointed as a touted feature of SL and SL2 is its compatibility especially HTML5 for mobile use. I published the content using the HTML5 setting and also tested it with my Samsung Galaxy 10. It was a little sticky at first but it seemed to run on the tablet.

Your thoughts?

Thanks, Guy

Guy Armstrong

Thanks, Emily.

Just to clarify, when I publish by checking the boxes that say “Include HTML5 Content” and “Use Articulate Mobile Player for iOS and Android” it publishes both Flash and HTML5 versions, right?

And then when a user accesses the content it can tell whether they are using a Flash or mobile device and launches it in that format for them – is this correct?

Appreciate your attention.

Guy Armstrong

Emily Ruby

Hello Guy,

That is correct. Checking those buttons will publish the Flash, HTML5, and App content. 

Here’s how Storyline determines which version of your content to display when learners view it:

  • Learners will see the Flash version of your course if their browser supports it.
  • If learners are using iPads or Android tablets and you selected the Articulate Mobile Player (AMP) option when you published, the course will launch in AMP. (If they don't have the app installed, they'll be prompted to install it.)
  • If learners are using iPads or Android tablets and you didn't select the AMP option when you published, but you did select HTML5, the HTML5 output will launch in their mobile browser.
  • If learners are using a browser without Flash and you marked the HTML5 option, they'll see the HTML5 output. (For a list of supported browsers, click here.)