Sound overlapping on iPad

Hello community!!

I've started to test a couple of modules on an iPad.  We have to use our LMS and play the html5 file in the web browser of our LMS.  The module works fine except for the sound, which overlaps on the slides or delays.  I know that module play most optimally in the Storyline player but that's not an option for us unfortunately.  Any way that we can avoid this sound issue?????

18 Replies
Christine Hendrickson

Hi Lauren,

Without seeing the project, it's difficult to say why the audio is overlapping in your HTML5 output. Does this happen if you publish for the Articulate Mobile player, as well?

Also, an you tell me what version of Storyline you're using, please? To find this information, click on "Help" and "About Articulate Storyline".

If you're not running version 3 (1305.2012), please download and install the update using the link below:

Articulate - Storyline Update 3

Once you've finished installing the update, please republish and test your course on the iPad. If the problem continues after installing the update, or if you already have Update 3 installed, please let me know.

Thanks very much!

Christine

Markus Olsson

We have a lot of  audio issues on iPad which we didn't have prior to installing Update 3. For example two audio files playing simultaneously, overlapping audio between slides, audio playing on slides even though there isn't any audio on the timeline etc.

Anyone else who experienced the same thing and was able to resolve it?

I've submitted a support case.

Jane Jones

I am experiencing the same problems when playing on an iPad as Markus Olsson "audio files playing simultaneously, overlapping audio between slides, audio playing on slides even though there isn't any audio on the timeline etc." I see in the post above that "Jonathan" helped him. Please post the advice or workaround.

I'm also having a problem with audio when when leaving a page (during the timeline, not at the beginning)  to go to a lightbox then returning to that page. After I close the lightbox, it returns to the page I left but the page animations start over at the beginning of the timeline, however, the audio continues from the place where it left off when I jumped to the lightbox page. I tried a play audio when timeline starts trigger but that didn't work.

Also, if I go to the next page, then go back to the previous page (where I originally left it to go to a lightbox) the audio doesn't start at the beginning. The audio begins at the point where it stopped when I jumped to the lightbox.

I would appreciate help on this. Thanks.

Ashley Terwilliger-Pollard

Hi Jane,

I looked at Marcus's case, and it seemed a number of the audio issues were do to the HTML5.

Jonathan was able to fix the file and also shared:

"There are many issues involving media like audio and video in HTML5 most probably because of the limitations in HTML5 but most of them were improved in the coming updates."

Since you're having the additional problem with the lightbox as well, would you be able to share your .story file with our Support team so that they can help you out? 

Markus Olsson

Sorry for not replying earlier. Regarding the audio: it seems like the issues we had were related to two things.

1) Audio that were controlled by a trigger, for example "start audio when a certain variable is true". For some reason this lead to many weird issues where the conditional statement was simply ignored. We had audio from slide #30 that were played on slide #1 just because the conditional statement from slide #30 was ignored.

2) We also had issues with overlapping audio on slides with multiple layers. When I removed the layers and just made multiple slides instead, the issues went away.

In the end, I decided it was just too much work to do anything about it at the moment. It seems like the next update for Storyline (Update 4) which Jonathan showed me, will handle audio better. Since it was just a beta I didn't want to use it in a production environment yet. I hope the wait won't be long before it's released though.

Carol Widstrand

Hi,

Seeking solutions to have media stop triggers to work on layers from the iPad. 

Base layer has audio file, and so does each layer. I put a trigger on the base to stop media when XXX layer is accessed. Also, put a trigger on each layer to stop media when user clicks outside.

Audio behaves correctly on the PC, but the iPad is not recognizing the layer triggers. The audio plays over each other.

I have updated to the most recent Storyline 2 Update 12:1705.520.  iPad is running iOS 10.

Any help or advice is most appreciated!

Carol

Alyssa Gomez

Hi Carol, sorry for the trouble! I haven't seen reports of this, so I'd be interested in taking a closer look at your file. Could you share it with me here?

In the meantime, have you tried using the "pause timeline of base layer" setting, along with "hide other slide layers"?  Hopefully you can remove the stop media triggers with those layer settings. 

Carol Widstrand

Hello Alyssa and Ali,

Thank you for looking at this.  There are two slides (3. Objectives and 4. Landmarks) with a base layer (with audio) and the subsequent layers (with audio.) I did try the pause audio but not hide other layers (would like have all the layers visible.

Both work as intended on the PC, but when viewed on the iPad (thru Safari), the landmark slide is not stopping audio when other terms are selected. Hence the 'overlapping of audio'.

Is there a private server I upload this file to?

Best,
Carol