State Animations don't appear to Work in SL2

Unless I'm doing something wrong ... I'm unable to add an animation to an object's new state using SL2. This was a basic function in SL1. When you edit the state and go to add an animation, the animation options are grayed out and unclickable.

Does anyone have a workaround for this or am I doing it wrong? Thanks

13 Replies
Andy Learning Specialist

Say I want a tab to slide out onto the page when hovered over. I'm trying to do a workaround by setting up a trigger to move the tab along a path when the mouse is hovered over, which appears like it could do the same thing as animating a state but it doesn't seem to function correctly upon the mouse leaving.

Ashley Terwilliger

Hi Walter, 

I see what you're saying in regards to SL1 not greying out those options - but I don't seem to be able to apply an animation to a state in SL1? Within SL2 - I can set up a trigger for a motion path though - which would allow for the animation you're discussing in terms of a tab hovering out and moving further onto the screen. 

Andy Learning Specialist

"- but I don't seem to be able to apply an animation to a state in SL1? "

You can apply animations to states in SL1. Jerson Campos had a big post about it awhile back. SL2 seems to have downgraded that feature though.

"Within SL2 - I can set up a trigger for a motion path though"

Yeah, that's what I discussed in my second post. That's the only workaround that seems close although for some reason the 'Restore on mouse leave' option isn't working very well and I have not  gotten it to work all the way yet.

So, I went back to the drawing board and this time, instead of applying an animation to the new state, I copied a shape that already had an animation and pasted it into the new state and it retained the animation. Which is good and usable. Just wish there wasn't that extra step.

Andy Learning Specialist

Wow, strange. I opened a brand new SL2 project and tried it out and everything worked exactly as I wanted it to and like it did in SL1.

However, the original file I was using still does not allow me to add the animation to the state. I think it might have something to do with the fact that it has an uploaded PowerPoint file in it. That's the only difference I can see between the two projects. And I wasn't trying to change the state on any of the PowerPoint's original objects; I was adding brand new objects and trying to add the animation to the state.

So still not sure why that happens but I'm OK with it as long as it's only for projects with imported PP files in them as I usually don't work with those.

Char Larkin

Before I decide to send anything, can someone answer my question? In SL2, can states be animated? When I add a state, my animation features are greyed out. I tried reading a previous thread on this and I don't think it was directly ever answered - there was just information about "work-arounds" --

Thank you,

Terra

Char Larkin

I see what you have done. Your new state included changing out an image and then applying an animation to it, worked just fine.

What I am not able to do is to keep the same shape (or image) but then my new State will change this shape to a new color when the timeline reaches a certain point. When the new color appears, I want it to Fade to the new color. The new State set up does not allow me to select the Fade animation as it is greyed out.

Yes, I was able to "work around" with an extra step by duplicating the shape, on the base layer and then adding my animation this way.

But my original question was asking why I can't apply an animation in a new state in the way I was attempting. It seems that it would be a logical thing to do.

Thank you,

Terra