Stop slides from advancing automatically

I want all my slides to advance if the user clicks "next". So I changed the settings in the Player Trigger in all slides accordingly ("jump to next slide when user clicks next button"). Also, in the slide properties it says "slide advances --> by user" (pls see screenshots below). But still, the slides keep advancing automatically in my preview.

Does anyone have an advice, where I can correct this?

41 Replies
Ashley Terwilliger

Hi Julia and welcome to Heroes!

Thanks for sharing the images here and those are definitely the two places you want to check into. Is every slide advancing automatically or just same slides? I would suggest double checking all of those items and if there are any other triggers that could be interfering with the "next" trigger as triggers are executed in the order described here and therefore another trigger could be interfering with the next trigger when the user clicks.

If you're still having difficulty, can you share the .story file here with us so that we can take a look?

Paula Hays

I'm suddenly having a similar problem, after doing the update that came out today... I have a slide where it won't process any new advancement triggers, no matter how many times I set them. When the Next button is clicked it's going to the next Slide, rather than to the next layer (despite what the trigger says to do) -- and then the next slides are suddenly advancing automatically, skipping over all the layers, when it's previewed, even though they were all previously set to advance when user clicks.

Could this be an update glitch?

Ashley Terwilliger

Hi Paula and welcome to Heroes!

I haven't seen the behavior myself yet, and I didn't see a case yet for Julia. Do you have a sample file you could share here with us?

Also, it may be worth conducting the repair in the event that it was an installation issue. And as a reminder you'll always want to be sure you're following along with the guidelines here for working on local project files.

Stephen Cubbon

I am having this same issue. I cannot find a way around it. The attached demo was created originally as a 'Try' Screen Recording.

Note that slide 1 is a screenshot I manually inserted, and manually added the green double-click hotspot, and this is working. ie: The slide does not advance until the double-click is done.

However, the second and third slides were a 'Try' screen recording, and it definitely is advancing from slide 2 to slide 3 without any reason that I can find. I deleted the automatic hotspot that Articulate inserted, and replaced it with a hotspot of my own, but it's still not stopping on slide 2.

Any ideas?

Note that I've created many of these in the past and never had this issue. Then I went a while without using Articulate, and now it's not working.

Steve C

Here is an older one I did the exact same way with the same method -- (1) Record Screen Actions (2) Set triggers to Advance by User; Jump to next slide when Media Completes; and Play Media when User Clicks hotspot --- it works as expected.

Am I doing this wrong? Is there another way to get the desired effect?

My older files I created with this method don't auto-advance. The new file is auto-advancing.

Storyline Demo

 

Steve C

Thanks for asking --

Interestingly, the original demo I uploaded still is not working and I cannot get it to work as expected.

However, to prove the point, I had created a new blank presentation, recorded a new Screen Recording, and also set it up as a "Try" mode simulation, and what do you know -- the new one is working and stopping on each slide.

The original issue may have had something to do with me opening an old file and working with it to create a new lesson, rather than starting a new document from scratch.

Ashley Terwilliger

Hi Stephen, 

Hm, if the new one is working than I'd have to agree that the original file may have had an issue already associated with it. You'll want to confirm that you're following along with the steps here in terms of working locally. 

I'm glad the new file works though - and hopefully you'll be able to continue using that going forward! 

Steve C

Addendum: I think I understand the problem people are having when they report this issue (Can't stop slides from advancing).

If I screen record a software program, going step by step through it, and insert it into a new project as a "Try" simulation -- it does not work. It does not stop, but continues like watching a movie.

Even if I set the slides to "advance by user", even if I assure you there is nothing on my master slide, and even if I set the triggers to "Stop Playing screen recording when timeline starts" and a trigger of "play screen recording when user clicks hotspot" and "Jump to next slide when media completes" -- it still doesn't work, it advances without waiting for the user to click anything.

HOWEVER...

If I instead insert the screen recording as a 'Test' scene rather than as a 'Try' scene, then magically everything works as expected. It stops and waits on each slide for the user to click the hotspot. Then I set the trigger for that hotspot to play the media, and then advance to next slide when media is complete. 

I don't know why the "Try" mode doesn't work. But it's not. However using "Test" mode does work exactly as expected. However, then I have to go through each slide, delete the "Right" and "Wrong" layers, and remove the scoring, and add in the custom triggers. More work, but it does work. 

Hope this makes sense for anyone else who runs into the same issue.

Ashley Terwilliger

HI Stephen,

Thanks for sharing here - the "test" scene is waiting for the user to answer to grade them based on that, whereas the "try" scene is just giving them the opportunity to try their hand at answering. That may be the difference you're experiencing? 

I'm glad you found a method that'll work for you. 

Steve C

Perhaps I misunderstand the meaning of 'Try' mode. It is not allowing the user to 'try' anything at all. It's playing like a video, even though there are many separate slides, each with hotspots and triggers that are supposed to wait for the user to do something, and even though each slide is set to advance 'by User'.

Or perhaps my installation has a glitch?

Chris Smit

Hi All, Hi Ashley,

We are working with SL1 and are having the same problem.

Not just in try mode, but also in test mode. We work locally all of the time, but do store our files on a network drive. So we do copy the files often.

Is this issue something you guys have solved already?

Does the repair/clean up file work for SL1 as well?

Kind regards,

Chris

Ashley Terwilliger

Hi Chris, 

You can still go through the import process for SL1 described here or conduct the repair - and that's a repair of the software, not an individual file. 

Saving it on the network drive as a back up should be ok, but you'd want to make sure that when you're working on the project file on your local drive it's not associated with the network drive version (doing a save as or disconnecting from the network are good ways to ensure that). 

If you're still having difficulty, could you share a sample .story file here with us and we're happy to take a look. 

Ashley Terwilliger

Hi Suzanne,

In addition to your triggers did you check your slide properties to ensure that they're not set to automatically advance either? You can read more about slide properties here and you'll want to set it to "advance by user". 

If you've checked into that and are still having difficulty we'll want to take a look at your .story file as Wendy mentioned. You can upload it here using the 'add attachment' button at the bottom of the reply window. 

Suzanne Timmerhans

Thanks for the follow-up, but when I went back to check I found that the individual slide setting was for automatic for some of the slides -duh. Since I corrected that – they are working as expected.

Suzanne Timmerhans
Suzanne Timmerhans, Associate Executive Director for Management Services
InterAgency Council of Developmental Disabilities, Inc. (IAC)

Suzanne Timmerhans

It was the slide properties - reset them and all is A-OK. Thanks for the follow-up

Suzanne Timmerhans
Suzanne Timmerhans
Associate Executive Director for Management Services
InterAgency Council of Developmental Disabilities, Inc.
150 West 30th Street, 15th floor
New York, New York 10001
Phone: 212.645.6360, ext. 207
Fax: 212.627.8847
Email: Suzanne@iacny.org