Stop slides from advancing automatically

I want all my slides to advance if the user clicks "next". So I changed the settings in the Player Trigger in all slides accordingly ("jump to next slide when user clicks next button"). Also, in the slide properties it says "slide advances --> by user" (pls see screenshots below). But still, the slides keep advancing automatically in my preview.

Does anyone have an advice, where I can correct this?

49 Replies
Walt Hamilton

Kim,

None of the triggers associated with built-in state advance slides. The triggers are just what the names suggest. For example, the trigger associated with the hover state is "change state to hover when the mouse hovers over". Visited is "Change state to visited when user clicks." If you want the visited to jump to a slide, you have to supply the trigger to do it. Built-in triggers only change states.

Copying items (like templates) can bring triggers along, and there are a couple of settings (clearly explored in this thread) that can cause slide jumps. Even if you copied an object that has a jump trigger, that trigger will be listed with the triggers, and not attached to a state.

Katie Riggio

Welcome to eLearning Heroes, Helene!

This discussion is a bit older, so Suzanne may no longer be subscribed. Feel free to reach out to folks directly using the Contact Me link on their profile pages. Let's see if I can help before your presentation! 

If a few slides auto-advance even though there's a trigger set to jump to the next slide when the user clicks Next in place, let's check the affected slides' properties.

When on a troublesome slide, click the gear icon in the lower right corner of the Slide Layers panel, or right-click the slide and choose Properties. Is the Slide advances: property set to Automatically or By user?

Sonya Lowson

HI,

I am having the same problem re: slides auto-advancing even though the trigger is set to jump to next slide when user clicks Button.  I'm wondering if there is a fix to resolve this. 

I set up  my triggers to advance when user clicks next, and changed slide properties to "Slide advances by User".  This didn't work, so I added a button and changed each trigger to advance when user clicked individual buttons.  However when I preview the slide it auto advances and doesn't change the state of the character.

Lauren Connelly

Hi Sonya!

Let's see what's going on. By chance, have you imported slides from Presenter or PowerPoint? When you import slides from PowerPoint, Storyline will respect the advance behavior from Articulate Presenter.

If not, I also saw your navigation settings are set to "Jump to Previous Slide when the User Clicks the previous button or swipes the previous button". If you uncheck "swipe next/previous" in the slide properties, are you still seeing the slide auto advance? 

Lastly, have you considered adding a trigger to pause the timeline when a user clicks an object? 

I'm more than happy to take a look at your file. You can do so by using the "add attachment" button in this discussion. Or you can share the file privately with our Support Engineers by using this link.

Sonya Lowson

HI Lauren,

Thank you so much for your reply.  I had imported slides from PowerPoint.  I started again without these slides, adding the images from PowerPoint I needed.  That seems to have nailed the issue. 

I thought it would be something simple I did, causing the issue, but couldn't figure it out. 

 

Cheers

 

Sarah Bezanson

Hi Articulate team,

I'm having a similar problem with a .story file that was originally created as an animated PPT deck and has been adapted to Storyline. Slides are advancing by user click for all of the scenes except one. From what I can see, I have the same slide settings for each but one scene is not cooperating and is auto-advancing. I don't see any triggers indicating to advance automatically when the timeline ends. Any tips on where to look to have this scene behave like the others?

Thanks!

Wendy Farmer

Hi Sarah

normally slides imported from PPT always advance automatically and the slide properties need to be changed to by user.

Sounds like you may have already checked that but if you want to double check and do a multi change you can do in Story View.  Click the first slide of the scene you are having trouble with, then Ctrl A to select all in that scene and change the slide property from whatever it is to something else then to 'by user'.

 

Monic Verdugo

I am having the same issue the only thing that seems to fix it is if I insert a new slide copy and paste my timeline to the new one. Problem solved. :) If there is a better way? Will they be fixing this issue? It seems that the power point has is inbreeded,  please let me know as I am getting questioned on my work as If I am taking too long. Thank you for your time. 

Lauren Connelly

Hi Monic!

I'm happy to help!

Have you tried changing the Slide Advances setting to "By User?"

Here's how to change this setting for all the slides in your project:

1. In Story View, select the first slide.

2. Hold on your keyboard and click the last slide. Now all slides should be selected.

3. Over to the bottom right, you should see the Slide Properties. Make sure it's set to By User.

 

Lastly, preview the course to make sure the slides aren't advancing automatically. If they are, would you mind sharing your file with us? You can either attach it to this discussion using the Add Attachment button, or you can share it privately by using this private upload link. 

Vincent Scoma

Hi Monic,

Thank you for sharing those details! 

When importing slides from PowerPoint, Storyline will carryover the advance behavior from the PowerPoint presentation. Unless otherwise specified in the PowerPoint file, the default behavior when importing the presentation may have been set to advance automatically.

If those settings are in place for learners to advance slides, but the slides continue to auto-advance, would you be able to share your file for further troubleshooting? You can share files in this thread here, or you're always welcome to share it privately using this link here. We'll let you know our findings and will delete it after having a closer look.

Mira Gomez

Hi all,

One of my colleagues has this problem today. We found the issue  - when we looked at the slide properties while it was open in a scene, it had the correct setting of 'User clicks' but when we looked at that same slide in 'Story view', it was set to 'Advance automatically'! We amended the settings in story view and the problem was fixed. Not sure why the slide properties for the same slide were different in different views.

Suzanne Timmerhans

Thanks so much for the feedback. I will try your solution today!

Get Outlook for iOS

Disclaimer

The information contained in this communication from the sender is confidential. It is intended solely for use by the recipient and others authorized to receive it. If you are not the recipient, you are hereby notified that any disclosure, copying, distribution or taking action in relation of the contents of this information is strictly prohibited and may be unlawful.

This email has been scanned for viruses and malware, and may have been automatically archived by Mimecast Ltd, an innovator in Software as a Service (SaaS) for business. Providing a safer and more useful place for your human generated data. Specializing in; Security, archiving and compliance. To find out more visit the Mimecast website.

Christopher Friedl

I am trying to create an adaptive learning course using the points method for advancement.  I am using a pick one quiz and behind the scenes is a results slide.  In order for points to accumulate I must use Submit Interaction.  Unfortunately, this auto advances the slide to the next slide and does not show my custom feedback slides.  

I think I found one way to bypass this issue.  If you notice slide 1.3 (my first pick one quiz slide) has variables listed within each slide layer.  No matter what the learner chooses for the first question they will automatically be sent to scene 4.1.   When I click on one of the 3 buttons on the base layer (best, second best, or worst answer)  it does not automatically send me to the next slide because there is no next slide due to me linking the feedback slides to the next scene.  This seems to stop the submit interaction from automatically advancing.  

Is there a trigger, variable, or condition that I could insert that would allow the submit interaction to still count the points but shut off the auto jump to next slide feature?  This would allow me to keep a few quiz slides within the same scene instead of having to create a new scene for every question.  

If not,  at least I may have found a way to bypass the auto advance feature and still be able to keep my custom feedback slides and point based advancement scenario.  

I have attached my raw file to show what I have been working on.  

Walt Hamilton

Unfortunately, this auto advances the slide to the next slide and does not show my custom feedback slides.

To avoid the auto advance, you need to use the built-in feedback layers. To use them, click on MORE... and give each choice some text.

 

That will create a feedback layer for each option.  Then on the layers that are created, drag everything you can off the stage, so it doesn't show on the layer. In the attached sample, look at slide 1.3. I took your original feedback slides (XXX Response ORI), copied everything on them, and pasted it to the built-in Feedback slides. Then you can set the Continue button to jump to the next slide (1.4). Be sure that the trigger refers to your Continue button, and not the original.

Christopher Friedl

Thank you Walt, that is a very simple fix for my future projects.  I did not even think to add text to that field.  I am guess the math behind the scenes is automatically set up to prompt built in feedback but will not recognize a custom feedback slide.  

I will make sure to do this for future slides as it simplifies things.