Story.html not switching to the html5 version

When we publish a course in HTML5 only and run the story.html file, it doesn't load in IE11. we get a blank screen.

When we publish in HTML5 with Flash fallback and load in IE11, it loads the Flash version.

I tried deleting the story. html file, then renaming the story_html5.html to story.html, and the course still won't run in IE11.

The courses run in chrome, but when put in SCORM and run through an LMS, they don't pass the completion trigger to the LMS, so users can't sign off.

Is there a problem with the coding of the story.html file that won't allow the HTML5 to run in IE11?

If I run the story_HTML5.html file from either IE11 or Chrome, the course runs fine.

3 Replies
Lauren Connelly

Hi Bernard!

I'm happy to help! It sounds like you're only seeing this error with the completion trigger in IE11. 

Do you mind answering these questions to get us started?

  • Which version of Storyline are you using? Storyline 360, Storyline 3, etc
  • Which Learning Management System are you using?

I'd like to take a look at your file and see if there is something specific affecting the completion trigger in IE11. Here's a secure upload link for you to share your file. You can also attach it to this discussion using the Add Attachment button.

Bernard Maxfield

Hi Lauren. Thanks for responding

We are using SL3 update 6.

The problem is not just the trigger. There are several issues I believe.

When a course is published in Html5 only, and you run story.html, it's giving a blank screen and not switching to story_html5.html.

The LMS we are using is called ISOtrain. They claim the problem is not with their system. But it does run the story_lms.html file, but it's not switching to the HTML5 file, but neither does IE11.

When we publish a course as SCORM 1.2 in flash->html5, it plays in Flash for IE, but gives a blank screen in Chrome. IE11 will allow the completion trigger to mark the course complete.

When we publish a course as SCORM1.2 in html5->Flash, or just html, it does not work in IE11. It does work in Chrome, but will not pass the completion trigger to the LMS.

I tried to delete the story_lms.html, then renamed story_lms_html5.html to story_lms.html, thinking that might work but still got the blank screen.

I've uploaded a simple module that I run outside the LMS using story_html5.html and published in html5 only. it's not a SCORM course. I don't have a SCORM course that I'm authorized to upload to you.

On a  side note, we do have Edge, but I haven't tried that yet.

 

Vincent Scoma

Hi Bernard,

Thank you for sharing those details! It looks like you have done quite a bit of testing here. 

I did want to share that when testing the files locally, you can run into issues around security restrictions from the computer, web browser, Flash Player, and network, which will cause various features of the course to fail. When testing the published content, it is best to upload it to the environment for which it was published. You can find more details about this here: 

I appreciate you sharing your .story file with us! I published the course for LMS and uploaded the course to SCORM Cloud, an LMS testing environment, to see if I could recreate the issue. Here are the publishing settings I used: 

I tested the course in IE 11 and Google Chrome, but I was not able to recreate the blank screen issue you are experiencing. Could I have you test the published output of the course as well using this link: 

Please let us know if you run into any issues when testing that link!