Storyline 2 corrupted files

Hi there,

I had to revisit a module from a couple of months ago to adjust something for a client. It was just a small publishing adjustment (changing completion requirements from 77/77 slides to 65/77 slides to account for wrong answer screens)

When I try to publish it though, I'm always met with an error report. My coworkers tried to publish on their machines and it comes up with the same. That was fine, errors happen, but when I opened up a different version of the same project, the same thing happened. Even when I opened up an old version of it and tried to publish, it would be the same. I'm also met with those storyline big X error visuals on some of the screens. I've used these files previously and this had never occurred, it's bizarre that it's affecting all of the files somehow. Does anyone have any experience with this?

 

25 Replies
Veronica Budnikas

Hi Tyson,

The sort of error you're describing could be caused by a number of things. I experiences this recently with some SL2, and after much to and fro and a lot of help from support, we still couldn't figure out what was happening.

Long story short, I eventually figure out it was due to a couple of fonts that had been installed incorrectly (or rather, I had installed them from my Nexus Font Manager instead of in the traditional way). Once I re-installed the fonts, all was well. 

It may not be at all what is happening at your end, but it's pretty easy to check that on the off chance it's the same issue.

If not, perhaps reach out to support: https://articulate.com/support/contact/case 

It would be great to post back here if you find a solution for other folks to benefit too :) 

Good luck! 

Ali Goulet

So glad that re-installing solved this for you, Vikas! Thanks so much for popping in here to share that.

I also wanted to point you toward this article for some great tips on avoiding file corruption in the future. It's definitely a handy one to keep bookmarked if you weren't aware of it! ☺️

IMC Learning

Hi guys,

Still having trouble publishing and getting those large Xs on the screen when I click on text. I tried re-installing the program, and the fonts, but no successes yet. Any other ideas? I'll try reinstalling the fonts again, because I do feel like that may be the issue or at least part of it

IMC Learning

I'm starting to think it's not a font issue, as I reinstalled the fonts and checked it out, then checked the fonts again and was met with the same big X. But when I select the text box, rather than the text, I could change the font. I changed it to a different font, and the same red X happened when I clicked on the text inside the box. It feels like a big bug, but the thing is, it's occurring in all past versions of the project as well, which doesn't make sense to me. What do you guys think?

Veronica Budnikas

hey Tyson, 

that’s really weird. When I was having my issue, before I discovered what it was, it would also occasionally ‘fix itself’ after a restart. It was really quite random, but when I fixed up the font issue there was never a problem again.

I’d say maybe submit a support case.

Wendy Farmer

Hi Tyson

I’ve had it a couple of times - one was a corrupt image. I could add another images and replace the corrupt one but every time I tried to insert this specific image I got the red x.

Other time I had too many other apps open and every slide in my project had a red x. Closed Storyline, closed everything. Rebooted and opened the file and it was fine - all objects appeared.

Ashley Terwilliger

Hi Tyson,

I saw your support case, and I'm sorry there has been a delay in responding. This week our team has been playing a bit of catch up post-Thanksgiving holiday. They'll be in touch as soon as possible to offer any other ideas and advice on your project file.

In the meantime, some general steps that I always recommend when coming across "odd" behavior are to first check that you're following along with the guidelines here for working on project files. Next, look at going through the repair steps of Storyline. 

IMC Learning

Hi Wendy and Ashley,

I've reinstalled storyline using the repair steps like you suggested, and closed down almost all other programs running so that it would run optimally, but unfortunately, I'm still met with the same issue. I double checked with an older version in case this truly is just a corrupted file, but the same thing is still happening. 

Thank you for all the support here though, and look forward to the response to the support case :) I'm still happy to try anything to get this project published!

IMC Learning

Hi guys,

Success! Renato published out the course with the correct font with no problems. Still unsure as to the issue we were experiencing, but perhaps if we can get the Storyline file that Renato used as well, the file could work on our computers too.

Thank you for all of your help! This has been a bizarre issue, but it's resolved! 

Indrani Sen

Hello,

I have a fairly large course, and was in the process of 'publishing' this course. However every time I try to PUBLISH it, I get an error message. I don't think I have ever encountered this message before.  Attached please find the error report.

It was working fine till yesterday. All I did differently this time was reorganized the slides into separate scenes and then collapsed all for easier organization.

Just to let you know that I did open a support ticket.  My case # is : 01425110.

However you guys are so awesome, that I could not resist posting my question here.

 

Please could you let me know what I am doing wrong. 

Many thanks,
Indrani

 

Leslie McKerchie

Hi Indrani,

So sorry to hear that you're running into difficulty publishing your file. Thanks for letting us know that you reached out to the support team.

I took a look and it looks like Renson is doing some testing and digging in to try to understand what may be happening. Thanks for continuing to work with him and ask your follow up questions :)

Indrani Sen

Yes, Renson is super helpful. However I posted in the community to see if anyone had similar problems as me.

Uninstalling, reinstalling the software, creating a new project, rendering the project is a lesson on patience and mindfulness 😊 I am hopeful that there will be a solution.

Thanks
Indrani