Storyline 2 - playing video clips on Android tablet

Hi, I'm testing Storyline 2 today prior to purchasing an upgrade. I was very happy to see Android support at last and my tests of html5 SCORM content on an Android tablet were going well.

However I can't get video clips to play on an Android device. The same clips are playing through PCs and iPads.

I have tried auto play, manual play, importing source as different formats i.e. flv and mp4, seek bar on and off etc.

Has anyone managed to get video to play on an Android devices if published through Storyline 2?

Regards

Trevor

7 Replies
Trevor White-Miller

Hi Emily,

I'm testing on two different Android tablets. One is running 4.1.2, the other is running 4.2.2.

As per the recommendation for Android I'm only using Chrome browser 37.0.2062.117 (latest I can download).

I have checked the tablets can play mp4 video clips by accessing the same video clips directly from my web server and both tablets play the clips without any issues. I have also accessed an mp4 reference site with mp4 video clips made with different encoders, bit rates, settings etc and my tablets can play them all.

So it appears to me to be a Storyline issue.

Trevor

Trevor White-Miller

Hi Emily, another update:

I have been doing some more testing this morning and I appear to have found aspecific setup where the video will not play on an Android device which is LMSrelated.

Test that worked:

I made a story project with my video clip imported as MP4 and did not compress.I published to the web (not LMS), uploaded and played via story.html. This timethe video played on PC, iPad and Android. So all was working, although itappears to be a good idea not to recompress an MP4 video (the original MP4 wasa very good compression anyway).

Test that did not work:

I published the same project as LMS SCORM including the HTML5 option but notthe AMP. That was uploaded to the LMS which is Totara 2.5 (a variant ofMoodle). On the PC and iPad the video plays OK. However this time on an Androiddevice the video will not play.

SoI have to conclude that the issue is LMS related. I'll contact the LMS supportteam and have them look into the issue.

Regards

Trevor