Storyline 2 published content and Edge

Hi Heroes, hope anyone will have an idea to help me!!

I have a directory with different Articulate courses in it. 
I created different html-files to start the single courses.
The html-files are working correct with different browser, but I can not start the courses with MS Edge. Yes I can start the course with Edge if I start it from the course directory with the original story.html, but not with my html-file outside the course.

Anyone who could help me? Please see enclosed my html-file

3 Replies
Ali Goulet

Hey there Karin!

Thanks so much for reaching out here! Are you accessing that directory of published courses from a local location right on your computer? If so, when you open an Articulate Storyline course from your local hard drive, you may encounter security restrictions from the computer, web browser, Flash Player, and network that'll cause various features of your content to fail. To properly test your published content and share it with others, make sure to upload the entire published output to the environment for which it was published. For instance, if you were to Publish for Web you'll want to upload the entire published output to a web environment, such as tempshare, to properly view or test it.

I'm not quite sure what you mean about creating different html-files to start the courses, but I also wanted to mention that making changes to the published output isn't something we can support. You'll need to have access to the full published output in order to ensure the course plays properly in it's intended environment.

If you want to be able to access the course directly from your computer without having to upload it anywhere, you'll need to use the Publish for CD option then double click the Launch_Story.exe to view the course. 

Hope that helps clarify a little, please let me know if I've misunderstood at all or if you have any further questions! 

Karin Amann

Hi Ali, thanks for your reply. Maybe my description was not ok. I will send you a zip-file enclosed.
Normally there are a lot of courses. In my example I have only 1 course.

If I go in the directory IT4IT/1_Course/1_Slides/Intro I can start the course with the story.html in all browsers - also in Edge (no flash player problem)

If I use the Start_Slides_Intro.html in the root-directory I can start the course in all browsers but not in Edge.

Any idea? Thanks for your help!

 

Ali Goulet

Hey Karin,

Thanks for the additional details here! The zip that you provided looks to include other items along with the actual published output which appears to be a custom setup that we wouldn't be able to provide support for. If you're publishing the course for the web, you'll want to make sure to upload the entire published output as is to a web environment in order to ensure proper playback, otherwise you run the risk of encountering undesired behavior such as what you're experiencing.