Storyline 2 - System Training - Creating variable to assess 2 methods

Back story- I am creating system training (for SAP), and within the training there are two methods that the user needs to learn, try and be tested on.  I am having issues in the assessment area.  Instead of trying the variables in the actual project, I created a test storyline file to test out the layout, variables and triggers I want to apply to the assessment, but I'm running into some problems.

I want both to be scored separately, and then either use an end slide to record the completion of of the course or set a variable to show both were passed. I created a hotspot question slide for4 steps of each method.

I want to user to have 2 attempts at each step (1 point for correct selection, -1 if they choose incorrectly), and want them to have to get each step correct or be sent back to start over.  In this test I used 75% as a passing rate (plan to use 90% in final). I only created 4 questions for each method (I call them routes in the test file). I'm going to use a missed questions variable to help them gauge if they need to go back to the training at any point (which would reset both assessments).

When I go through as the learner in preview mode (haven't published and tested), I run into the following problems:

When I start with Route 1, get question 1, 2 right on first try and then get qu 3 and 4, wrong on first attempt and right on second (to bring up my retake layer). I retake and test at 100% missing nothing which launches a layer to proceed to route 2. I treat route 2 the same get 1 and 2 correct on first try then get qu 3 and 4 wrong on first attempt and right on second to prompt the retake layer.  When it goes back to the beginning of route 2 to retake, I am unable to select the hotspot and retake the quiz. ( tried just taking and retaking route 2 on it's own and had no problems, I think it's somehow tied to route 1).

When I start with Route 2, get question 1, 2 right on first try and then get qu 3 and 4, wrong on first attempt and right on second (to bring up my retake layer). I retake and test at 100% missing nothing which launches a layer to proceed to route 1. When I get to the first question I'm getting the missed questions layer I created for when they've missed more than 1 question (to pass a 4 step quiz at 75% can only miss one). It's a different variable, so I don't understand why it's showing that there are 2 missed questions and why this layer would be showing.

So these problems are making me think twice about how I score the assessment. Any help would be appreciated.

8 Replies
M. W.

Here's an update on what I've discovered so far. I removed the triggers (submit results and reset) for Results slides 1.8 and 1.13, which seems to have resolved the issue going from Route 1 and not being able to retake Route 2. I am able to select the hotspot and continue. When I passed the wrong layer appears (it seems to be thinking Route 1 has been reset or doesn't have a score above 75%). So I'm not sure what's going on here, and if it's related to the 2nd issue (also discussed below). It seems to correlate with the screen I'm receiving in the problem mentioned below. Just not sure why, because the variables are different.

Screenshot after completing Route 1 and 2 - Showing Wrong Layer (Review - begin other) It should be showing Review-both complete

Route2 completed Not able to begin Route 1

I am still having problems with the missed layer appearing when starting route 1 after completing route 2. (second problem listed above). It thinks 2 questions were missed (in Route 2 there were, but then it was reset and none were missed - those are also different variables). **Update 2/27/15 - I've found that it's only if you miss one or both of the last two questions in Route 2. Variables seem fine, so not sure what the problem is.

Screenshot after completing Route 2 and trying to begin Route 1 - Showing Wrong Layer (Sorry you were unable to answer in 2 attempts) it shouldn't be showing any layers because all layers are responses to the learners selection.

WrongLayer_afterbothroutescompleted

I've checked all the variables for both Route 1 and 2 and they seem to be correct, so I don't know what is causing it to think Route 1 has not been completed in one instance and completed in the second.

 

M. W.

Hi Chris! Thanks for taking the time to look at my mock-up!  Thanks for catch the retry button issue!!!! After correcting, I was still having an issue with the missed questions reached layer appearing, this time on retake of 2, and then I realized the variables on slide 1.13, retake layer, were the variable for Route 1 and not Route 2.  I think that solved the original problem!!!! So glad the error you found led me to the correction of the other problem.

In regards to the Slide 1.9 Retry button, I probably should have all of the Retake layer buttons jump back to 1.9 instead of 1.2. Originally I had directed them to go back to the the Quiz Start in case they wanted to go back to the training, but later I added the additional button (home) on the retake layer to take care of that. So thanks for that catch!

I'm going to test all the variations out, but it looks like right now, I don't have any issues!!! WOO HOO, thanks again for  your help. Now to apply this concept to 80+ slides and not miss something. I'm going to use this as the model, so hopefully won't be an issue.

MW

Chris Cole

Good morning MW. Glad you got it figured out.

That's a nice logic pattern you worked out for the project. When I was troubleshooting, I created text fields to show all of your variables and put them in a group on your Slide Master so I could see everything that was happening on each slide as I ran through the file - a home-rolled debugger so to speak. Helped me see how your logic flowed and where the issue might be. Since they were in a group, I could easily hide the group to run through it "cleanly."

Good luck with the rest of your project.

Chris