Storyline 2 - text with Fade out doesn't display on slide replay

I have a simple text box that I've added a fade out Exit Animation to so I can show other content in its place.

However, if the slide plays as normal and the text has faded out, and I hit the replay button, the text does not display again until it gets back to its exit animation - then it displays and fades out right away. It's like it stays faded out. If I drag the seekbar back to the beginning, I get the same result. I can no longer get the textbox to display for the whole period it is normally on-screen and this is a bit of a dealbreaker.

Is there a reason this is occurring?

EDIT: I've done some further testing, and the issue does not seem to occur if you have an entrance animation on the same object. But without one, I'm getting the problem consistently.

6 Replies
Stacy Morse

Hi Keith,

I discovered the same problem today in my project.  It is incredibly frustrating and I hope that Articulate fixes it soon.  In the meantime, however, I have figured out a workaround that might be helpful to you.

I noticed that the problem was only occurring on text boxes that were not in groups.  I have other text boxes on other slides that are grouped with one or more corresponding images/shapes/etc., all of which fade out at the same time.  After some experimentation, I have found that doing the following will get the text to appear properly when the slide is replayed.

1. Un-apply the fade out animation to the text box in question.

2. Create a shape (I used a rectangle, but I assume any shape would work) and place it off the slide so it won't appear in your project.

3.  Time the shape to end at the same point on the timeline as your text box.

4.  Select the text box and the shape, right click and choose "Group" to combine the two into a single group.

5. Apply the fade out animation to the group (make sure you have the overall group selected, not single elements within it).

Although not an ideal solution, it worked for me.  Hope it's helpful to others who encounter this issue.

Stacy