14 Replies
Mike Enders

Victoria,

I believe the no compression options relies upon the video having been encoded into mp4 via the H.264 codec.

Do you know how the mp4 video was encoded?  If not h.264, then Storyline will still need to convert the .mp4 into .mp4 with the h.264 codec and hence, the no compression option.  

For the no compression option to be visible, your source video will need to be mp4 videos encoded with the h.264 codec.

Mike

Victoria Nap

Hi Mike,

Sorry I did not reply sooner. I forgot to subscribe to the thread. I think I've found the problem. Rather than deleting the video and adding a new one, I was using the "Change Video" feature in the edit video menu. Since the original file did not have the option of whether or not to compress, that setting held over. I originally started this project in SL1, so I think the automatic compression carried over. When I delete the video are add a new one, I'm able to control the compression.

Thanks for your help!

Eric Brennan-Hazell

Hi, I have been battling with this issue for over a year now. We currently use Active Presenter to record software simulation, export them as .mp4 videos and then (on the advice of a number of people on here) run them through Handbrake. We also make sure the h.264 profile is set as High. 90% of the time this allows us to change the compression option to none. However, inconsistently and randomly this stays grayed out for other 10%! This is happening within the same project. We have around 14 scenes with a video at the end of each one. Following the same steps to produce, save, export and 'handbrake' the videos we come up against this issue.

 

Having looked through the forums this seems to be an issue for a number of people and has been for some time. Can Articulate give us some reassurance/comfort that this will be looked at in Storyline 3? It would be great it WE could decide if video is compressed or not, without having to jump through various hoops and use 3rd party software just to get good quality videos.

Thanks

Donna Baumgart

Hi -

I had the same issue. I created file in SL1, but wanted to try to take advantage of the compression feature in SL2 to improve video quality. When I opened the file in SL2, the Compression option was grayed out. I tried several of the options explained here and other places, including the one that required painstakingly replacing the videos in the output file. (Who wants to do that each time you publish??) That method worked, but the simplest was to rename the videos I would be using and reinserting them as new. I created a new folder, appended 'copy' to the name of each of the videos, deleted the old videos, and added the renamed videos. The Compression option was now available and I could set it to None. I did not need to mess with the encoding or anything! Worked fine and videos are super clear when posting to SharePoint. I have not tried in the LMS yet.

Ina Draijer

Just experienced the same problem but found a workaround.

I recorded several small videos with Replay and wanted to insert them into SL360. I wanted to set the video compression to "none" - however, I could only do that for the first video. Deleting the other videos and inserting them with a different name didn't work.

I figured my problem was somehow connected to Replay. Initially, I made a new Replay project für every video I recorded. But since I was only able to use non-compression for my first recording, I opened that replay file and recorded my videos in that file. Now it works perfectly fine.

Kinda strange, considering I didn't change any settings in Replay (just hit "start new project") several times and recorded them all in a row).

Ina Draijer

Hi Ashley,

thanks for the offer, but since I made it work, there's no need for the Support Staff to check it out.

On another note, I wanted to send you the .replay files. I just checked them again (you know, just in case) - and it works now. Crazy stuff.
I didn't change anything within the .replay or .storyline, so maybe the difference was in re-starting the application.

Katie Riggio

Hi, Ina. Appreciate your update!

While I'm glad to hear you're up and running, that behavior should not have happened. I may recommend doing a simple Replay 360 repair (and even one for Storyline 360) to be safe! 

If you run into this problem again while building out your course, please let us know!