Storyline 2: Where's the setting to prevent video compression?

The "What's New" list for SL2 says I can keep videos from being compressed during publishing. But I don't see how. The Publish Quality window looks the same as in SL1, with the Video Quality slider only going to "9"/"higher quality." 

So where can I set it to HIGHEST quality, i.e., don't compress it?

48 Replies
Ashley Terwilliger-Pollard

Hi Cassidy, 

You could always use a tool like Handbrake to convert or check the codec and MP4 settings.  I'm not a video expert by any means, but whenever I have an issue with an MP4 I run it through Handbrake and it'll work normally again. 

Hopefully others with more video expertise will be able to chime in here! 

Rick Brinkman

My videos are exported from Final Cut Pro X into Compressor and the settings are very clear.

Format is MP4 and profile is baseline. I have not edited them in Storyline2 but the "compression none" is grayed out. 

If I re-encode the video in Handbrake and bring that into Storyline2 the "None" option becomes available. 

I have 49 videos. Final Cut Pro X and Compressor are professional tools. I hope you pursue what the problem is and solve it.

 

Julius Koester

Sorry but i have exactly the same problem. i  encodet 4 videofiles with the 100% identical h.264 settings. 3 of them didn't have problem with the compression dropdown menue. i dont want to encode this videos again in the publishing process. is there any chance to force the "2nd compression" to  bypass. this is a very uncomfortably bug in storyline.  I think it will be helpfully with a tiny checkbox in the publish function to disable videoencoding. Im old enough to do that :) .I also have 232 Videofiles and my project deadline is in one week.

Julius Koester

Hi Ashley,

thank you verry much for your fast support :)

meanwhile the same video on the same slide chages randomly the "disablety" to bypass the Compression. I'm sure that all my videosetting are correct and im sure that the algorithm that check the videofile is a bit broken. Maybe you can tell me how that algorothm works, that would maybe help me to understand how i can fix this problem or you can give me a tip how i can bypass the 2nd encoding with e.g. manipulating a registry file or some kind of DIY fixing.

Ashley Terwilliger-Pollard

Hi Julius,

The algorithm is a proprietary code to compress the video files or to allow them to not be compressed based on those settings. 

Prior to the option for disable the compression I know that an unsupported option, and I've seen this work with mixed results, would be to replace the videos in the published output with your higher-quality versions and our file names.

But please keep in mind, that's not something that is supported in any way by Articulate. 

 

Julius Koester

Hi Ashley,

thx for the tipp with replacing the files. finaly i find my mistake which disabled me the function to bypass the compression. I scaled the videos down a bit (28px in high) to have some place for the player controls. this trigged the compression. Now i change my videoresolution to crop these 28 px and have a resolution of 1920x1052 instead of 1920x1080. Furthermore my settings in Adobe Premiere are

Profil: Baseline

Level: 4,0

and i chose a vbr of 2Mbit/s and max 3 MBit/s and also a Keyframe(distance i think) of 24

aac audio with 44100 Hz Stereo with a bitrate of 128 KBit/s with an MP4 Multiplexer and the standard streamcompatibility.

 

in my case, these settings worked really well in Storyline.

I hope that this information will help.

Julius Koester

Hi,

sorry I was looking forward to early. :(

the problem is back, and I do not know why. I attached you an videofile of the problem (this was also exported with the same settings as i used for my storryline project, and its the german trenslated version of storryline but the steps are the same as in the english version i guess)

at first i load the videofile into the storyline, sometimes it works somtime the problem is in the first load in (change compression from automaticly to none). ok in this case it works perfectly. but if i wanna change the videofile (maybe the cutter make some changes and i need to repleace the video file) ok next i repleace it with the exactly same video file and now i can't change the the compression settings. next i delete it from the slide and load the same file again into it. now i can't change the settings. i try it ten times but this option will never come back. the only thing i can make is restart storyline and hopefully it work at first try. other i need torestart it for the 2nd time and so on. but i don't want to do this.

Julius Koester
Laith Salama

I wish I had some help other than close SL every time and re-open it and insert a video as new. I found I had to insert it absolutely fresh, new triggers and all.

 

Thanks Liath,

I've found an solution that works, but i can't use this in my specific case, cause it gives user the chance to easily download the videofiles. Im not shure that this solution works on all platforms and in the swf version. I didn't have access to the server that will host this project or the videos. Also it can't automaticly go to the next slide if the video ends. But otherwise it's a good solution for some Projects.

 here the "solution"

 You can insert a video as a web-object with the url of the video (you need the full absolute paths cause relative paths like ../folder/video.mp4 didn't work). This will use the internal HTML5 videoplayer of the browser und you also have a fullscreen button in the playercontrollers. You can also overlay some buttons in sl.

 But i think Articulate need to fix this problem!

Ashley Terwilliger-Pollard

Hi Julius,

If you're making changes to the video and then replacing it - it sounds like it may not be the same video file and could have changed the compression elements and profile? If you'd like us to take a look at a video to help confirm we can certainly do that! Just send a copy of the video along to our team here. 

Julius Koester

Hi Ashley,

In my example (bug_videocompression.mp4 ) I load a 100% Identical copy of the video file into Storyline just for testing. This triggered the error. I can reproduce this error anytime with all my videofiles. The encoding settings are allways the same. I created a encoding preset (.epr) for all the cutters on this project and checked these before rendering starts. The import works well sometimes (I have the option to select no compression) and broke after repleacing. Then i need to restart Storyline again. Im sure that is a Bug. I already send you a file that was encodet with these encoding presets. I'll send your team the video file and the .epr file that is an xml written text file of all my rendering settings.

Ashley Terwilliger-Pollard

Hi Marcos, 

Storyline will compress based on an algorithm we've created, to allow for the smallest possible file size at the best output/playback. So there isn't a compression rate to share, but that's why we added the option to allow for Compression to be set to "None" for the instances where you may want to use a particular setting. 

Leslie McKerchie

Hi Marcos,

I do not know the specifics of the compression.

Here's what we have:

We worked hard to optimize video compression in Articulate Storyline, so you'd get the highest possible quality at the lowest possible file size. We recommend using high quality videos and letting Storyline handle the compression. However, you can turn off compression for MP4 videos if you'd prefer.

Adjusting Video Compression

When you publish a course, your videos will be encoded so they're no larger than your slide size with a key frame every 5 seconds—unless you turn off video compression as described in the next section.

To adjust the compression Storyline uses for videos, just click the Quality property in the publishing wizard, then drag the Video quality slider to the right to increase the publish quality. (Note that higher quality values also result in larger file sizes, which could mean longer download times for learners with slow Internet connections.)

Turning Video Compression Off

You can turn off compression altogether for MP4 videos created with baseline, main, or high profiles. (All other videos will be compressed automatically.)

  1. Select the video placeholder and go to the Options tab on the Storyline ribbon.
  2. Click the Compression drop-down and choose None.

If you turn off video compression, be aware that your published files will be larger, which could be problematic for learners with slow Internet connections.

See also: