Storyline 3 Invalid Answer - You must complete the question before submitting

Storyline 3 Invalid Answer - You must complete the question before submitting

Hi everyone,
I'm writing because I'm experiencing a frightening issue with the passage from SL2 to SL3. The issue is frightening because it messes up a specific interactiont have I have used with many of the project I've created on SL2 and updated to SL3.

Unless I get to solve this issue, for me the passage SL2>SL3 means losing the possibility to change in any way all the projects created previously.

Knowing that sometimes this can happen, I've recreated the slide in a new story file. You'll find it attached to this thread, so you can try for yourselves.


The interaction I use is a Pick one Interaction with Pictures used as valid and invalid answer, like this:

I then proceed to create one new custom status for each of the pictures:
- for the correct picture I create a green/correct status named "Correct"
- for the incorrect picture I create a red/incorrect status named "Incorrect"

Then I add the triggers
- CORRECT PICTURE: The first trigger changes the status of the picture from Normal to Correct. A second trigger submits the interaction.
- INCORRECT PICTURE: The first trigger changes the status of the picture from Normal to Incorrect. A second trigger changes the status of the other picture from Normal to Correct. A third trigger submits the interaction.

In SL2 this worked as expected:
- if I clicked the correct answer, it changed to its green/correct state and I was shown the correct layer
- if I clicked the incorrect answer, it changed to its red/incorrect state and it changed the state of the other picture to green/correct, and I was shown the incorrect layer.

If preview (or export and try outside storyline) I get this error:

Does anybody else experience this problem? Or maybe you already solved it? :)
Thanks in advance,
Andrea

17 Replies
Leslie McKerchie

Hi Andrea - Thanks for sharing the file so that we could take a look.

In your file, slide 1.3 seemed really close to what I think you are asking, but the trigger order was out of place. The submission should be happening so that Storyline knows an answer was submitted.

Take a look at the attached and let me know if this is what you were after.

Alyssa Gomez

Hi Andrea!

Thanks for sharing your file with me! I believe slide 1.3 was the one giving your problems, correct?

I moved the "Submit interaction" trigger to the top of the list, and that seemed to fix the issue. Here's how slide 1.3 works now: 


I made that change to slide 1.3, so you can click here to download the updated file. Let me know if that will work for you!

Andrea Cagli

Hi Leslie and Alyssa,
thank you both very much for your clear answer, and for how quick you have replied!

Honestly, I didn't try this solution before posting because I assumed that placing the Submit trigger at the top of the list would force SL to jump to the feedback layers right after the click on, and not enforcing the other state change triggers.

Thank you very very much! Now I just have to tell my boss that this problem was solved with just one click.. He'll kill me! :)

Andrea

Andrea Cagli

Hi,
sorry, I'm back with another question. :)

I started from the fixed version and tried adding a text to the cards. I grouped the text and the image and updated the triggers and the Form View according to the change. Then I preview and click one of the answers, and I get the error message. If I click ok on the error and, without quitting the preview, I try once more the interaction works as supposed to.

The same happens if the text is a part of the state and not a group with the image.

I've attached the modified story so you can take a look if want.

Andrea

Alyssa Gomez

Hey Andrea!

You had a great idea to add the text box to the states on slide 1.3! The only thing slide 1.3 was missing was a "selected" state. Even though you never actually see the selected state when you preview the slide, you still need it for the interaction to work correctly.

Take a look at the changes I made to slide 1.3--I hope that will work for you!

Uttam Biswas

Yes, Wendy thank you so much for your help. I have already fixed this issue and removed this part. I just jumped to the result slide from the exit merge slide and solved the problem. But right now, I can not open the story.html file in Google Chrome, it shows loading icon only. Looks like below image:

Caught an programming error like below:

There is no such issue with Firefox browser, only problem with latest Chrome and IE

It will be really helpful if you please provide a suggestion regarding this.

 

Attachment is the latest file

Wendy Farmer

So the file you uploaded is not the latest file? I'm using SL360 so I may not get the same results as you - I just took a look to see if I could see what was causing the Invalid answer message. 

Perhaps someone using SL3 can chime in to help you and maybe you can upload the latest file without the FITB slides that were throwing the error message.