Storyline 3 Roboto font issues

Good morning! 

I am working in Storyline 3 and using Google Font Roboto. It looks fine while editing but when I preview or publish, any font that is Roboto italics is rending gibberish (see attached). Any advice on how to resolve this? This is happening in any of my files where  I have italicized Roboto. 

Thanks in advance! 

Kate

 

14 Replies
Carol Dungan Logie

This is an issue me for me now after reinstalling Storyline today .... I've been using Roboto without issue for months and now today it is garbled in preview but fine in the slide file. I tried turning modern text off and on, and it doesn't make a difference.

Why is this happening all of a sudden? Using the same version of SL360 that I was yesterday.

Leslie McKerchie

Hi Carol,

Thanks for reaching out and letting us know that you're running into an issue previewing your course.

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Zachary Guidry

I am having the same problem in a Storyline 360 course. Today (Sept 24th) I opened a course created on August 27, 2019 and when I preview, any Roboto Light type set to Italic is gibberish. What can I do? Related question, are fonts embedded in the course - does the end user need to have the font installed?

Articulate One

I'm having a similar problem with Roboto. Certain combinations of  letters are producing weird symbols when published on Review 360. A few of the problem ones are:

's (like if I use it in DON'T)

fi (Like if I use it in the word FIND)

... (any 3 consecutive dots turn into a weird symbol)

and more.

Please see attached.

I downloaded the fonts from Google fonts. And I've checked, Use Modern Text is definitely on. And I do not have copies of the same font. 

Hope someone can help :)

Lauren Connelly

Hi!

I'm sorry you're running into this issue. It sounds like you've tried the steps listed in this discussion. Are you running into this issue when publishing for the web?

I'd like to enlist our Support Engineers' help so we can look at additional steps to understand why the Roboto font is displayed incorrectly in Review 360. Please use this link to connect with a Support Engineer.

Zachary Guidry

I don't know the answer exactly, but this may point you in the right direction. All 3 of these characters are special character types. If you are pasting in text from Word or some other app, you may be pasting in some special characters that Roboto doesn't have.

Try pasting you text into a simple text editor like "Notepad" (for Windows). Then, copy your text out of Notepad and paste it into Storyline. That will convert those special characters back to more standard text. (Or, you can delete the text out of Storyline and manually type it back in.)

I'm not sure about the apostrophe, but combination characters like "fi" is called a ligature. Some word processors will replace the "Fi" with the special character that is a combination of the 2. https://en.wikipedia.org/wiki/Orthographic_ligature The 3 dots is called an ellipsis and that is also a single special character that replaced the 3 separate periods.

Articulate One

Thanks so much for your help! I'm happy to say that I've solved the problem by doing the following:

1) Click Start and search for "Font Settings"

2) Open Font Settings, find and click the font "Roboto"

3) Scroll down and click "Uninstall"

4) Restart your computer

5) With Storyline still closed, reinstall the font and re-test

This seems to have solved my issue. Hope it helps someone else too :)