Storyline 360 Courses Not Loading in IE

Nothing I create in Storyline 360 will load in IE.  I only get a blank screen when launching from my LMS.   After 2 weeks of research, my IT group discovered that the index_lms_flash.html file does not contain this line of code (<meta http-equiv="x-ua-compatible" content="IE=edge" />  ).  Once this code is added to the file, the course works perfectly in IE. 

Can you help me understand if we are not publishing correctly?  Or if there is a way to have this line of code inserted in the html file?

22 Replies
Alyssa Gomez

Sorry this is giving you grief, Lori! We're seeing this, too. We have confirmed that this is a bug with Storyline 360 Update 3.7.12674.0, specifically that content does not play in IE11 when compatibility mode is enabled.  Although this is not a longterm solution, I would recommend disabling compatibility mode for the content to play. Adding the line of code to the index_lms.html file is another temporary solution. 

Our team is working hard on a fix for this, and I'll tag this thread to be updated as soon as the fix is released!

Elizabeth McCroskey

One thing you might try while Articulate is working on this is to add line of code to the HTML template here.

C:\Program Files (x86)\Articulate\360\Storyline\Content\index_lms_flash.html.

Add it right after the <head> tag and save.

<!DOCTYPE html>
<html lang="__LANGUAGE__">
<head>
<meta http-equiv="X-UA-Compatible" content="IE=edge"/>
<meta charset="UTF-8">
<title>__TITLE__</title>

Every time you publish from Storyline, it will pick up the change in your published files.

You might want to back up the original index_lms_flash.html just to be safe.

Ashley Terwilliger

Hi Lori, 

Great news!  Another update for Articulate 360 is now available.  It includes a few important fixes and new features that you'll see in the release notes here.  

The item you may be interested in is how it fixes an issue where Flash output wouldn't play in Internet Explorer with Compatibility View enabled.

Launch the Articulate 360 desktop app on your computer and click the Update button for each application. Details here.

Please let us know if you have any questions, either here or by reaching out to our Support Engineers directly.

Alyssa Gomez

Hi Sandra,

I can see that you’re still struggling with your course loading in Internet Explorer since you reached out here and in this other discussion. I’d love to help.  I reached out to Vic to let him know you're still hitting a roadblock and to reopen your case. You should hear back from him soon!

John Cooper

Hi

I have a client with exactly the same problem. A course I wrote some time ago for them has just been converted to Articulate 360 and translated into Chinese - but it won't run under their LMS if they use Internet Explorer - works fine if they launch using FireFox.

I was following the various threads about the Compatibility View mode problem - I have confirmed with the client that, if they disable compatibility view mode in IE, the course loads fine. I checked the  index_lms_flash.html file and sure enough it has the lines:

<meta http-equiv="x-ua-compatible" content="IE=edge" />

<meta charset="UTF-8">

right there after the <title>. The code was compiled under Version 3.9.13567.0

As they are in the middle of a big roll-out of this course and another I'm converting, I'm under a bit of pressure here and need a fix quite quickly. Any suggestions???

Sandra Lowe

Unfortunately, those options didn't resolve the issue for us. We are still gathering information and going back and forth with our internal IT dept and with our LMS vendor.

Sandra Lowe
eLearning Specialist
314-694-8413

Do you speak another language?
Spanish, Portuguese, French, Dutch, Korean, Russian, Ukrainian, Turkish, Romanian, Italian, Polish, Hungarian, Chinese, Thai, Vietnamese, Indonesian, Hebrew...and more are needed. Ask me how you can help our global colleagues learn or visit our TeamSite<https://monsanto365.sharepoint.com/teams/Translations/

John Cooper

Is there any further news on this issue? Our client has got to the stage where they can run courses if the user disables compatibility view mode in IE - BUT they are not happy. They would like a cleaner solution.

Their IT team is still looking at it to see if they can modify the LMS in some way - but so far, they haven't solved it.

They are at the point where they are asking if they should switch to another authoring tool. That would be a shame - we are still an Adobe shop, but haven't used Captivate since Storyline first came out - which was quite some time ago!

The frustrating thing is that we all know Microsoft will drop IE at some point in favour of Edge but for large corporates switching their default browser is still a big deal.

Sandra Lowe

Not that I'm aware of.  We have reverted to Storyline 2 until an answer is found.  Courses launch in Chrome but our company's default is still IE so we have to publish directions to guide users to manually launch in Chrome.  This is cumbersome for an employee base of 20k.  Our next step at this point is meeting with our LMS and our internal IT to see if there's anything we can do.

It's still frustrating because we will have had Articulate 360 for a year in Feb.  We will probably receive renewal notices for a product that we have simply been unable to use.  If we are unable to resolve the issue, we may not renew the subscription.

Sandra Lowe

I even tested in Storyline3 to the same result.  There is something different between SL2 and SL3 and 360.  Nothing has changed in our LMS.  Nothing has changed in our IT structure.  I have attempted all of the fixes offered by Articulate but they simply won't launch in IE.  We will wait for either further fixes to the Articulate products or if we have any major changes in our internal browser preferences.  I have been told that we may be changing the default to Chrome but we don't know when that is scheduled.  But even then, we prefer courses to function in both browsers.

John Cooper

Hi Leslie,

We believe we are using the latest updates to Storyline 360 (V3.10.13923.0) and have confirmed that the code:

<meta http-equiv="x-ua-compatible" content="IE=edge" />
<meta charset="UTF-8">
right there after the <title>.

Is present in the index_lms_flash.html file

Yet the course still fails to load under Internet Explorer 11 unless compatibility view mode is disabled. We will try Sandra's suggestion below.

John Cooper

Sandra - many thanks indeed!!!

By publishing using Flash with HTML5 fallback, my client is able to load the courses successfully from their LMS using Internet Explorer with compatibility view enabled (which they require for other legacy software). Phew!! It was a close run thing, they were on the point of kicking out Storyline altogether - and they are a very big company worldwide!

But, I'm not resting on my laurels. I'm kind of hoping that Microsoft finally retires Internet Explorer before Adobe retires Flash - it could be a close run thing. We are still an Adobe shop as well as Articulate (which is our default) - I'll be honest - we have been experimenting to see how best to migrate Storyline to Captivate. I know that sounds like treachery here - but when your business depends on it, it's kind of critical!!