Storyline 360 says Open Sans (Body) is Missing

With the last update to Storyline 360 last week, when I open the course I have been working on, it now tells me that Open Sans (Body) font is missing. Open Sans is the selected font for both body and headings in the Master slide. I am running Parallels and verified that Open Sans is indeed installed in Windows 10. I repaired Storyline 360 (uninstalled and re-installed) and even re-installed the font, but the problem persists. Interestingly, the Open Sans (Body and Headings) font is still in use and able to be selected within the course. The message isn't a big deal but I was curious why it appears?

15 Replies
Ashley Terwilliger

Hi Lu,

That message would appear when the font wasn't installed to let you know that some things may be off in the .story file. I wonder if we could get a look at the .story file and give it a test ourselves? 

You can upload it using the “ADD ATTACHMENT” button at the bottom of the reply window. If you’d prefer to not share in the public forums you’re always welcome to share with our Support Engineers here. They’re available 24/7 to assist! 

Ashley Terwilliger

Thanks Nicola. I saw the same error message opening your file but when I tried in a new file (showing my font as "Open Sans (Body)" ) that opened in SL360 and SL3 without the error message. 

I also tried creating it in SL2 and then upgrading it to Storyline 360, and no error message.

Did you create this file in SL360 or an earlier version of Storyline? 

Ashley Terwilliger

Hi Nicola and Lu,

Thanks for the additional information. I tested your file again this morning, Nicola, and upon opening it a second time I didn't see the missing font prompt. Both times, I saw the same that Lu did where the font appeared fine in the course for editing, preview and publish - so the error message although troublesome is incorrect. 

I'm going to share this with the team as a possible software bug. It's a hard to reproduce on a new file - so if you see steps that consistently cause this for you, please let me know! Here's more information on how we identify and tackle bugs.

I’ll let you know as soon as we have an update on this issue. Sorry if it's slowing you down and please keep me posted if it causes any other interference. 

Lu Post

Thanks so much, Ashley,

Even though I continue to get the message of the missing Open Sans font when opening my course, after publishing, it has worked just fine. I'll certainly let you know if we see this again. Thank you for the follow-up. Interestingly, we've had many courses that have used this font and were updated from SL2 to 360 and we only had this one course with this issue. However, we do have a development team that shares files, so that may have caused an issue.

Best,
Lu

Lu Post

Yes, I believe we do follow these steps. We store our course folder on our hosting server and when an update is needed, the entire folder is downloaded to the developer's local drive and saved there. Then, when the updates are completed, the old folder is deleted from the server and the new folder is loaded. We don't typically zip the files.

Alyssa Gomez

Great news!  Another update for Articulate 360 is now available.  It includes a few important fixes and new features that you'll see in the release notes here.  

The item you may be interested in is a fix for Storyline detecting missing fonts when opening a project file, even though the fonts were installed on the computer.

Launch the Articulate 360 desktop app on your computer and click the Update button for each application. Details here.

Please let us know if you have any questions, either here or by reaching out to our Support Engineers directly. 

Ian Farwell

After updating SL 360 to v3.14.15225.0 (affectionately referred to as version "pi"), it appears this bug has reared it's ugly head again.  Although I have Sherman Sans and Sherman Serif fonts installed, I receive an error message when I open project files that use these two fonts.  

A workaround is utilizing the replace fonts feature, but I would rather not have to do that, because there seems to be some re-formatting involved when utilizing this method.

I was wondering if anyone on Staff has heard of this popping up again or if anyone in the community has encountered this since updating to the latest version of SL 360?

Thanks,
Ian

Ashley Terwilliger

Hi Ian,

I haven't heard of the issue reoccurring, and when it was happening the fonts were installed and correctly showing in Storyline, but Storyline wasn't recognizing that and showing the "Missing fonts" message. In your image, is that the Sherman font?

If that's not the Sherman font in your image, I'd also look that these fonts are installed correctly in your local Windows font directory. You could try reinstalling them as well to make sure Storyline can recognize them. 

Ian Farwell

When I opened the file I received the missing fonts error and SL chose a replacement font, which is what you are seeing in Image 02.  You will also notice in Image 02 that I circled the font selector dropdown, which shows that Sherman is selected even though that is not what is being displayed on stage.  So what I did was globally replaced the font with Sherman.

However, when I did that, some of the copy looks terrible within SL; it's blurry, has fuzzy outlines, and does not look clean and clear.  When I publish or preview the file it cleans up a bit but I am also seeing that it is not displaying correctly at all.  See the attached image of what it looks like when I publish or preview.

I will do some more investigating -- any further guidance is much appreciated.

Ashley Terwilliger

Hi Ian,

Thanks for confirming, I wasn't sure what the Sherman font was supposed to look like, so it was hard for me to know.

That image you shared is definitely concerning. Do you see that when uploading the course to your server or LMS, or when testing it locally? If you're able to share the font files and your .story with me, I can also take a look at what happens when I install them and publish your course.