Storyline 360: Spinning Cursor Error

I've run into this issue a couple of times and I'm curious to see if any other Storyline 360 users are running into it. When I preview or publish a course, some slides display a spinning cursor, which disables the user from clicking anywhere in the presentation. Spinning Cursor - Screenshot

I've found that it's typically the slide before the one displaying in the preview or published file that is causing the error. I've sent previous errors to Articulate support and the answer was that the slide somehow became corrupt, with no notation whatsoever.

Is anyone else running into this? If so, do you have a better workaround than the suggested "from scratch" approach?

35 Replies
Soren J Birch

Yes, I have struggled a lot with that since upgrading from Storyline 2 to Storyline 3.  The projects I preview will just show the circle of loading forever. Or publish. Sometimes I can get it to publish in Flash, but not with HTML5.

I have had multiple cases opened with Support, and in my experience it boils down to, that the importer feature of Storyline 3 is, shall we say, less than robust.  So first, did you import this project, or slides from a previous project or a PowerPoint? Then you might use the below steps to troubleshoot.

Projects that work PERFECT in Storyline 2 or Presenter '13 suddenly behaves odd and I have at least two identified, reproducable scenarios where importing stuff will break your course - but without throwing an error. It might be what happens to you.

Case 1: Invalid characters in Accessability field

Accessability text includes escape characters such as \\ and / or $ - this leads to The Circle Of Loading Forever.

For reasons I cannot explain PowerPoint adds the path name to an image if it is inserted from a network drive. Sometimes. It could be like \\$S\hello\filename.png. 

This string of text breaks Storyline 360. The only way to find it is to right click all images on the slide that gives you problems and see if any text is written in the Accessibility section.

Make sure to check your Master Slides too. If this happens on ALL slides you use, it might be the master slide logo or something.

Case 2: Grouped objects with triggers 

When you import from a slide where groups of mixed objects (picture and text) have animations and triggers assigned to the group, this will often break Storyline 3. Again, no errors are thrown during importing so you are unaware of this problem until you try to preview or publish.

Solution here is to ungroup everything on your affected slide and rewrite your triggers.

I have asked support to file with QA as bugs, but I am not sure if that has happened or not. Still not fixed at least.

Soren J Birch

Hi Ashley, thank you.

The cases I had opened and closed again on importing issues are:

01046881

01044713

01034800

01025036

In those cases I shared the .story files with the support engineers, so they could diagnose and troubleshoot. Very helpful guys.

I just updated to yesterday's new build of Storyline 360. Update notes does not mention this specifically.

Ashley Terwilliger

Thanks Soren - I was able to find all your cases, and I updated Cleo as he was working on the most recent case with you.

He'll be able to double check the issues described in the others and see if there are any overlaps. 

I do see that your case with Abel, # 01044713, was something he reported to our team as a possible software bug. The issue noted is that you were seeing an infinite loop of the "slide target is not available" message while previewing when grouping together objects and data entry fields.

We'll keep you posted once we've discussed the issue with our team!

Jia Lin Lee

Hello,

Im experiencing the same error where the cursor remains spinning and the user is unable to interact with the slide. However, I realized this only happens in HTML5 export or preview (for me at least).

Is there anyway to solve this error other than to switch to FLASH, or has it been determined as a bug? My file is rather heavy and FLASH lags my motion path animations, I would want to avoid publishing in FLASH if possible.

Ashley Terwilliger

Hi Jia,

What is on that particular slide? Are you only seeing it in preview or have you tested the published output as well?  The issue that we were seeing with Soren was only in the preview of the course - so if yours is happening in publish too we'd want to take a look!

Can you upload a copy of your .story file here for me? 

Jia Lin Lee

Hi,

That slide is a freeform drag and drop and is pretty graphic heavy, it can go over 5MB. The spinning cursor appears in both HTML5 with FLASH backup and the Preview, rendering the user from interacting with anything on it.

If I exported it in FLASH with HTML5 backup, the motion path animation on the animation slide lags and it wouldn't look as smooth.

I've submitted a support case, 01108346, with the .story attached to it.

Hope this can be solved! 

Don Adams

Spinning cursor problem with Firefox 55.0.02(64 bit).  I have brought seven Storyline 1 files, ranging in size of 10 - 23 MB, into Storyline 3, and published them for the web.  The images were brought in through "new slide" "import" "import storyline". No problem with Safari, Microsoft Edge, a stutter then OK with Google Chrome, but a problem with FireFox. After uploading the published files to a web server, each one of them when run, yields a spinning wheel.  If I close any file out after a time or immediately, and reopen it, it runs perfectly. After once running the file and coming back later, the same scenario occurs. You may see this at my site (www.tabanat.com).  Browser settings are set to display at user's current browser size, lock player at optimal size, launch player in new window, allow user to resize browser.