Storyline course with video won't launch in iPad ios 10.2

Aug 30, 2017

Hi folks,

I have a course built in Storyline 2 that is in testing for HTML5 delivery from a website, no LMS involved. This is not working properly for iPad using ios 10.2. It is also not working as intended for iPhone 6 using ios 10.3.

The course includes a number of mp4 videos. Currently, each video is positioned on its own layer and set to play automatically. The learner clicks the image on the base layer to show the video layer. The layer appears and (presumably) plays the video. 

For the iPad, we are getting a Safari "address is invalid" error. Nothing loads or launches. I'm puzzled by this one.

For the iPhone, we are getting an error where the video layer appears, the first frame of the video appears, but then playback freezes. (The layer is triggered to Hide when the media completes, but the media can't complete, so the layer is stuck. The Next button is disabled until a SlideNComplete variable is equal to True, which is also set on media complete on the layer. Not the ideal arrangement, agreed.)

Other ios 10 posters have suggested setting up a trigger to play the media on start of timeline. At present, I don't actually have the original media files. (I inherited the project.) If "add a play on timeline start trigger" is the consensus recommendation, is it possible to use the mp4 media files from the /story_content folder, or do I have to get the client to find the original movie files?


22 Replies
Steve Semler

Hi Wendy,

Yes, I have the .story file. So, I would add the Play media on timeline start of the layer as the object, but it has to refer to the video from file to create that trigger, and I don't have the original video file. (However, I have not used this trigger type before, so I may not be understanding all the parameters!)

add media play trigger


Steve Semler

On the video layer timeline, the video is showing as one would expect it to (see image below). 

But, to cause it to play when the timeline starts, the trigger wizard (above) wants me to point to a "Video from file" for the Media parameter. I may be missing something you are thinking about, but I do not have the 2243_E_Learning_Intro_6.mp4 file from the client to point to with the wizard. I don't see a way to save the video from the .story project to a file, either. (But I do have a matching mp4 video in the existing output. Maybe I could use that? Do I need to use that to create the trigger? Am I understanding how the trigger wizard works for this purpose?)

video on timeline


Steve Semler

Hmm... I think I figured that out, but it is a funky way of doing it.

When I have that video layer open, the video object is the only thing on the layer. I add a trigger, select Action: Play Media, Media: Unassigned, When: Timeline starts, Object: [TitleOfLayer]. It allows me to click OK on that. Then, on the Triggers list, I can click Unassigned and edit the trigger to select the Video 1 object. (This is the part I did not know about, thanks!)

Then, I set the Video Options for the video object to Play Video: From trigger, instead of automatically.

I have no idea if this solves the ios 10 problem, but at least I've figured out how to set the triggers. Is there anything else I should be looking at to resolve the iPad and iPhone problems described above?

Steve Semler

Thank you, Wendy!

That did solve the iPhone video player problem. It had no effect on the iPad inability to launch issue, though (with Safari's "address is invalid" error). For some reason, it also added an issue with Windows 8.1 IE 11 and Mac running current version of Firefox. (No details from my QA person on those, yet.)

Any suggestions on how to get around this error on iPad?

ipad ios 10.2 launch error

These are the publishing settings I am using. Maybe this will help.

Storyline 2 course publishing settings


Steve Semler

The Articulate Media Player is available only from the Apple Store, correct? The client team reluctantly concluded that at this stage they would rather say it does not work than make users go to download and install an app. If there is a way around this where the user doesn't have to go off-site, I would love to know about it.

Sending you the link to the current course (without triggers) and test course (with your trigger suggestion). These are in different places.

Steve Semler

Hi Leslie,

Is it possible to have the course function on the iPad without the AMP
option checked? I have not tried that previously, because my other iPad
clients had already had a solid setup. This is going out to random
consumers whose configuration we cannot predict or support.

The file (including the sample file) has large 100 Mb mp4 videos, so I did
not want to attach those right away. I have a test course with just one
video, but it's still 105 MB. How can I best get that to you?

Wendy and I reached a point where Wendy wasn't sure why the course would
not launch on iPad from the client's website, so she suggested I submit a
ticket. (She was testing it with her iPad that presumably does have AMP

This is the course in the client website that is having the Safari iPad
launch problem:

Steve Semler

Very strange. I published without the AMP, and this worked for the things the client was able to test on at the time. However, this course is still giving the client a problem, but only when launching from their production site. I get different results from their production site (player loads, no content) and test sites (works as expected). I am thinking this is not a Storyline issue, at this point.

Here's the production URL:  http://www. story.html

And our test URL: http://mc-sandbox.s3- website-us-west-2.amazonaws. com/mos-elearning-test/story_ html5.html

The issue appears to stem from the player_compiled.js  at a function called Video.iOSPrepare line 630. 


I can provide the debug screens with the javascript error points, if this could be helpful.


Steve Semler
Leslie McKerchie

Hmm, that's the same output file? I'm seeing the same issue you are reporting with your links. Are you able to test via Tempshare as we did in the case? Or do you need me to take another look? Seems that it may be a server issue vs a Storyline issue.


Should I put in a fresh ticket on this?

Steve Semler

Thanks, Leslie. I've now verified with my sysadmin and SL technical expert that the problem behavior is out of the realm of Storyline functionality. No follow up needed on our part, thanks!

Updated Facts: The third-party hosting company has the course in a production environment using Salesforce's product. For some reason, this is causing Win7 Chrome, Mac Chrome, and Mac Safari browsers to load the course player frame, but not finish loading and launching the course. The same published course material works as expected on all browsers from the hosting company's AWS test server, SCORM Cloud, and from two other plain vanilla web test servers I've checked it on. In this particular situation, the error is stemming from: player_compiled.js at a function called Video.iOSPrepare line 630.

(Including this just in case someone else runs into the problem later and searches for info on the forums here.)

This discussion is closed. You can start a new discussion or contact Articulate Support.