Storyline Custom Quiz Error

Hey all, 

I'm new to storyline, and over the past few weeks have been getting to grips. It's very similar to ppt so I love it.

I've been making a custom quiz and have run into an error. When selecting an option then going to 'submit', it comes up saying "you must complete this question before submitting"... I'm baffled, because the option is selected and then submit is hit. The options selected are clearly in the form view for the question too. Weird. I've attached the file. Help would be great if you can tell me where I'm going wrong here!

4 Replies
Judy Nollet

Hi, John,

This has to do with using Groups. Yes, the objects within a Group change to their Selected states when the Group is clicked. However, the Group itself doesn't have a Selected state.

Thus, when you click Submit, the program is looking to see which of the items listed in Form View is Selected. And since the Groups listed don't have a Selected state, the program thinks the user hasn't answered the question. 

The fix: ungroup the objects, and only list objects in Form View. 

I'm guessing you're using 2 objects to get the look of the transparent outline and fill. You can adjust the transparency of an object's outline, as well as its thickness. So I suggest you try that so you only have 1 object per "response." And when those have Selected states, the program will recognize that one has been clicked. 

John Smith

Hey Judy, thanks for the help. I suspected the same, but if you check slide 1.3, I remade it with single objects instead and it still doesn't want to work! 

Attached another basic example with the single objects and it still doesn't work! Where am I going wrong here!?!?!?

Judy Nollet

Hi again, John,

I can't figure out what's wrong with your slide. It looks like it should work, but it doesn't. What's really weird is that a few times in Preview, clicking the Submit button would just advance to the next slide, without showing any feedback at all. Otherwise, it gave me the warning about needing to answer, even though I had.

FYI: I created a new pick-one in a copy of your file, and it works (see attached file). As Alice would say in Wonderland, "curiouser and curiouser"...

I suggest you submit a case to the helpful Articulate support staff. You can do that here: 

https://articulate.com/support/contact