Storyline NOT publishing properly

Here's the issue.

  • As I work, I save a version of Storyline 1-2 times per day (ie. say I am working on Project_version5.story, I first save Project_version5.story, then I do a Save As and name the file the next number in the sequence (Project_version5.story).   This saves me from losing work, should a problem occur.
  • Last Friday, I was working on a clients project, and I saved it in version 8.story.
  • Today I opened same project and first saved it as version 9.story. 
  • I worked on version 9.story all day, making doing several Saves etc.
  • After doing a lot of work and changes, I went to publish, to verify the content etc
  • I opened the published file (using IE10) the main screens appear, along with the menu, notes etc but there was NO content on the screen itself. 
  • I thought perhaps, there was some change with Security Settings on the Adobe Flash Player. Checked that, made some changes nothing.
  • Published content again, nothing. Same result.
  • Moved source file to my laptop, published again. Same result.
  • The content does not appear.

So, I went to Plan b.

  • I opened the last good version of the sources files (version8.story), opened it, published it, and voila, the content appears. No problem. OK, I did lose all the work I did today but I can see the content.

So, not certain where to go from here. This issue has never happened in the past. Only started after Updating Storyline last week. Have been using it extensively for the last several months and never had an issue.

Another thing that is happening.

  • When I publish, I now see a Launch button ( was never there before) when I view locally publishing content ( not LMS content).

Very concerned at this point, as I am in the middle of a major project for a client and if this happens again, I have delivery concerns. 

Would appreciate any help you can provide.

ps: I can upload both version 8 and version 9 source files if needed.

FYI: running Windows 7 Pro and current upgrade to Storyline.  All Windows files are up to date.

....Steve

25 Replies
Parashuram Vhaval

Well Mr. Steve I'm not sure my answer will defiantly solve your problem, some days ago I also faced some problems something close to one you shared here. That time I just reset my menu from the player options, screenshot and steps are provided below. Please check, hope that works for you also.

1. Go to home tab.

2. Click player button.

3. Click Menu button.

4. Click reset from story icon at the bottom.

Steve Chorny

I just tried resetting the menu. Unfortunately, it did not help.

Here's a screenshot after I published.  All pages are exactly the same.  The menu and the notes pages ( on the left) all contain the correct content.  Anything that displays on the main screen is blank.

At first I thought it was a Flash Security setting. Tried that and no luck.

Tech Support:

Interestingly, the previous version will publish correctly but not this version.   My concern is that this could happen again. 

...Steve

Peter Anderson

Hi Steve, 

It does sound like it may just be a local Flash security restriction preventing the content from displaying. When you test it, are you actually uploading it to its intended environment, or just testing locally

Try testing it in Tempshare and see if that helps. 

Otherwise, we'd be more than happy to have you send us the .story file(s) that is giving you trouble. 

Thanks, Steve

Steve Chorny

Testing locally on desktop. Same issue on my portable.

but.... It is only with one version of the program.  Previous version works ok.  I did check flash security settings and they appeer ok. 

Suggest you might want to look at source files. Will send you that when I get back to office later today.

...Steve

Erika Anderson

Hi, Leslie -
We have created a story file with 8 scenes. There are questions and knowledge checks in each scene, created using the question template for Multiple Choice graded. After publishing to SCORM 1.2, I have found errors in some of the feedback prose. I have attempted to change the feedback these questions several times. When I reopen the story file and go to the questions, I see the corrected feedback. When I republish and check and the old feedback is back. I have cleared cache, used 3 different browsers, had other people check on their machines, tried to republish, etc. The only way that we seem to be able to change the feedback is to create a new question and put the correct feedback in. We have had this happen to this project on several occasions. I have deleted and replaced and overwritten the feedback. But it still comes back when we republish. We can change or add answers, all works except changing feedback.
I am trying to replicate the error now and have not been able to yet, but we'll keep trying. Could there be a setting locking the questions from change? If so, can we change that setting?

Leslie McKerchie

Hi Erika,

That certainly does sound odd and the cache would have been my first guess if you were only seeing it once published. You can check out some troubleshooting here on that.

It looks like your email signature came through when you replied via email. You can remove that if needed by clicking ‘Edit’ beneath your response. Here’s a quick Peek video if you need help.

Bess Crawford

Hi! I am having the same problem. The course looks fine when publishing but once we load it to the LMS the screen is blank. Previous versions of this course worked fine. The only difference is I downloaded the latest update to Storyline 3 and am wondering if that is the contributing factor. We publish courses all the time, so our process has not changed. Do you have any suggestions? Thank you very much!

Katie Riggio

Really sorry you're seeing a blank screen, Bess! I'd love to help out. Are you able to share your .story file here or privately through this link? This is a perfect opportunity to do some digging into the file – I'd also like to see if I experience the blank screen when uploading the course to SCORM Cloud. I'll be standing by!

Janet Place

I have the same problem now. It is happening with any storyline 360 course, I try to publish. Just started about two weeks ago. I tried reinstalling but it did not help. I am trying to publish it for an LMS. I am getting the Launch button and then inaction. I have attached one I am currently working on.

Alyssa Gomez

Hi there Janet!

I published your file for LMS with SCORM 1.2 using Storyline 360. Then I uploaded the published output to SCORM Cloud, which is a handy tool we use for LMS testing.

Could you test this link to your content in SCORM Cloud and let me know if the content is working correctly for you? I'll be standing by!

Janet Place

Hi,

It worked, but it still asked me to launch the course. I don't mind that if the content opens correctly. Most of the time it doesn't. It is happening in some other courses too. I appreciate any insight. I have having some other weird glitches too. When I set up an interaction, the tabs do not show the content, even when it is clearly set right. For example, I set up a drag and drop interaction. When it was published only targets were there not the information. Is anyone else having this problem. It happened again in something I was creating yesterday.

Janet L. Place, MPH
Director of Workforce Development/Instructor
USC Arnold School of Public Health
915 Greene Street, #507
Columbia, SC 29208
(803) 777-8980

Alyssa Gomez

Hi Janet!

It sounds like you're seeing two different issues, so let's tackle these separately:

  1. Course launches in new window: The course is launching in a new window because of a setting you have enabled in the Player Properties window.
     
    If you would prefer courses to open in the same window, you'll want to disable this setting.
  2. Drag options disappear on Drag-and-Drop slides: This is actually a bug in Storyline 360, and we're hard at work on a solution. We're targeting to release a fix for this issue very soon. In the meantime, you can work around it by setting the "Shuffle" option to None.

Let me know if you have any other questions about that! By the way, you can edit out your contact information from your post if you'd like!  Replying via email will include your signature.

Nina Bacun

Hello all, I have same problem with publishing a course with Storyline 350.

When I go and check my slides with preview, slide works fine (and I can see all the changes I made, but when I publish the course, triggers don't work. So, I go back to my course but I cant find problem as everything works. So I don't touch anything but change colour of 1 idem on slide and when publish slide works but now slides that worked before don't work.

Also, there is extra question that appeared in my test that wasn't there before and I didn't touch the test at all as it was working ok before.

I lost 2 days on this issues that I don't know how to fix and my client is starting to get 'slightly mad cos I cant show him the course as it is bugged.

Any options? Anyone?

Alyssa Gomez

Hello, Nives! 

It sounds like you've run into all sorts of roadblocks, and I'm sure that's been frustrating! I'm happy to help.

First, let's be sure you're on the latest update of Storyline 360. To check, click the Help tab, then click About Storyline. You should see 3.19.16600.0 in the bottom-right corner. 

If you're already on the latest update and you're still getting stuck, share your file with us by clicking here, and let us know which slides are giving you trouble. We'll take a closer look!