Storyline not using Proxy settings

Mar 13, 2014

Hi all,

So my Storyline install can neither connect to the activation software, nor do anything online related.

First things first, I know you can go to to Storyline Options > Proxy Settings and choose to whether use IE proxy settings or input a proxy server.

I've tried both method and confirmed that Storyline is not using either option.

To confirm this, I used the two below methods:

Webmarshal monitoring - checking active sessions; none registering

Wireshark packet tracing

Lastly, I turned off the need to use a proxy server and connected directly to the internet, and Storyline finally had connectivity.


Is there a way, adding a parameter to the shortcut, or even registry hack where Storyline will actually use the proxy server?

3 Replies
Ashley Terwilliger-Pollard

Hi Jose and welcome to Heroes!

If you're unable to connect to the Articulate activation servers, you may need to allowlist this URL:
Standard ports 80 and 443 are required. These ports are open by default.  
In addition to changing the proxy options you'll want to check:
  • Ensure that you have an Internet connection. After re-establishing your Internet connection, press F5 to refresh the start screen, or close and reopen Storyline.
  • If your firewall is blocking access to the Storyline start page, ask your IT staff for assistance.
Jose Capco

Hi Ashley,

I think you did not understand my question.

I am the IT staff here, hence I have access to Webmarshal and other means.

Whitelisting is pointless because the actual Articulate Storyline software is not using the proxy settings from Internet Explorer, nor is it using the proxy settings you enter in the options menu.

I confirmed this by turning on webmarshal monitoring for my PC and did below tests:

1. Go to - checked and confirmed that this registered on webmarshal

2. Launched Storyline - nothing registering on webmarshal

3. tried to use online activation - nothing registering on webmarshal

Short story: even though there are settings for Proxy in Storyline, the software does not actual use it. You can only activate if you have a straight internet connection and this causes problems for corporate environments.

This discussion is closed. You can start a new discussion or contact Articulate Support.