Storyline Translation Export to Word Not Working

Hello,

I'm trying to use the Translation feature in Storyline 2 (exporting to Word file type), but it won't generate the file. My Storyline 2 version is fully up to date (update 6). Is there a step I'm missing? I reviewed the steps laid out in this tutorial - seems extremely simple but just not working for me. I'm using Windows 8.1, and MS Word 2013.

I've attached a picture to show how far my export gets before it stops - only clickable options are then OK, and cancel. It looks like the translation exported, but when I go to my export location there's no Word file (not an error file, nothing). The only export that seems to  generate a file is the XLIFF (and I don't know how to work with this).

Thank you for any suggestions you  can offer.

69 Replies
Stephanie Decret

Hello everyone,

I have also run into the translation export issue, and I have found a solution similar to Tobias's.

After reading many posts regarding this issue I made sure my file name was meeting the requirements, that I was running it from my local hard drive, etc.

However, I realised that although no Word documents were open prior to the export, the Word application was launched when starting the export through Articulate Storyline 2 menu. At one point, a message was popping, indicating that there were too many grammar mistakes to be displayed on the screen. Unfortunately, I could not see this pop up right away, as the Word pop up was underneath the Articulate Storyline / export window. Indeed, I had my Articulate Storyline window opened in full size and noticed it could not be resized during the export process.

I realized that if you left the pop up at the back of the screen until the end of the export process, somehow, there was no Word document created anywhere and the only solution was to manually crash the Word application, reopen it to have my latest documents "recovered" automatically => including the "failed" export.

Therefore, I have just tried the following :

- Resize my Articulate Storyline 2 window as small as possible, and move it down to a corner of the screen. That way, I can see most of my screen while I launch the process.

- Launch the Translation / Export process from Articulate Storyline, select a name and location for my .doc file

- Stand by my screen until the Word pop up about overwhelming grammar mistakes appear

- Click "ok" to have the pop up disappear

- When the Articulate export process finishes, Word is launched automatically with my export showing correctly.

I am aware it is quite a long post, I hope it makes sense and that it can save someone's hair from an awful fate. :-)

PS : I can also add that all my applications are in French, Word's language check is set to be French by default. However, my course in Articulate is in English. It must certainly increase the number of "grammar and spelling mistakes" found by Word during the export process, and hasten the moment the application is overwhelmed.

PPS : sorry for any grammar and spelling mistakes in the above post !

Ashley Terwilliger

Hi Stephanie,

Thanks for sharing the steps here and no worries on the long post! It's not something I've seen before, but a good reminder or element to check for. I'm going to share it with some of our other Support engineers so that they can share with other users experiencing a similar issue.

Thanks again for sharing it here and please let us know if we can assist with anything else. 

Robert Stewart

This just happened to me today using Windows 10.

My One Drive folder keep popping up. I opened CMD as Administrator typed.

taskkill /f /im OneDrive.exe

I saved the translation file in a folder that I know OneDrive did not use.

In my case: I think OneDrive keeps checking for new file changes and interferes with Storyline's translation and the word engine during the long translation file building by Storyline.

 

Kelley Conrad

I am having the same issue. The function was working a few weeks ago and now won't work on any of my files. I have submitted one of them to support. I'm running Storyline 2 Upton 7 on Windows 8. I'm running it locally and tried saving it in several different locations to not exceed the character count. I receive the empty error message box with no message and no Word document is created.

Ashley Terwilliger

Thanks Kelley and I see you're working with my colleague Cleo on this issue in your case (# 00689468 for my reference). We'll continue to keep an eye on this case so that we can update the forum thread, but I know we're looking for users who can consistently reproduce the issue so please continue to work with Cleo. 

Ashley Terwilliger

Hi Kelley,

I was just checking in and see that you're still working with Cleo. I was actually discussing this issue with our QA team yesterday afternoon as well, as we're continuing to look for some reproducible steps to help track down the problem. One of the QA leads suggested what may sound like a simple enough solution, but one I don't know that we mentioned in this thread - to shut down Storyline, Word and then do a reboot of your computer and then try going through the steps again to generate the Word document. 

Let Cleo or I know if you're able to go through those steps and if there is any change in behavior. 

Kelley Conrad

Hi Ashley,

Yes - I've tried that several times. I also followed the steps for when Storyline is acting erratically and uninstalled it, removed the registry files, and reinstalled it. I'm still having the same problem. I have tried to restore my PC to an earlier date when it was working, but that didn't solve the problem either. I have tried importing some screens into a new file with no luck. I tried some older files and was able to successfully export it once, but then couldn't do it a second time on the same file. For now, I've installed the trial version on a 2nd laptop, but I'll ultimately need to register it on both laptops if the problem cannot be resolved for it to work on my primary one.

I have sent Cleo the various logs that resulted based on the troubleshooting steps as well.

 

Thanks for the follow up!

Kelley 

Ashley Terwilliger

Thanks Kelley for confirming - I promised our team I would ask since I had explicitly yet. :-) 

You've definitely run through all of our normal troubleshooting steps, so continuing to work with Cleo to try and showcase how you replicate the problem will be the best course of action. In regards to installing it on your other laptop, your license allows for 2 installs such as a work and home computer - so feel free to activate the trial you downloaded for your laptop and continue working there too. 

I'll keep an eye on your case as well to see if Cleo is able to dig up anything else! 

Justyna Szluinska

I'm having the same problem and have tried all kinds of suggestions from the forums.  The problem happens only if using a file that was originally created using Storyline 1.  First, I have tried with the converted file, and it did not work at all.  Then, I set up a new file with a couple new slides and imported the slides from the converted file - I managed to get a "no column" translation, but it only worked once.  When I removed the imported slides and translated the remaining (new) slides, it worked perfectly (both with and without column).  I've also had no problems translating files that were build directly from scratch in Storyline 2.  I do get the same problem when using Storyline 1. 

Ashley Terwilliger

Thanks Justyna for sharing those steps here. As you can see throughout this thread it's not been something easily reproducible by our team - so if you're able to follow those same steps and see it each time, we'd like to take a look at one of your files and trying reproducing it on your files first. Can you reach out to our Support team here and share the SL1 file, the steps you've gone through, a copy of the translation document, etc. 

Anthony Fitzgerald

Hi Guys,

This issue has been going on for years now with Storyline export for translation. I'm sure it has something to do with the Windows ClipBoard bug. 

The issue also happens with PowerPoint when exporting the Slides for Word Handouts.

If you Google windows clipboard errors or PowerPoint Handout export errors you will find a lot of issues in Windows relating to this going back over a decade, which Microsoft has refused to fix or even admit the issue exists.

So I guess this is not really a bug with Storyline itself but a bug with windows, which is why the Articulate Support guys have yet to find an answer for it unfortunately.

However its still an issue to be looked at due to the fact that this Storyline export process relies heavily on using the clipboard to copy and paste every text entry into Word that is causing the issue due to the inherent windows bug. It would be great if the Storyline Dev guys could allocate some production/design time to look into this method and change the process to do this internally inside code, e.g. creating an RTF should be relatively straight forward without any need for Word. Then at the end of the process they can convert it to Doc. The end result would be the same and it would avoid all of this Clipboard messiness,

Cheers,
Anthony. 

 

Anthony Fitzgerald

*Update*

I just got my Storyline to export. This may or may not help some of you, but it just worked for me.

I just decided to close down any office applications I had open before running the export, the only one I had open was Outlook so I closed that then tried the export again, and low and behold it worked.  This is definitely one  crazy Office/Windows/Clipboard bug.

*Update 2*

I spoke too soon, the export just worked once, but when I tried another Story file it failed again :-(

Ashley Terwilliger

Hi Anthony,

We always recommend closing other Office applications such as Word while publishing to Word or exporting for translation. We'd be happy to take a look at your files as well as I shared above for Justyna. If you'd like to share it with our Support team here please feel free to send along. 

Anthony Fitzgerald

HI Ashley.

Thanks but there doesn't seem to be anything wrong with the file. The Story file can export on a freshly installed clean machines, like a virtual machine, which is what I had to set up in order to work with this process.

All story files have this problem on my PC and Laptop. Its a Windows/Office/Clipboard bug that no one seems to know how to fix.

Ashley Terwilliger

Hi Anthony,

Thanks for clarifying that the file works fine on another PC. If that's the case, it may be helpful for our team to take a better look at your particular set up (OS, version of Office, etc.) and any additional information you could share in regards to what occurs when you try to publish for Word. 

Anthony Fitzgerald

Thanks Ashley. 

My setup on both PC and Laptop is nothing special and I'm sure its different to the other users on this forum who have the same issue so won't be helpful to specify everything. Also I had the same issue when I worked for a previous company using their desktop setup, different version of office and different version of windows. 

This is a reoccuring issue for many users. I have reported this in the past, and I have seen other posts from other people on the forum, including this thread. 

My only suggestion is that this needs to be looked at by your Devs, in debug mode step by step to see what is happening. But I can imagine this to be almost impossible if you cannot recreate the issue.

From doing some research I can see this is probably related to the Office/Windows/Clipboard bug which I mentioned above, and it has been there in the last few versions of Windows/Office.

Is there any chance you can put me in direct contact with your Devs, so that we can discuss in more technical terms. I am free any time for a call.

Cheers,
Anthony.

 

Ashley Terwilliger

Hi Jonathan,

What version of Word are you using? Also are you on the latest update of Storyline 2? I'd want to confirm that you were also working on local project files and had closed down any other applications or Word documents prior to conducting the export.  Lastly have you gone through the repair steps of Storyline detailed here? The issue has been reported to our QA team, but it's been reproduced inconsistently, so those steps have assisted some users. 

Justine Swain

i had the same issue, and also cannot currently import a ppt either.

to get my translation export to work,  i had to close absolutely everything on my laptop other than storyline. i then had to set the export running,  and not touch the keyboard for the duration.  managed to export the word doc with reference column ok this way.

Ashley Terwilliger

Hi Jonathan,

The difficulty is we haven't been able to replicate it consistently, as a number of us have tried with SL2 and Office 2013. 

Justine, if you're having other difficulty with importing into Storyline as well, I'd advise you to work with our Support engineers after confirming that you've confirmed that you're working on local project files as detailed here and that you've gone through the repair steps documented here.