Storyline Translation Export to Word Not Working

Hello,

I'm trying to use the Translation feature in Storyline 2 (exporting to Word file type), but it won't generate the file. My Storyline 2 version is fully up to date (update 6). Is there a step I'm missing? I reviewed the steps laid out in this tutorial - seems extremely simple but just not working for me. I'm using Windows 8.1, and MS Word 2013.

I've attached a picture to show how far my export gets before it stops - only clickable options are then OK, and cancel. It looks like the translation exported, but when I go to my export location there's no Word file (not an error file, nothing). The only export that seems to  generate a file is the XLIFF (and I don't know how to work with this).

Thank you for any suggestions you  can offer.

70 Replies
Catherine Orfald

Had to work through this one again today myself as I was having the same problem (and have before, and have posted about it before).

  • SL2 v 2.7.1509.1408
  • Win 8
  • Microsoft Word, Office 2010-Office 14 (v. 14.0.7167.5001)

Today, after going through a Restart, Run as Admin, nothing else open, save as doc file (Word is set as default) to the desktop with a short name, and my export was still not working with a large file, I:

  1. Opened a small project and exported. It worked (test1.doc).
  2. Opened the large project and exported. It didn't work.
  3. Saved the large project as a new project and deleted a bunch of scenes and exported. It worked (test2.doc).
  4. Opened the large project again and exported. It worked (test3.doc) !?!?

I have had "inconsistent fix success" like this before with this issue. I think Anthony's Office/Windows/Clipboard bug sounds reasonable, because if we can push it past with success, it's more likely to work again.

Good luck with a resolution. Keep us posted, thanks!

Anthony Fitzgerald

Thanks Catherine for your update. I feel your pain and frustration, seems
we have been on the same journey to solve this issue.

After my exhaustive Google searches I could not find a viable fix for this
issue.
Seems to be an inherit clipboard bug which has been in the last number of
Window OS and/or Office releases.
Have repro'd this on Win XP, 7, 8, 10 and with Office 2010, 2013, 2016.

One other strange thing to add to the mix is if I set up a brand new PC
with nothing else installed except Office and Articulate, it will continue
to work for a period of time, then eventually the export will stop working
with the usual blank error message. I've noticed this happens after a big
windows auto-update... hmmmm seems fishy.
So moral of the story is to turn off automatic updates, however that's not
really great on a personal desktop for security reasons.

My only workaround is to set-up a virtual image that has just office and
articulate installed, with automatic updates turned off, and also I have
snapshot saved so I can just reload it clean.
It solves all my issues, except running in Virtual can be a lot slower,
especially for large Courses.

Ashley please keep us updated if your teams track this bug down.

Cheers,
Anthony.

Got a problem? Odds against you? Call The Localizer!
http://www.thelocalizer.com/

Ashley Terwilliger

Hi Anthony,

Thanks for sharing the workaround set up you're using here - as although it's not ideal, it's not one I've heard so I can share it with our QA team for them to continue their investigation. 

We'll keep folks updated here once there is any additional information to share, so thanks again for your patience and sharing the inventive ways you're continuing to work with this set up. 

Ashley Terwilliger

Hi Aida,

Thanks for reaching out here and I'm sorry to hear you've run into difficulty. It sounds like your following the guidelines to work locally so that's a good first step - and can you also confirm that you're using the latest update of Storyline 2 Update 7? As you'll see mentioned earlier, this is something that our team is aware of, and we're happy to take a look at your file as well to determine if there are any other causes or if it matches the known issue. If you'd like to send it along to our Support Engineers here we're happy to take a look. 

Leslie McKerchie

Hi all,

I wanted to provide an update here, as Storyline 2 Update 8 was just released, and included a number of fixes which you can see in the release notes available here. The item you all may be particularly interested in is how it fixed an issue where exporting text to a Word doc for translation wouldn't always work. You can download the latest update here, and after downloading and installing the latest update you’ll want to republish any existing content to ensure that the updates and fixes are applied.

Let us know if you have any questions, either here or by reaching out to our Support Engineers directly.

Anthony Fitzgerald

Wow, excellent, I would love to know how it was fixed, as PowerPoint handout export has a similar issue by the way :-)

Anyway I still have some clients using Storyline 1, so I have to still use that version on their projects. Is there any plan to include this fix in an update to Storyline 1? Pretty please ;-)

Cheers,

Anthony.

D Leith

If it's of any help, I had this problem and solved it by ensuring that Word is the default app for all relevant file types.

The only way to do this properly (on Windows 10) is to follow these exact steps:

Go to 'Windows Settings'

Select 'System'

Select 'Default apps'

Select 'Set defaults by app' option (not any other - it doesn't work any other way)

It will then take a moment to find all apps on your system.

From the list it generates select the version of Word installed.

Click the 'Set this program as default' option.

Click OK.

Close everything down and restart.

And I bet your problem is solved.  Mine was.

 

Noel Gorman

I recently encountered this very error (strange blank popup message and no actual translator file returned), and I believe I've found the cause and resolve.  It was only while shutting down Storyline and while shutting down my computer that additional messages started popping up that helped paint the picture.

Here's what's going on: Storyline is copy/pasting your presentation's text into a Word file, and Word's spell-check and grammar-check are losing their minds over the "errors" they're seeing and trying to fix.  The message chime you hear part-way through the translation effort is a message from Word that it's giving up on your file.  This is why Storyline users are receiving only a partial file of their whole presentation (if they get one).

How to fix it: go into Microsoft Word (or other application that manages .doc files), and over to the options/settings/controls for spell-check and grammar-check (in Word 2013, it's in 'Proofing,' and don't forget to clear check-boxes in the 'Settings' button on 'Writing Style').  Disable them all.  Storyline will have no problem turning out a translate file.