System simulations not playing correctly

I'm getting inconsistent results when publishing and playing some demo system simulations. Some play fine, others don't. Sometimes the screencast disappears and white background and captions only display.

I'm getting different results depending on where it's access from:

-- Preview is fine

-- It works fine when publilshed and played from my computer

-- jams at a certain point when played from a folder within Citrix. You can sometimes continue by refreshing.

-- jams as above when played from various folders on the company's server.

-- I'm yet to test it on the company's LMS.

Would it have something to do with the Flash version - we have Adobe Flash V13 on the desktop.

The IT department has tested it under different conditions, and are getting inconsistent results.

Any help would be appreciated.

12 Replies
Ashley Terwilliger

Hi Felicity,

We'll definitely want to know how it plays once loaded into your LMS or another web server - as it seems the issue is mostly connected to playing it from a company server or a shared folder? There are a few web server options that are free detailed within this article and you could also test it at SCORM Cloud (which is a great way to test SCORM content and is also free for a small account). 

Will Wood

Hi,

I'm having a similar problem (uploading to our LMS with AICC (using normal HTML)) in that the slide goes white in the final few seconds before it advances (while the mouse is moving). Other course uploads were fine until the last few weeks and I was wondering why this has just started to happen on the dozen or so I've just created. Is there a setting I've missed? Is this something to do with automatic advance? 

Testing in preview is OK (even after published)

Oddly enough a few slides are OK.

Please see example of one of my courses below:-

I'm using Storyline - Update 5

I've checked the page you suppled for Felicity but have followed all instructions (It's normally a routine procedure).

Thanks for any assistance.

Will

Robert Lengacher

Will - I can think of two possible explanations.

  1. There is a gap in your timeline after the end of the video file that contains the screen captured video of the interactive simulation. Solution: Adjust the end of your timeline by dragging to the left until it hits the right end of the video clip (it'll stop automatically)
  2. The screen captured video clip of the software simulation on this slide (step in the process) ends with a white screen because in real life the screen turns white after "Manage Customer" is clicked, and the video clip freezes on that moment. Solution: You can trim the video clip right in Storyline as you can with any video clip. Here's a tutorial from Jeanette Brooks on that process.
Ashley Terwilliger

Hi Felicity,

Thanks for the update and I'm happy to hear everything worked normally once in your LMS.

Will - welcome to the Heroes community! If after you've checked into Robert's suggestion you're still having difficulty you'll want to confirm that your .story files and published output follow along with these guidelines for working locally and the file name/path guidelines. If you're still having difficulty we'll want to take a look at your .story file (or even just a few of those slides). 

Will Wood

Hi Robert,

Thanks for your reply. I've learnt something new today about fine tuning but alas there is still a problem. I've always done the same in the timeline area and made sure there are no gaps at the end.

It all looks OK in the Storyline program itself. 'Preview entire project' is fine. Even 'Publish to Web' looks fine - and uploading to our web host.

It only occurs when I publish to LMS and then upload onto our LMS. (I've attempted LMS/HTML5 too but the browser always stalls for a second or two before it moves on, coincidently about the same time the other problem happens on LMS/HTML).

I've double checked everything. :-S

(I've raised a support call too)

Ashley Terwilliger

Hi Will,

Since you mentioned it only happened in your LMS and not when testing it on a web server, I wanted to confirm that you're publishing for LMS as detailed here. Also, you may want to try testing it within SCORM Cloud to see how the course behaves there to help narrow down if the issue is within the LMS itself. 

Also, can you share your case number with us here so I can follow along? 

Will Wood

Hi Ashley,

Details below:-

Case Number: 00407673
Reference ID: ref:_00D30Txo._50040bHwZV:ref

I submitted one recording with the case number as an example. (although preview doesn't cause any problems so I've e-mailed you a link of the live version. The problems starts a few slides in when it automatically advances)

I definately choose LMS as the publish option and will look again tomorrow to see the LMS host has updated any of my uploads.

Thanks again for your help.

Ashley Terwilliger

Thanks Will - and I see that Regil took a look at your course and wasn't able to reproduce the issue at SCORM Cloud which is an industry standard for testing SCORM Content. You may want to try uploading it there as well and if the behavior does not persist you'll want to reach out to your LMS team for further assistance and troubleshooting. 

Will Wood

Hi Ashley,

Just thought you would like to know that, yes Regil got back to me and the SCORM link on one of my recordings worked perfectly.

I narrowed it down to three possible explanations:

- Our LMS is not working (Although I've reproduced a test course on another computer which has Articulate Storyline Update 4 only installed and it's worked with success). I need to find another with Update 5 on to test.

- Our LMS doesn't like Update 5

- My laptop that I created all recordings on needs to re-install Storyline (possible Update 4 only) - I've asked for a fresh Storyline download with a download for Update 4. Is that possible do you know? as I would really like to try that.

Thanks again for your help Ashley. I'll keep you updated of the final result.

Will