Tab order problem with storyline course

I am having trouble with tab order of a course. When I preview and when I publish the course it is not tabbing as its set on the back end. It pulls tabs from the previous screen and skips tabs all together. This is happening in every project that I open. I tested the tab order using the NVDAA screen reader as well as trying to tab through in preview mode with the exact same result. Older courses I have published work just fine. My courses have to be 508 compliant and I have no idea why the tab order is not being read as its set. 

8 Replies
Meagan Taylor-Booth

Morgan - this is happening to us, too.  With the new "improvements" to the accessibility of the player, it has created so many issues (i.e. buttons not appearing in tab order if they are not on the screen when a slide starts; old alt tags from copied boxes and slides being read, even if the alt text has been changed; etc.).  We have filed several tickets and there have not been any fixes.

Meagan Taylor-Booth

Actually, Lauren, these are issues that appeared AFTER update 36.  The alt text is now incorrect for any shape or text box (other than buttons) that was copied from a previous slide or if the slide was copied.  The alt text does not read what the current alt text is; instead, it reads the previous alt text that comes from previous screens.  We have also called attention to the issue here: https://community.articulate.com/discussions/articulate-storyline/screen-reader-reads-out-previous-tags-on-copied-pasted-pages.  This makes the content completely inaccessible and means that Storyline 360 does not support WCAG 2.1 Level AA.

Lauren Connelly

Hi Meagan!

I'm so sorry for the typo on my end! You're correct, the current update for Storyline 360 (Build 3.36.21213.0) included changes to the way Storyline behaves in regards to accessibility. We still meet WCAG 2.1 Level A, Level AA, and Level AAA standards which you'll see in our conformance report here.

I responded to your post in that discussion and we are still working with William to test his file since the bug fix was included in Update 36! I'd encourage you to also work with our Support Engineers so that we can look into the specifics of what you're seeing. 

I've started a case on your behalf and escalated it to our Support Engineers. You should be receiving an email shortly.

Meagan Taylor-Booth

Lauren - my colleague has already filed a ticket (Case #02139296) regarding this issue and received the following over a week ago.  We have not heard anything since.

Thank you so much for your patience in this.

And thank you for letting us know about this issue. I was able to replicate the error when I tested it in a new project file using the latest update version of SL360 and NVDA. I've reported it to our team and logged it as a possible software bug.

From here, I'll meet with my team to take a closer look so we can determine next steps. Sometimes my team catches errors in my logic and we don't have a bug after all. Of course, if that's the case, I'll let you know!

Depending on priority and risk, some bugs can be fixed quickly, while others take longer to resolve. Here's more information on how we identify and tackle bugs: https://articulate.com/support/article/How-We-Tackle-Bugs

I'll let you know as soon as we have an update on this issue. Thanks so much again for letting us know about this, and I'm sorry if it's slowing you down.

If this is in fact a bug, it takes anything produced with Build 3.36.21213.0 out of compliance with WCAG 2.1 Level AA and Level AAA standards in regards to alternate text.

Vincent Scoma

Hi Megan and Morgan,

I am happy to share that we just released the newest version of Storyline 360 Build 3.37.21453.0, which fixed the issue where screen reader tools would repeat the previous question when jumping to the next quiz slide. To see all the new updates this new version brings, please check out this page here

The next step is to update Storyline 360 by heading to your Articulate 360 desktop app and clicking "Update" next to Storyline 360. 

As always, we are happy to answer any questions you have by posting in this discussion, or you can contact our Support Engineers directly.