Text boxes resizing??

Anyone know why my text boxes resize themselves after I've entered text? It's worse with questions - they will be in a defined area (like in 3 lines) and then later the text is in a straight line off the page. It's a pain to resize these all the time and I don't know what's causing it

HELP please as I have to pass the course off to another user in a few days.

25 Replies
Wendy Farmer

Hi Diane

if you right click the text box and select the Text Box option at the bottom - you'll see the Autofit resize options there. Depending on what is set is what is happening to your text boxes.

Here is the explanation of the options

https://community.articulate.com/articles/text-box-formatting-in-articulate-storyline-2

Christie Pollick

Hi, Diane -- Many thanks for your reply and for the additional details on the behavior you are seeing. Would it be possible for you to try importing the file into a new file to see if you find improvement? Also, it may be worth a moment to check out this information on Unexpected or Erratic Behavior in SL2, and perhaps it would be helpful to run through the repair steps mentioned in step #2. 

Christie Pollick

Thanks so much, Wendy, and I actually think it's sort of nice when more than 1 person suggests the same idea in a thread, because it solidifies that that would most likely be the right path to take! And thank you -- we wish you and the rest of this awesome community a joyous holiday and New Year full of cheer! :D

diane clark

Yes, I do only work from my local drive. This is not the first course I've had the issue with. I looked at the article about unexpected behavior but may just need to pass it along. I'm retiring the end of this month and someone else will have to pick up the software and finish the course. Unfortunately it will not be someone with experience so I was hoping I could resolve it before hand.

Were you able to see the attached file to see what I'm talking about?

Allie Munro

Diane,
I too have run into this issue multiple times before, I have not found an easy solution to solve this problem but I have found out how to avoid it in the future.

What is happening?
Storyline runs through a series of commands that "Draw" what is in your slides. This happens every-time you close a slide or launch Storyline. There is a lag sometimes (unable to identify when and how it happens) that cause it to draw your items before it reads all your settings.

One of the settings in particular for text boxes is "Wrap Text in Shape". When this lag happens before this setting is read by Storyline, it will unwrap your text as you see in your case.

Why some text boxes and not others?
When you create text boxes there are two methods. "Click Once" and you get a one line text box. If you check the properties of this box you will see it is not set to "Wrap Text in Shape". This is where the problem lies. Storyline uses the default settings for when you created your shape as a baseline. This text box is now subject to your issue.

If you created a text box by dragging out a shape large than one line height you would see that the default setting is "Wrap Text in Shape".

How to Avoid?

When creating your text boxes, always drag  a rectangle so that by default your text box settings are set to "Wrap Text in Shape". This text box will never inherit this issue, or at-least I have mitigated this issue in my development.

How to Test this issue

Create two of the above text boxes, one drag out to be a few line in size and the other done with a single click. Write in a large junk of text so that there is enough text for them to carry onto multiple lines.

Adjust your single click text box to be "Wrap Text in Shape" and size it to match the other box. 

Now toggle the "Wrap Text in Shape" setting for each box. You'll see that the Single Click text box does not fix itself while the other text box will.

How to Solve:

Unfortunately to fix this issue from re-occurring you should create new text boxes that dragged out appose to single clicked onto the stage. 

 

I hope this helps Diane, best of luck to you and with your retirement.

Ashley Terwilliger

Hi Camille,

I'm sorry you're having such trouble - but this discussion is quite a bit older! I'd like to know more about your setup and Storyline version to offer new ideas and advice, as perhaps it's not the same issue. Can you share those details with us here? If you'd prefer to work privately, our Support Team is available for one on one help! 

Also, if you don't know the version of Storyline you're using, you can check by going to the "Help" Tab -> "About Articulate Storyline".

Carrie Albin

I am having the same issue and I am working Storyline 360.  When I look at what Allie mentions, all of the text boxes that are acting up are ones that don't have Wrap Text in Shape checked.  Just checking it doesn't resolve the issue.  So Allie is correct, recreating the text box seems to be the only solution.  The file seemed to work fine back in June and we just did the final review and I am going in to finish up the final edits and that is when the text boxes did this.  Up until now the textboxes have been fine.  :(  I also tried bringing in the slides into a new Storyline file and that didn't resolve the issue either.   Perhaps a recent update is causing the issue?  I am on the latest updated version of Storyline 360.  

Ren Gomez

Hi Carrie,

It sounds like even after you’ve set the text box to wrap text, it doesn’t seem to stay formatted that way, is that correct?

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Carrie Albin

Hi Ren,

That is correct. They did not reformat even when I checked that box. I
had to recreate each textbox.

I did see a pattern though and it was only on slides that I had reused from
a previous course. We have a specific layout for all quote and journal
reflection slides. Those were the ones that seemed to be having the
issue.

I have already recreated all the textboxes since this project needed to be
finished last week. So I don't have a file where they do not work
anymore.

Thanks,
Carrie

Ashley Terwilliger

Sorry to hear you've already done the work to fix it up, Carrie. If you get stuck again, please let us know. We never want you to spend hours troubleshooting a problem alone-that's why our team is here to help. You can reach out to our Support team 27/4 at this link or always find us here in the E-Learning Heroes Community! 

Katie Riggio

Hi there, Janice. 

That does sound frustrating. I'm so sorry you and your team are dealing with this oddity with the textbox!

We'd love to lend a hand–if you don't mind sharing a troublesome .story file with us, we'll try to replicate the behavior and let you know what we find. If that works, you can upload it privately by using this link. We'll delete it after troubleshooting!

Janice Pericich

Unfortunately, I've already fixed them on the course I am currently working on. But it took 3 revisions. I'm following the suggestion to draw a multiple line text box and replacing the text boxes that were there previously as they kept losing the wrap setting. We have even been checking the option to "Do not autofit". If (when) it does it to me again, I will send the storyline file.

This seems like an obvious bug as the original posts on this are from 4 years ago.

Rachel Crabtree

I'm glad I'm not the only battling this issue!  It mostly seems to be slides that are imported, which are 100% of my courses at the moment.  I have tried to ensure the same master slide layout is applied to all.  I have tried to change the powerpoint file to be the same size as my SL file.  I double check that the master powerpoint slide text box setting was correct.  I also have been saving each slide thinking maybe it was saving issue.  I have tried to create a text boxes in the master slide that act as a parent for all.  All to no avail .....Hopefully setting the default text box option will fix the issue (just read it on another thread). 

Keeping my fingers crossed :) ahh tech problems we would be so bored without you!

==> Update:  Setting a default text box prior to importing did not help.  Submitted case did not fix issue.  I will keep my eye on this thread!