Text entry field on tablet devices

Hello. Hope someone can help.

I have a text  entry field on a slide. It works great on PC. Users can add text, edit it, leave the slide, return to it and edit again. Great.

This also seems to work on iPads running ios 11.

However, it does not work on android tablets or ios 10 or below. In these cases, the users can input text but they cannot then position the cursor to edit the text. The return (paragraph) and delete from the keyboard works but the cursor cannot be moved around using the touch screen. I have tried one finger, two fingers, press and hold etc. When users leave the slide and return to it, they can press into the box to get the keyboard up but the cursor defaults to the beginning of the text. As they cannot reposition the cursor, they can't then edit the text.

Any help or solutions appreciated.

Cliff

11 Replies
Crystal Horn

Hi there, Cliff.  Thanks for sharing those details!  I can see where that is problematic when users need to input and potentially edit more than a few words.

  • iOS:  I tested a sample course, and I also noticed that I was unable to edit the text entry on an iOS 10 device.  I could only completely delete the text.  An iOS 11 device worked as expected.
  • Android:  It did work for me on an Android tablet with OS 6, and an Android phone with OS 8.  Can you let me know what Android device you used to test?

In the meantime, I'll get this behavior documented for my team to review, and we'll keep you posted with any changes.

Cliff Porter

 

Hello Crystal,

 

 

 

Thanks for responding. Apologies it has taken me a while to get back to you.

 

 

 

I've tried with iOS9 and it did not work properly.

 

 

 

Also tried on Android tablet - did not work with Android 7. Did work for me
on phone with Android 8.

 

 

 

I wonder if this is going to be something linked with both the operating
system and also the hardware??

 

 

 

Many thanks for looking into this.

 

 

 

Please let me know if you get any more information.

 

 

 

Regards

Ashley Terwilliger

Hi Cliff,

First, I wanted to let you know your email signature came through when you replied via email. You can remove that if needed by clicking ‘Edit’ beneath your response. Here’s a quick Peek video if you need help.

As for the issue you've run into - did you publish with Storyline 360 Update 21? 

Storyline 360 would need iOS 10 or later on a mobile device to work properly, and I see Crystal noted it doesn't work in iOS 10 but it does work in iOS11. Are you able to update that device? 

What Android tablet did you use? That way we can make sure we're testing the same setup as you have. 

Cliff Porter

Thanks Ashley

Published using Storyline 3 with latest update.

Did not work on a Lenovo tablet. Also does not work on (very) old Samsung tablet. My phone is a Motorola with Android 8 and that's ok.

Tried on iPad mini on iOS 10 and did not work.

The only solution I came up with was moving the cursor using keyboard in gesture control setting on Android and in two-finger 'touch pad' mode on iPad. Bit of a clunky work-around though.

 

Ashley Terwilliger

Thanks, Cliff

It sounds like it's the older devices and iOS that don't work? Do you know what Samsung tablet it was so that I could test it? I don't have a Lenovo tablet, but what browsers were you using there? 

We shared the issue of iOS10 with our team, so will keep you posted here if we have any updates to share.

Ivana P.

Hi I just tried out using the Text Entry Field (with a specific value that needs to be entered on an iPad running on IOS 11) and it wasn't working. The keyboard appears/disappears, and when it finally appeared, I wasn't able to enter the value at all. The iPad has IOS 12 installed, and it didn't work with IOS 11 either.

Leslie McKerchie

Hello Ivana and welcome to E-Learning Heroes :)

Thanks for reaching out and letting us know what you are experiencing in your course.

I took a look at a sample file using iOS 12.1 and I am not experiencing an issue.

Here's a screen recording of what I'm seeing. 

Do you have a sample .story file we could take a look at?