Timeline changes do not take effect

May 16, 2012

I am wondering if anyone else is having this problem, but i couldn't find anything when searching the forum.

I am matching audio files up to a video by moving the audio files around in the timeling to sync them up. I have found on a number of occassions that I will make a change by moving the audio along the timeline and then replay the timeline preview and it ignores the fact that the audio has moved and plays it at the time that I moved it from.

You can see quite clearly on the timeline that it is playing audio when there is no audio at that time in the timeline. I have included a picture that shows the gap between the two audio files.

 I have noticed this before with pictures and shapes not updating as well but it wasn't such a big deal, but syncing audio needs to be more accurate.

Can anyone tell me how to make the timeline refresh itself perhaps? I have tried going to other slides/scenes and saving the file.


18 Replies
James Brandwood

Unfortunately I work for an insurance company... well that's not the unfortunate part, but it means that I can't upload the content due to our strict security restrictions.

It is an on-going problem howevere, the timeline just doesn't update the changes you make. It will preview and publish with the updates occuring but as Bruce pointed out you really have to re-open it to get a result. 

At the moment I am just doing a preview of the one slide whenever I make changes. This loads up pretty quickly (actually about as fast as pressing play on the timeline, which can take awhile on a slide with a few elements) but it really does take away from the timeline's function/purpose. I do love having a timeline though, it was one of the things I really thought was missing from Presenter.

If someone else having this problem could upload their project I would really appreciate it. If I get some time I might check if this is happening on both slide with video and slides that just have screen shots.

Elizabeth Ross

I've been having a similar problem, though admittedly I've been using Storyline for all of 2 days.  I have the trial version, and I'm trying to decide whether to ask my school to buy the software. 

I have a screen recording with audio.  While that plays, I have captions and pictures that fade in and out to annotate the video.  In theory, I should be able to play the video, pause where I want the annotation to appear, align the image/caption to the playhead, and then resume to do the next one.  When I resume, however, the video hiccups and becomes unsynced with the timeline.  If I just keep going, pause at the video cue for the next annotation, and align with the playhead, that annotation won't be in the right place because the playhead and video are out of sync.  I find that after syncing every annotation, in order to do the next sync, I have to save the story, close, reopen, and play the slide from the beginning.

James Brandwood

I am still having this problem with video or screen shot. I am using the trial but HR should have the paid version for me this week and we will see if this will make a difference. I doubt it will unless an update occurs when you register the software.

 I can only suggest using the single slide preview, it does open faster and you will be surprised how often you guess the syncing correctly off the audio wave form. 

Julie Miles

I'm having the same problem as  Elizabeth. The audio plays perfectly in the Audio Editor, but when I try to play the slide so that I can sync pictures and captions to it, the playhead starts moving across the waveform before the audio starts. This means I can't possibly sync the animations accurately with the audio, since there is a disconnect of several seconds between them. Closing and re-opening the program doesn't seem to have any effect in my case.

Has anyone been able to figure out why this is happening, and whether there's a fix for it?

Christine Hendrickson

Hi Julie,

Have you used the "Trim" option in the Audio Editor to modify the length of the audio file? Or is there just random additional time added to the item in the timeline?

If you'd like, we'd be happy to take a look at the file and see what's happening. You'll be able to attach the .STORY file on the second page of the following form:

Articulate Support - Submit a Support Case

Please be sure to include a description of your issue. Please also include the URL for this thread in the form. Also, please share the case number with me. You're welcome to do so here, or in a private message. This way I can follow the progress of the case and update this thread.


James Brandwood

I still get this fault on all projects I do - although I have found it occurs less since update 2 was done and is generally more likely to occur if I have been working for a while or have run a number of previews on the same slide while syncing items on the slide.

I find it has nothing to do with trimming/editing audio or video and simply occurs if you have made a change on the timeline and press preview. At these times it simply plays the slide as it was before the change was made, which makes it appear out of sync, when I guess it isn't really it just hasn't updated.

I have grown used to it being a feature of the program and when it does occur I find it can sometimes be remidied by clicking around a bit on other slides and coming back. If that fails it is fixed by saving - closing and reopening the file.

Julie Miles

I think there are two separate issues being described in this thread, both of which make syncing difficult.

The issue that James is describing is something I have experienced as well. You have several  items in a screen; you play through the slide and move each item to a specific point on the timeline to sync with the audio, then you move the playhead back to the beginning of the waveform to play it again, and it plays as it did before you moved anything - all the items appear exactly as they did before you tried to sync the slide. This is irritating, but it does seem to be something that occurs after you've been working on a file for a while, and it can be cleared up by closing and re-opening the file.

The second issue, which is the one that was really bothering me and which I think Elizabeth was also encountering, is different. With several items in a screen and some narration to sync them with, you click on the "Play" button in the bottom left corner of the Timeline panel. There is a pause of several seconds, then the playhead starts moving, and several seconds later the audio actually starts. This means that the narration is not in sync with the waveform and the timing is out by several seconds throughout the slide. This behaviour is apparent as soon as I start working on the file, and I am not able to fix it by closing and re-opening the file.

However, I  made an interesting discovery after submitting a ticket and uploading the file for Articulate to look at (they weren't able to replicate the problem). Yesterday I worked on the same file but a different computer, and although I still encountered the first problem, the second problem with the audio delay didn't show up at all. I have to conclude, therefore, that there is something in the setup of my computer that is causing that second problem, and it's not an issue with the software. I wish I knew what it was, though!

Christine Hendrickson

Hi Julie,

I've kept an eye on the case and I'm curious as to what may be different on the original machine that's causing this issue. Have you had any luck determining a difference between the machines? 

You mentioned you may be considering rebuilding the setup on the original machine. Before you do so, can you try following the steps outlined in the article below, please? 

Unexpected or erratic behavior in Storyline

If you notice any changes, or if you're able to find some additional information on this, please let myself or Jonathan know.


James Brandwood

Hi Julie,

Just a comment on your last point about using a different computer. After having so many problems like the one on this thread and storyline crashing/saving issues, I recently tested storyline out on a different computer and had a lot of success.

My current laptop (work) is actually quite powerful and is only 1 year old (brand new when I started using storyline on it) and has no issues running any other software but it is only 32 bit and therefore only has 4gb ram. Based on other reports of people having less issues on 64 bit machines the laptop (same build/model)  I trialled was 64it with 8gb ram (with a patch to enable storyline to access all 8gb as it is a 32bit program).

The difference was night and day. I actually couldn't make it crash and I didn't have any issue when previewing using the timeline and like you I was using the same files that had problems on the other computer.

I did notice that storyline used a massive amount of ram and when it has finished a resource hungry process it doesn't seem to give the ram back. When I tried to crash it I ran 5 or so other programs to try use up all the ram and storyline, when open but idle, was using more ram on it's own than the 5 programs combined while they were doing tasks. I did end up using about 6gb of ram doing this which explains why my 4gb computer struggles.

In short if you are making small modules (under 60,000kb file size) you're probably going to be fine with 4gb, if you go bigger you will probably start experiencing issues and if you get over 90,000kb than good luck to you unless you have a 64 bit machine.

Hope this helps.

Julie Miles

Christine, I went through the steps described in the link above, but with no luck - the problem persists.

James, that's interesting - but different from my experience, which I suspect will make it even harder to identify the cause of the problem! Both of the computers I'm using are 64 bit Windows, and both have 16 GB RAM. The differences are that the desktop, where I'm having the problem, is Windows 7 and a couple of years old, and the laptop, on which Storyline runs perfectly, is  Windows 8 and only a few months old.

What is the patch you mentioned that lets Storyline access more RAM? I should try that before I attempt anything more drastic!

James Brandwood

Hi Julie,

More RAM without Articulate being able to access it (it is a 32bit program) will probably mean the exra RAM won't help too much. I don' know if there is anyway to make Storyline use the first 4 gb of RAM on your computer and other programs to use the later bit so you may find without the patch you're still sharing the 4gb anyway.

It is mentioned in his forum thread:


and the link is:


The company/person that made it isn't affiliated with Aticulate so I guess it is a run at your own risk patch. So far that risk is paying off for me.

Hope this helps.

Christine Hendrickson

Hi Leslie,

Is it the seekbar control that's not working in the LMS, or the animations? 

If this is working for you in Storyline, but not the LMS, have you tried using a different server for testing? If you'd like, you can try uploading the course to Tempshare or SCORM Cloud and see if it works with one of those servers. Or, if you'd like, you're welcome to share the STORY file here. I'd be happy to take a look.


This discussion is closed. You can start a new discussion or contact Articulate Support.