Tin Can API Index Filename

Hello,

I am publishing a course to an LMS using the Tin Can API. The LMS needs the index page to be index.html instead of index_lms.html which is the default for Tin Can API when published from Storyline.

I have changed the Launch URL to be index.html in the Tin Can API Reporting and Tracking Options and when published, the manifest file is updated to reflect that change. However, and most importantly, the published index file is still named index_lms.html.

As it stands right now I have to publish and instead of just zipping up the output and uploading it to the LMS, I have to open the output folder, change the filename, zip up the files, and upload it to the LMS. This isn't the end of the world but it seems strange that the outputted index file doesn't pick up the Launch URL setting when the manifest file does.

Am I missing something that I need to change to get the index file to be outputted as index.html instead of index_lms.html?

3 Replies
Ren Gomez

Hi J.,

What LMS are you using? Storyline defaults to publishing to the index_lms.html file as described in the publishing options:

Storyline 360: Publishing a Course for LMS Distribution

Does it not work correctly when you trying pointing to that file? If not, it looks like you may need to manually change it as you described.

 

J Frankwick

I have a client who is using Adobe Connect as their LMS. There's a known issue for it that the launch file needs to be index.html and not index_lms.html.

As I mentioned I went into the publishing output and changed the launch URL to index.html. However, when published, Storyline still publishes the file as index_lms.html while at the same time changing the manifest file entry to index.html.

Unless I'm missing a setting somewhere, this seems like a bug. If it changes the entry for the launch page in the manifest file it should also change the name of the file it's publishing. There is no reason it should change index_lms.html to index.html in the manifest file while still outputting index_lms.html.