translation feature not working in SL3

I am trying to export a file for translation to a Word document and am getting an error message about half way through the process. I'm using SL3 on Parallels. I've tried restarting the print spool, reinstalling SL3 and a number of other things, but no success. I've attached a screen shot. I even tried on another computer, also with parallels, but an older version of SL3 and both with most up to date version of Windows 10. I also noticed that the translation export now calls up MS Word to open.  I have discovered that the problem is somewhere within the course. The course is all in one scene. There are 4 lessons. Each lesson on its own translates fine. Lessons 2 and 4 translate fine. I'm still working on various combinations, but when I put lessons 1, 2 and 3 together I got another error. I've uploaded it here. For now I'm stuck and not sure how to find the problem. Any ideas, help??? THANKS

7 Replies
Katie Riggio

Hi Sylvia,

Thanks for providing all of that helpful info. We've seen those errors appear when:

  1. "The RPC server is unavailable": This typically means that the Windows computer is having trouble communicating with other devices or machines through the used network. 
  2. "Exception has been thrown by the target of an invocation": This is an open bug in Storyline when exporting numerous slides/text-heavy content to Word.

Next Steps

  1. Working on a shared drive can cause the first error. Let's make sure that the project is stored on a local drive.
  2. For the second error, we recommend splitting the project into multiple parts by doing a Save As on the original .story file to reduce the number of slides. Then, exporting and translating the translation documents and lastly importing them into the original .story file.
    • Or, closing all Office applications could help.

Of course, we're here to help along the way! If you'd like to send your project file to our Support team for testing, use this private case link.

Sylvia Wright

Katie, thanks so much for this. I'll work my way through this. Is the bug in SL3 only or 360 too? I'm not working with 360 and don't share my devices. I AM working on a virtual machine (Parallels on Mac), but I share nothing but internet connection and printer with the MAC. Do I assume "open" bug means it is a bug that has not yet been resolved?

I do find it interesting that I had no problem getting the translation from on earlier version of SL3.

As for dividing the project does it work to import more than one translation file into a project? I will divide out the lessons into separate files, but it's just frustrating that I have in the past gotten this translation document so somewhere there is a coding conflict.

Mega thanks for being available!!!

Katie Riggio

Good morning, Sylvia!

Thanks for writing back.

The bug noted in the second bullet affects Storyline 3 and Storyline 360, and you're right. Since it's open, it is currently in the early stages of our How We Tackle Bugs process.

Also, we found that the error appears in Storyline 3 Update 9 and 10, but good to know that it didn't appear in an earlier version for you. Could you let me know which update you used so I can add it to our internal report?

Lastly, once the exported files are translated, we recommend importing them to the main project for translation. For example, if you have 5 Word files containing sections of the translation, you can import them one at a time to the main project to translate the parts that match these Word files.

I know this isn't an ideal workaround, so we promise to notify you as soon as there's more to share. Thanks for bearing with us!

Sylvia Wright

Thanks Katie. I can't recall which version I was using... AND, unfortunately! I deleted it :(!

As for importing into the main file that will not work because SL3 renumbers slides when you move a section to a new project :( and so I have 4 lessons in 4 separate files and the all contain a slide 1.1, 1.2, 1.3 and they are not the same in the different files :(. Will that change when I import the translation form from the smaller, divided out file into the main project file? I'm thinking I'm going to have to import the translation back into the smaller file and the put all the 4 files into one new file and remake all my connections :( :(. I do hope someone is actively working on this bug. The translation feature of SL was my absolute main reason for choosing this tool. I have 30 different languages to work on and THIS issue is a real problem.

Leslie McKerchie

Thanks for the additional information, Sylvia.

One solution that has worked for some users involves disabling Unicode UTF-8. Not sure if you'd like to try this in the meantime.

You can access this setting using these steps:

  1. In Windows, open Settings
  2.  Click Time & Language
  3. Click Language
  4. On the right side under "Related Settings" click Administrative Language Settings
  5. Under the Administrative Tab click "Change System Locale" (requires admin rights)
  6. Ensure that the box labeled "Beta: Use Unicode UTF-8 for worldwide language support" is unchecked
  7. Reboot if asked when changing this setting

See this peek for more info:

‚ÄčDisabling Unicode UTF-8 for worldwide language support