Trigger order not as expected

Hello all!

I have a branching scenario in my SL360 module which relies on a random variable and two number variables to guide the direction of the branching.

The module has been working well for over 6 months (including a lot of user testing to get the flow working correctly) but I have made a small change to disable the back button in the assessment, and now when I preview or publish the module, it appears that the order of the triggers is not being followed as before, although I can't see why.

Does anyone have any thoughts on what I could look into? I have attached an image of the trigger panel if that helps. Thank you!

2 Replies
Walt Hamilton

The only thing I see is that the Value of Assessment2 isn't checked if ScenarioComplete = 2, but I'm guessing that's the way you want it. Of course, if this is an exhaustive list of triggers, nothing happens unless ScenarioComplete =2, or Assessment2 = 1 or 2, but again, that's probably the way it should be.

The triggers look good, so the problem must be with the values placed in the variables. i would start by putting a reference to those three variables on this layer, and checking what those values are before I click Continue.

Ellen Valvasori

Thanks Walt, that was really helpful and showed me that the issue was on another page entirely! 

I had a trigger adding 1 to ScenarioIncorrect on the start of the incorrect layer timeline, which makes me think that the incorrect layer is playing even though I selected the correct answers and can see the correct layer displayed. I have moved the trigger to the continue button instead which fixes the issue, now to hunt down why the incorrect layer is showing in the background...

Thanks again!