Triggered layers skipped

I created a slide with four layers.  I triggered the second through fourth layers to appear when the user clicks the Next button.  But when the Next button is clicked the first time, the slide jumps straight from the first (Intro) to the fourth layer (Bullet list 3) without displaying the ones in between.  How can I make it display the middle layers (Bullet list 1 and Bullet list 2) before displaying the fourth one?  Here's the configuration...

3 Replies
Mike Enders

Hi David,

Here's the scoop:

Triggers fire from top to bottom.  And layers are preset to hide each other.

So, in your setup, when you hit the next button on the player, it executes all of those show layer triggers from top to bottom.  It shows layer 1, then 2 (which hides layer 1), then 3, (which hides layer 2) and this all happens instantly (so you likely won't even see the other lists appearing and disappearing).  Further, if you were to add a slide following this one, that jump to next slide trigger is going to fire and jump you immediately to the next slide.

So...

Here's what I'd do. 

If you want the lists to appear with the next button, you could do something like this: https://player.vimeo.com/video/204869775

If you want the slide layers to all stay put (so they build), then you'll want to go into slide properties and remove the hide other slide layers option (do this for each layer).

You'll still need to consider the jumping to next slide behavior (if you wish to keep that trigger on the next button).  I'll have to think it through a bit, but ultimately, you'll need some type of condition to only jump to the next slide after all of the layers have been displayed.

I hope this gets you started.  Keep me updated.  I'll be traveling today, but can check in periodically to help you out!

Mike

David Ward

That concept worked great, Mike.  Thanks.

I didn't understand that all triggers are fired every time the Next button is clicked.  I thought it only triggered one until the Next button is clicked again.  Your video clarified that for me.  Here's how I changed the configuration to make it work...