Triggers not working Storyline 2

Just a little context, Articulate user since 2009, built 100s of courses in Studio and Storyline, first time I've run into this. Submitted a ticket yesterday and no contact back from support.

We're doing software training and using the screen recording option then importing to individual slides to populate content. We've done this with dozens of courses in the past with no issues.

For our navigation, we use custom arrows on the left and right side of the screen for previous and next slides. Our triggers are set up so jump to the next or previous slide when the arrow is clicked. Nothing complex, used this same process on 1000s of slides.

Here's the weirdness...when the previous arrow is clicked on, it jumps to the first slide in the scene. Doesn't matter which slide you're on, 1st or 20th, they all jump to the previous slide.

We have multiple developers working assembly line on the projects, so there is the possibility that someone has done something weird and wonderful in the logic somewhere but for the life of me I can't find it. Nothing on the slide masters. Nothing on the states. Nothing conditional on the triggers. No variables that I can find, nothing on layers. Just strange little triggers that say Jump to previous slide when the user clicks the object, exactly the same as 10,000 other ones I've built, but that act as if they are Jump to scene and are being directed to the first slide in the current scene. I've even tried going to the built in Prev/Next buttons on the player and same result.

The only wild card I can think of is the use of the screen recordings to populate the slides and if that interferes in the logic. It's something fairly new for us, a couple of dozen courses, maybe 1000 slides under our belts, but this is a new issue using an existing template process.

Thoughts or ideas?

2 Replies