Triggers taking time to respond

Hi,

was wondering if anyone frequently uses jump/hide/show triggers and whether they have issues with this triggers taking a long time to activate/take place. For example i have a number of slides with in a deck which contain layers. These layers have buttons which when you press them, they open up new layers or close existing layers. However when published we seem to be encountering times when the navigation is sluggish, you press a button which has a jump or show trigger and it take an eternity for the slide to progress.

Has anyone encountered this issue?

Any solutions?

Any help would be appreciated 

Many Thanks

Gavin

14 Replies
Ashley Terwilliger

Hi Gavin and Dan,

Sorry to hear about the slow behavior you're experiencing with your triggers, and I have a few additional questions to help point us in the right direction for troubleshooting:

If you're able to share one of your Storyline project here we'd also be happy to take a look at it. 

Daniel Sweigert

Hi Ashley,

At this point, although I'm "Publishing to Web" the published files are on my desktop. I'm viewing them through a Google Chrome browser. The funny thing is, when I "Preview the Entire Project" everything works perfectly, but when I publish and click the "View Project" button, a number of the triggers don't work.

The triggers I have set to start & stop playing the video & audio seem to work fine. But the triggers that change the states of my pictures from visible to invisible and vise-versa, and the triggers that jump to the next slide aren't always working.

I had trouble attaching the file to this message, so here's a Dropbox link to where you can download it:

https://www.dropbox.com/s/dkr45dtgpw8j41n/Pinnacle%20Video%20Editing%20Working%20with%20the%20Player.zip

Thanks,

Dan

Gavin Henry

Hi Ashley,

The initial testing has been done with in preview but now that we are viewing it with in the intended environment these issues have become a factor. Similar to Dan's troubles a number of triggers don't seem to be working as intended. Sometimes we have to minimize the window tab before the trigger takes place.

As for browsers, there are two of us working on this project, we are using the latest version of chrome & firefox and both have the latest version of Adode Flash.

We have created a number of pages which do have multiple buttons, hidden elements and variables, at first we thought it could be a naming convention conflict but we have totally gone through and made sure each element has it own identity and no change.

Unfortunately i can't share the actual module due to sensitive material but i will rework a version that i can share so you can have a look.

Kind Regards

Gavin

Phil Mayor

Dan Sweigert said:

Hi Ashley,

At this point, although I'm "Publishing to Web" the published files are on my desktop. I'm viewing them through a Google Chrome browser. The funny thing is, when I "Preview the Entire Project" everything works perfectly, but when I publish and click the "View Project" button, a number of the triggers don't work.

The triggers I have set to start & stop playing the video & audio seem to work fine. But the triggers that change the states of my pictures from visible to invisible and vise-versa, and the triggers that jump to the next slide aren't always working.

I had trouble attaching the file to this message, so here's a Dropbox link to where you can download it:

https://www.dropbox.com/s/dkr45dtgpw8j41n/Pinnacle%20Video%20Editing%20Working%20with%20the%20Player.zip

Thanks,

Dan


Hi Dan , I had a quick look at your project you will probably be better off using the hidden state rather than a custom hidden state, also I think a few of your triggers are in the wrong order you have a jump to trigger before a change state trigger, the change state trigger will never fire after a jump to trigger.

Daniel Sweigert

Hi Phil, Thanks for taking the time to look at my project. I have taken care of the trigger issues you mentioned. I'm also going to work on cleaning things up a bit, and eliminating some of the extra bells and whistles to make this more functional. I really appreciate you taking the time to look at this and respond. Dan

Ashley Terwilliger

Hi Dan,

I'd agree with Phil here, there are a few triggers that need to be moved so that they'll fire correctly. There is some additional information here about the order in which triggers will fire that you may want to review. Also, once you've published you'll want to view the published version in the intended environment and not from your desktop or local hard drive. If you need a testing platform before loading to your web site or LMS you may want to use one of the options listed in this article. 

Hi Gavin,

I'd also suggest checking out the trigger order, as they'll fire from top to bottom and if you have a number of buttons, variables, and hidden elements the trigger order will be especially important. If you're able to create a mock up or example of your course we'll be happy to take a look. 

Daniel Sweigert

Hi Ashley,

I made the changes to the triggers that Phil suggested, and now everything works fine except the two videos don't run. Everything including the videos work when I preview the project and when I view it after publishing. But when I uploaded it to my website and tried to run it from there, the videos don't work.

Here's a Dropbox link to the current Storyline file:

https://www.dropbox.com/s/kgg91um9vtnx1hj/Pinnacle%20Video%20Editing%20Working%20with%20the%20Player%20v2.0.zip

And here's the link to where you can see the published version on my website:

http://offbeatimports.com/pinnacle_video_challenge_2/story.html

Thanks,

Dan

Daniel Sweigert

Thanks for your reply Phil,

Based on what you said about mp4s, I thought I'd just try putting up on my other website where I do more music/video/media type stuff and it works. Thanks again for your help! I'm putting this project up for the latest E-learning challenge from David Anderson. Thank you also Ashley!

Have a great week!

Dan

Ashley Terwilliger

Hey Sheri, 

Are you able to share a copy of the .story file here with us? That way we can take a look at your slide settings, states and triggers.  You’ll want to upload the .story file here (which is the file prior to publishing) using the “ADD ATTACHMENT” button at the bottom of the forums reply window. If you’d prefer to not share in the public you’re always welcome to share with our Support Engineers here. They’re available 24/7 to assist!