Trouble with triggers

Hi,

I have a question with attached story file on slide 1.1 BloodFilm&CBCSlide3 with Slide Layer Q3. I have set triggers to show layer Q3 correct when a correct text value of  "cryoglobulin" or "cryoglobulins" has been entered and the user clicks submit; however, when I preview the slide and enter "cryoglobulin"  and click submit nothing happens; when I enter "cryoglobulins" I am shown the wrong slide layer of Q3 Incorrect. I cannot figure out why the triggers are not working.

11 Replies
nandini khandekar

Yes sorry. My bad.

You might want to shift the Incorrect trigger before the the Correct trigger. This is because we dont want to check for the incorrect condition if the correct condition is satisfied. Earlier, the Incorrect trigger was after the Correct trigger so everytime it was running even after checking for the correct condition. I hope I am able to explain it clearly.

Thanks

Nandini

Stephanie Brooks

Just another follow-up question: I have another slide in same format except this time it marks the correct answer as incorrect at first and I have to click 2x on submit button even though trigger is set to user click. I have attached both the story file and the demo screencast

Ashley Terwilliger

Hi Stephanie,

You'll want to look at trigger order for this one and ensure that your "show layer" triggers appear in the list after the triggers that are adjusting the items to selected. Once I made that change I only had to hit select once. Here is a bit more information about the importance of trigger order. 

Stephanie Brooks

So I have literally copied the same triggers that were working for me before, but this time, when answer to question 3 is correct, layer 4 is not showing up. Additionally, when layer 4 is shown, I do not see layer Q2 even though the first layer trigger is show layer Q2. Example attached.

Ashley Terwilliger

Hi Stephanie,

Your layers are currently set up to "hide other slide layers" so once you show one layer, it'll hide the other ones as you move on. You could look at not using that selection with the slide layer properties and use the "eye" icon within the timeline to hide individual elements but it'll be a bit more of a manual process to do so.  

Stephanie Brooks

Thanks Ashley. However, I am still having trouble with Q3. When the correct answer is entered after an incorrect attempt, slide layer Q4 is not shown even though there is a trigger set up for it, exactly the same as I had in the other slides. in addition,  I set triggers to show the other layers when the timeline begins.

Ashley Terwilliger

Hi Stephanie,

I've been playing with this most of the morning - but there are a number of triggers and behaviors that are causing additional confusion.
- all the slide layer properties are set to hide other slide layers but you've allowed the items to be shown in the timeline
- they then are set with triggers to show the other layer at the slide timeline start, and some of those triggers are below other triggers and may not be executing properly such as the continue buttons on the incorrect layers

I think i got this working now, but it's a lot of trigger and a lot to get lost in. Please test out the attached and take a look at the items I deleted, moved around and added to get this to work. It's worth noting that Storyline is designed to have one question per slide.