True/False displaying incorrect layer

I am having an issue with a True False question. I have set up the question for the user to be able to have three attempts. If they answer correctly on the first attempt the Correct layer is displayed. If they answer correctly after the third attempt the Incorrect message is displayed. 

The question

This is the correct response after three attempts but the Incorrect layer is displayed.

Incorrect response

3 Replies
Alyssa Gomez

Hi there Tegid! Sorry to hear you've encountered this roadblock, and thank you for sharing those screenshots. So the incorrect layer is showing when the user gets the question correct on the third try?

Would you mind sharing your .story project file (or even just this slide) so I can have a closer look at how your triggers are set up? Just use the Add Attachment button at the bottom of the reply window. 

Alyssa Gomez

Hi again Tegid! Thanks for sending over your file. The problem lies in using a drag and drop to set up this type of question.

Specifically:

  • Each drag item can be matched to only one drop target.
  • However, each drop target can be assigned to more than one drag item (i.e., you can drop multiple items into the same target).

Although your drag items have correct and incorrect states, the interaction is still determining whether or not the answer is correct based on specific drop targets. 

In my testing, I tried intentionally getting the answer wrong twice, and on the third try, I matched the drag items to the correct drop targets as they are listed in Form View, and I got the Correct layer.

There may be some community workarounds that you could implement, so I hope someone in the community is able to share here with you!