True/False Variable not working

I have worked with True/False variables a lot however for some reason I can't get it to work on this particular project. I have a menu page with three topics which I want learners to read before they advance (see screenshot 1). They click on the title and it takes them to the corresponding page. Once they've read it, they click next and it will bring them back to the menu page and a tick should appear in the checkbox on the right of that topic. I have done the following:

  • Created 3 variables all defaulting to False
  • Created a 'visited' state on each checkbox 
  • Created a trigger which adjusts variable to True when they click on the next arrow for that corresponding page. I have made sure this trigger is above 'jump to slide x'
  • Created three triggers on the menu page 'when timeline starts on this slide, change var x to state 'visited''. 

Despite this, the check boxes aren't changing. I'm not doing anything differently to usual so I don't understand what's wrong? Can someone advise? 

8 Replies
Ned Whiteley

Hi Bethan,

The Visited state is a built-in Storyline state that doesn't require additional variables to implement it and can cause problems when you try to use it this way. You would be far better off creating a new state for each of your check boxes with a different name (e.g. Completed). Once you do this, I think you will find that it works as you want it to.

Ned Whiteley

Hi Bethan,

I'm not sure why it's still not working. To assist you in fault finding, I have attached an example I created a while ago of a sequential menu. This uses variables in the same way that you have in order to place a check mark against completed sections in the menu and also uses the same variables to ensure that each section is visited sequentially.

Hope this helps, but if you are still having problems, are you able to post a copy of your Storyline file here so that I can have a look?

Phil Mayor

There is something odd going on, I think you have everything set up correctly the jump trigger is taking precedence no matter what the order, really odd.

If you remove the jump trigger the b=variable changes. I wonder if you have some corruption going on somewhere. I even switched triggers to button as I thought it was a group thing, but no joy.

Ned Whiteley

Hi Bethan,

There is absolutely no reason why this should not be working. However, I am happy to say that if you delete all your triggers for the forward arrow on each of your three option slides and simply recreate them, you will find that all is working okay. It would appear to be a simple glitch with no explanation. :-)