Trying to upload published course in Saba yeilds this Error

So, what's different about me publishing and uploading these courses from other successful efforts is that I'm getting these .story files back from a vendor who internationalized them (8 different language versions). I've tried three now and I get the same error for all of them...see below

(43073) Failed to import Content Inventory: Getting Started with Aspire - German
(43269) Invalid content. (*)ERROR: Failed to extract the manifest file from content package. Possible cause: The markup in XML document (manifest file) preceding the root element is not well-formed.

I'm using Saba LMS...but I'm thinking the issue is the .story files I've gotten back. When I preview the .story files, they work fine.

Any ideas?

25 Replies
Angela Hutchinson

I received the following error when trying to upload a SCORM file in Saba from Articulate Studio 13. Any insight into why this might be? When I recreated the same file, I got the error mentioned previously in this post. I'm not sure what is going on. Can anyone advise?

(43073) Failed to import Content Inventory: Org Charts (43209) Failed to generate TOC. Error: "java.io.FileNotFoundException: /home/spc/SabaWeb/temp/sabacr1128832556174271373/imsmanifest.xml (No such file or directory)". Please make sure the Asset Storage is configured correctly. 

Christie Pollick

Hi, Angela -- Thanks for reaching out and sorry to hear of your troubles! May I ask if you have had an opportunity to reach out to Saba directly for their thoughts on the error message you are receiving? And as noted above, have you had a chance to take a look at at whether the names of your resources are lengthy or include special characters? You may also want to store your resources on your local C drive to see if you find improvement, as well. 

Angela Hutchinson

I renamed my files and republished them and tried again and still got the error. When I reached out to Saba I received the following:

Hello Angela,

Thank you for contacting SABA support.

I have checked the case and also checked the error that you are getting and seems that the issue is with the content file and the imsmanifest.xml and need to liaise with your content vendor.

Could you please check the same with them and try uploading this once again.

Leslie McKerchie

Hi Sushmita,

Thanks for reaching out with what you are having difficulty with. This thread is a bit dated, but I'd love to be able to help you out.

A great way to test if an issue lies within the project file or your LMS is to test in an environment such as SCORM Cloud.

We'd be happy to test this out for you if you'd like to share the .story file for us to take a look.

Leslie McKerchie

Thanks for the update Sushmita.

Are you zipping the output from the publish successful dialog box or manually zipping the content?

Did the output that I shared above not upload to your LMS either?

I did notice that the title is a bit long, so be sure that you are publishing locally and perhaps reduce the number of characters to see if that works better for you.

Crystal Horn

Hi there, Sonica. We found an issue with Rise 360 output exported for SCORM when it includes Storyline blocks. There is an unnecessary tincan.xml file in the output that is giving some learning management systems trouble identifying the SCORM format.

  • Does your Rise 360 output include Storyline blocks?
  • You mentioned you had issues with web format. Are you exporting for web and hosting on a web server or in a learning management system?

We'll help pinpoint what's happening and give you some next steps!

sonica pujji

Hi Crystal

Thanks for your response.  I have no storyline blocks in the Rise content I created, but it's good to be aware of that.  Are you suggesting deleting the tincan.xml file in such an instance?

For now, the Rise content is exported for web and hosted on a LMS.  I have done this multiple times in the past with no issues.

Appreciate your help and attention.

Cheers