Undo Button in SL

I have seen some sporadic instances of UNDO not working fine in SL.  Please note that I am only a 3-day old user of SL.  So on my 3rd day of SL, I found that when I am working on slide 5 and I do UNDO, it somehow takes me back to slide 2 and does UNDO operation there.  This happened about 5-10 times...And today when I opened the same file, it worked just fine - I mean the UNDO function worked as expected.  Is there some minor bug in the system related to UNDO function? 

46 Replies
Bruce Graham

Undo cannot be trusted! It is evil I say....evil.. 

The only time I would ever use Undo is if I had saved my project first - which is somehow rather strangely counter-productive...

I believe it may be currently coded as "Undo Something at Random", rather than "Undo last action". It seems to get more flaky the more graphical content is there (IMHO), I had it jumping around scenes yesterday which was a little perturbing.

The madness must be stopped (v1.1? - pretty please...)

Bruce

Bruce Graham

Actually Peter, I guess I should have included a in my post.

Doesn't saving "override" the Undo feature? I always thought that Undo only worked in an "unsaved" workflow, hence my reference to it being "...strangely counter-productive".

If I have inadvertently suggesting something useful then I'm rather chuffed with myself

Bruce

Payal Tandon

Thanks Peter and Bruce.  I will try to not use undo feature or if I do, I will try with CTRL S and then CTRL Z.  Although, it may take quite a lot of conditioning.

This is a very minor adjustment that I am willing to make.  I just love storyline..Seems like there is no going back to ppt for me...But definitely it would be great if we could know of such known issues before hand so that we are prepared to face them and figure out work arounds for them.  Are such things documented somewhere?

Thanks,

Payal

Barb Bodemer

I love Storyline, but I have to agree with Bruce, the madness must be stopped! I've been working on a project for weeks and  the back arrow has worked on and off, mostly off. I just now I logged on to see if anyone else was having the same issue when lo and behold, I find it's been a serious issue since Beta testing!  What's up with that? Using the back arrow is ingrained in us from the day we learn to use a computer - it's not cool that you expect us to just stop using it instead of fixing it. PLEASE make this a priority! Pretty please?

Eilert Torsnes

As I haven't been able to find a post from someone saying they reported this issue as a bug, I took the liberty to send a bug report regarding the issue with the undo/redo func

I will paste the report here, and keep you guys posted on any development.

To the forum administrators: would it be easier to navigate the forum if similar discussions were combined into one? For instance the three overlapping discussions regarding the ctrl-z mystery...

Apologize for the typos hehe...

Case Number: 00290320
Reference ID: ref:_00D30Txo._50040LVvnk:ref
Case Details: The undo/redo function/ctrl+z/y

After browsing the forum yesterday, I saw that others had experiencing issues with the undo/redo func as well.

What happened to me was that I lost an hours work, two times in a row...pressing ctrl+z, resulted in the undoing of the last god knows how many steps. Pressing ctrl+y, some of what I had prior to pressing ctrl+z reappeared, but half the layers I had created was still M.I.A...

It has probably been reported by others as there's been some forum buzz on the matter, but I report it as well out of sheer frustration.

Eilert

PRODUCT: Storyline

Eilert Torsnes

Oki

Would be nice to have a thread in the forum or somewhere on the articulate website where the update details were posted by the developers. Then clients could see what was being done about bug reports.

It's like when waiting for a delayed train to start moving again...if you get some info about what's going on, when it will be sorted etc then the waiting time becomes more bearable hehe:)

Patience is a virtue, but when I'm on the clock I just need stuff to work...

- Eilert

Peter Anderson

Eilert Torsnes said:

I'm bearing

Do you know of any info on what the 1th of August update for Storyline contained somewhere?

Eilert


Sorry, guys. Still working to get the unexpected behavior of the undo button under control and fixed for one of the next updates. I'll update here once we get it resolved. Sorry again for the inconvenience. If you'd like to check out what we fixed in Update 1, here's the rundown. 

Egor Semenikhin

I’m losing loyalty to Articulate. I can’t rely on Storyline anymore because of undo issue. Yesterday I lost many hours of work. It wasn’t  the first time. And I’m pretty sure I had been saving changings all the time. This bug wasn’t fixed in the last update in December, 2012. When will you do this guys? All you always say is lame excuses. 

Peter Anderson

Really sorry for the trouble and lost work, Egor. Our engineers continue working to improve the undo functionality. It's proven to be a difficult one to track down because of all the variables involved. 

As others have noted, as a workaround, continue to save frequently. And if you notice the undo function beginning to misbehave, a quick save and restart usually restores order. And please feel free to send us reports if you have information that will help. 

Again, I'm really sorry for the inconvenience, and we're eager to get this one knocked out, too.