24 Replies
Nancy Woinoski

Hi Bill, I'm sorry to hear that you lost your work. The undo/redo in Storyline is a known bug. Articulate improved the way it works with text in the last update but it is still bad when trying to undo anything else. The only thing that I can suggest until Articulate fixes it properly is to save your work often.

Suchada Stevens

Hello,

This just happened to me as well and I was hoping to find a solution.  When I click undo, it does not undo all of my work for the past couple hours.  It just picks one random thing to undo (like a trigger) from a couple hours ago and it's never the same thing.  I see these posts were from earlier this year.  Is there a fix yet?

Leslie McKerchie

Hi Peter - this thread is a bit dated and seems specific to SL1. Does this happen in any file that you are working on or a particular file? Can you consistently replicate the behavior so that we could try to as well? That could certainly be helpful.

If a particular file, you may first want to try to import your slides into a new file as explained here.

If it's your software in general, please be sure you are utilizing the latest update and if so, please conduct a repair outlined here.

Ashley Terwilliger

Hi Walter,

As you'll see from this discussion it's quite a bit older! So let's get a bit more information about your setup to determine next steps. 

Are you on the latest update of Storyline 360? Update 22 was released today, so I'd start by updating Storyline. Also, is this happening on only one file? Are you able to share that file with us for testing? 

Crystal Horn

Hi, Martin.  It sounds like you have seen some inconsistency with the Undo function in your Storyline 360 projects.  Let's see if we can narrow it down:

  • Are you noticing issues with using Undo and the Closed Caption editor?
  • Have you had issues with Undo in your Notes panel after going to a different slide?

These are two issues with Undo that we currently have on our radar for Storyline 360.  Let me know if those don't apply to you.  We'll be happy to work one-on-one with you to find a solution!

Martin Dean

Hi Crystal

Thank you for getting back to me.

I have not experienced the two issues you mention in your message.  So far, I cannot repeat the issue here but it has happened twice in one day.  I shall try to identify if there is a specific ‘cause’.

I can report that CTRL+Z and the undo button in the interface ceased to work until I restarted A360.

 I will let you know if it happens again and try to tell you exactly what I was doing at the time.

Regards

Martin

 

Martin Dean

Crystal

I have made a short video showing the problem I am having.  It appears to be happening in one file, although I have seen this in other files as well.

What I have found:

Text can be edited and the CTRL+Z function and UNDO button work. 

However, if the text object is deselected, the Undo functions do not work.

If a shape is edited, the Undo functions do not work

(This is weird!)

I saved and closed the file used in the video without removing the extra text and shape boxes.  When I opened the file again, these had disappeared!

https://vimeo.com/310071538

 

Katie (Gokhshteyn) Riggio

Thank you for creating a quick recording of the quirk, Martin. Very helpful (and weird, indeed)!

I haven't seen other reports of this Undo behavior, but we're happy to work closely with you to find the cause and file a new bug if necessary!

If this is happening in one file at this time, we'd want to be sure that the project is stored on a local C: drive. Also, let's see if a Storyline 360 repair helps fix the broken function on the affected file.

Looking forward to digging deeper!

Martin Dean

Hello Katie

Thanks for diving in on this.

I can confirm that all my SL files are on a local C: drive and I followed the instructions to repair SL (uninstall and re-install).

The problem is intermittent and does not apply to all open files at the same time.  So, this suggests it is a file corruption issue rather than a bug in the actual software.  However, this does not explain why, after closing and re-opening the software, the problem does not appear.

I think this cannot be readily addressed so I will update this post as and when it happens again.  If a pattern appears, then I will report it.

Meanwhile I will put it in the 'weird' tray and hope it goes away

M

Katie (Gokhshteyn) Riggio

Hello, Martin. Thanks for giving Storyline 360 a repair and for working locally! 

I'll stamp this Undo experience as Weird on our side, too. 🙂If you run into this again especially in a new file, do let us know. We'll work with you to compare both projects to see if we can help find the source of the problem!

Crystal Horn

Hi there, Martin. We have been able to document reproducible issues with Undo when working with closed captions, notes after going to a different slide, and grouped objects. It sounds like you are consistently seeing issues with Undo despite it being hard to reproduce.

Let's get you working with our team to see if we can nail down why this is happening. If it's still happening in the one file as your Vimeo showed, please include that file when you submit your case! We'll delete it when we're done troubleshooting.

Katie (Gokhshteyn) Riggio

Hi there, Christen. So sorry you've hit this roadblock!

A few questions to help us unlock this mystery:

Let me know, and we'll explore our next course of action from there!