URGENT! Bug with trigger panel on new update

Hi all.

Since the recent update to Storyline a bug has surfaced whereby layers on a master slide are no longer recognised. When creating a trigger it's not showing the layers in the dropdown, which means triggers can no longer be added for any master slide layers. I've attached a screenshot.

This has broken all of our courses which need to go live by the end of the year, so this needs to be resolved ASAP.

11 Replies
Astutis Articulate 3

Hi.

Thanks for the responses.

I've closed and reopened it and rebooted today and it's still an issue on the projects we created before the update. I've installed the Nov 5th update.

As you can see from the screenshot in my original post, the triggers aren't recognising that the layers exist. We don't particularly want to use an old version of Storyline, as this means we'll miss out on all future updates.

Peggy Harris

I JUST ran into, and submitted, a similar issue. Only, I'm not seeing my post show up (yet?).  In my case, I am creating software training.  I am adding comment layers to explain pieces of the code. This is what it looked like yesterday. 

This morning, after installing v3.33.20697.0, whenever I create a new layer, I cannot see the base layer.  Performing the exact same steps, when my new layer is visible, I now see the following.

I have tried clicking all of the visibility icons, and cannot figure out how to see my base layer while creating a new layer.

Leslie McKerchie

Hello Peggy and welcome to E-Learning Heroes :)

I'm not seeing a similar conversation or support case for you, so let me know if you have a link or case number and I'd be happy to take a look.

As for this issue you're running into, I'm curious if you have the layer properties set to 'Hide Objects on Base Layer'? That would cause the behavior you're seeing.

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Hi Astutis,

Thanks for letting us know that you're still running into an issue.

With your permission, I'd like you to share your project file with our support engineers to investigate what's happening. You can share it privately by uploading it here. It will be deleted when troubleshooting is complete.

Peggy Harris

Leslie - I just checked, and I do not have Hide objects on base layer set.  It's only set to Hide other slide layers (as you can see below). 

Let me cut my file down to the pertinent slides, and then I can post or send privately.  Please note that nothing changed since yesterday, except for the upgrade to v3.33.20697.0 (and resulting changed behavior when a new layer is created). 

Astutis Articulate 3

Hi there.

I've uploaded my Story file to the link that was provided. I've just noticed that it appears to be an intermittent problem - the project I'm currently working on was fine, then while I was switching between master slides the problem occurred. It seems to be related to how it's showing in Storyline, rather than the actual function of it, as the triggers are still working when previewed, I just can't amend them or add any new ones.

Peggy Harris

Quick results of my layers issue. After I upgraded to v3.33.20697.0, a default setting appears to have changed on my existing story.  Previously, when I created a new layer (open the layer, right-click, and select Format Background) my settings defaulted to No fill.  

After the update, when I create a new layer, right-click and select Format Background, my settings default to Solid fill. So, my base layer didn't disappear, but was covered by the solid fill. 

The fix was to create a new Storyline project, and import all slides from the last project. After doing so, I am able to create new layers and see the base layer below.