Urgent help needed - can't save file (CompressLengthMismatch)

I could really use some suggestions from those of you have been through the 'can't save file' issue. The error in my situation is CompressLengthMismatch. I have many hours of work possibly lost -- I have backups as recently as yesterday, but have added a huge amount since then. I've been reading this board and followed several suggestions already... I'm working locally, have no special characters or spaces in filename or path, the file is directly in C:\Documents to avoid long paths, have rebooted several times, tried saving under a different name, deleted tmp files after checking for the one I need, etc. I also reinstalled SL 2 and have the latest updates.

I can import the slides to a new project, but many images and mouse cursors are lost in the process. It would require a large amount of work to re-add them all. The course is due later today for an important client, and I'm at a loss.

The file is 111 slides and about 200mb (115 in the new file with slides imported). It's almost entirely a recorded demo save as individual slides. I noticed some people have had issues with fine-tuning the action on specific slides. I've done that on 8-10 slides with no obvious problem. I saw that one person had trouble when previewing the full course -- I hadn't done that yet.

The only other thing that's at all unusual (for me, anyway) is that I have all 111 slides in one scene, but even that doesn't seem that odd. I'd really appreciate any suggestions. If I have to recreate all the elements that are missing when I import to a new file, there's no way I'll make the deadline. This is so discouraging after working all weekend to make sure it was done on time. I'll submit a ticket and the file, if necessary, but am hoping I can find a solution here. Thank you for your help.

7 Replies
Ashley Terwilliger

Hi Cory,

I'm really sorry to hear about the issues with your file. It sounds like you've gone through the majority of troubleshooting steps that I would recommend, and are still unable to save this one particular file. You mentioned importing it causing the file to lose certain items such as images - so it would lead me to believe that there may be an element of corruption associated with the file and/or the images that go missing. 

I think the next best step would be to look at sending along what you can to Support engineers so that they could dive a bit deeper into the specifics. Can you reach out to them here? Also I will follow along once you let me know you've submitted the case. 

Cory Solutes

This is no longer urgent because after hours of troubleshooting, I'm able to save the file, at least for now. I'm just hoping the problem doesn't resurface. I'd really like to find out why it happened, and whether it's being investigated for a future update.

Here's what led up to finally being able to save, for no apparent reason. After trying every tip and trick I could find, I tried Save As several more times with different file names, and continued to get the 'can't save' error. I then noticed it WAS saving the new files (the error said it wasn't), but without edits. I tried editing/saving the new files directly, with no luck. Occasionally, I'd go back to the original file and make a minor change and try a regular save, and about the 15th time, it worked.

I haven't done any serious editing since then, so I don't know if the joy will continue, but at least for now, it seems like I can save edits and I have a few (theoretically) good backups.

Ashley Terwilliger

Hi Cory,

Could there have been additional elements in the file that were causing a file size bloat or general issues with the file such as unused slide masters, unused screen recordings, etc.? Typically doing a save as or importing into a new file also helps with those issues to give you a clean copy and resolve any odd behavior. I'm happy to hear that it's working again - and please feel free to let us know if you need anything else! 

Sushil Suryawanshi

Hi Cory,

I m facing the same error (compresslengthmismatch) in one of my important projects. The file is as heavy as 500 mb! However, I faced this issue no earlier than today while saving the file. I donno what happened today!

I am curious to know urgently:

1. How come your file could get saved?

2. How come the size of your file got down so drastically?? Did you delete any elements or it happened automatically??

3. What should I do to make same things happen to my file?

Regards,

Sushil

Ashley Terwilliger

Hi Sushil,

This thread is a bit older, so I'm unsure if Cory is still subscribed but you could reach out to him directly using the "contact me" button on his profile.

If you've already gone through the troubleshooting steps I shared above, you could also contact our support team and we'll take a look at what's happening.