Urgent : PeopleSoft LMS cannot display the content

Urgent : PeopleSoft LMS cannot display the content

Hi There,

Hello, I am new to Articulate Storyline, I am working in training department of an organization in Hong Kong.  Now we are making a purchasing decision for a new eLearning tool, and Storyline is at the top of the list, as it is easy to use and powerful.  However, I am facing the problem below.  Could you please give me a help?  If the problem can be fixed.  I am sure that I will ask my company to purchase the licenses. 

I downloaded the trail version of Storyline and try to create an e-learning for my company, but I published the zip file and sent to our LMS administrator for uploading, a message from webpage are showed "An error has occurred: Error - unable to acquire LMS API, content may not play properly and results may not be recorded.  Please contact technical support.  Press 'OK' to view debug information to send to technical support."  Internet Explorer will be closed automatically, once I clicked 'OK'.

More information:

My company is using Oracle PeopleSoft LMS, possibly version 9.0.  Windows XP 32bit

I created the e-learning by using my own computer, my computer is Windows 7 64bit


Below is the debug code:

0:Tue Apr 30 18:15:46 UTC+0800 2013 - AICCComm - Trying to create MSXML2.XMLHTTP in VBScript

1:Tue Apr 30 18:15:46 UTC+0800 2013 - AICCComm - intReCheckLoadedInterval=250

2:Tue Apr 30 18:15:46 UTC+0800 2013 - AICCComm - intReCheckAttemptsBeforeTimeout=240

3:Tue Apr 30 18:15:46 UTC+0800 2013 - AICCComm - IFrameLoaded

4:Tue Apr 30 18:15:46 UTC+0800 2013 - AICCComm - In GetAICCURL

5:Tue Apr 30 18:15:46 UTC+0800 2013 - GetQueryStringValue Element 'AICC_URL' Not Found, Returning: empty string

6:Tue Apr 30 18:15:46 UTC+0800 2013 - AICCComm - Querystring value =

7:Tue Apr 30 18:15:46 UTC+0800 2013 - AICCComm - GetAICCURL returning:

8:Tue Apr 30 18:15:46 UTC+0800 2013 - AICCComm - In DetectPreferredCommMethod, checking XMLHTTP

9:Tue Apr 30 18:15:46 UTC+0800 2013 - AICCComm - Checking IFrame

10:Tue Apr 30 18:15:46 UTC+0800 2013 - AICCComm - blnCanUseXMLHTTP=true

11:Tue Apr 30 18:15:46 UTC+0800 2013 - AICCComm - blnCanUseIFrame=true

12:Tue Apr 30 18:15:46 UTC+0800 2013 - ----------------------------------------

13:Tue Apr 30 18:15:46 UTC+0800 2013 - ----------------------------------------

14:Tue Apr 30 18:15:46 UTC+0800 2013 - In Start - Version: 3.8.2 Last Modified=04/30/2013 17:29:17

15:Tue Apr 30 18:15:46 UTC+0800 2013 - Browser Info (Microsoft Internet Explorer 4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.1; .NET CLR 1.1.4322; MS-RTC LM 8))

16:Tue Apr 30 18:15:46 UTC+0800 2013 - URL: https://a01shrmslmsweb1a.rsrc.silver.dbs.com:9443/dbseluat/scorm/New_Staff_Induction_20130430a/index_lms.html

17:Tue Apr 30 18:15:46 UTC+0800 2013 - ----------------------------------------

18:Tue Apr 30 18:15:46 UTC+0800 2013 - ----------------------------------------

19:Tue Apr 30 18:15:46 UTC+0800 2013 - In ClearErrorInfo

20:Tue Apr 30 18:15:46 UTC+0800 2013 - GetQueryStringValue Element 'StandAlone' Not Found, Returning: empty string

21:Tue Apr 30 18:15:46 UTC+0800 2013 - GetQueryStringValue Element 'ShowDebug' Not Found, Returning: empty string

22:Tue Apr 30 18:15:46 UTC+0800 2013 - strStandAlone= strShowInteractiveDebug=

23:Tue Apr 30 18:15:46 UTC+0800 2013 - Standard From Configuration File - SCORM

24:Tue Apr 30 18:15:46 UTC+0800 2013 - Using Standard From Configuration File - SCORM

25:Tue Apr 30 18:15:46 UTC+0800 2013 - In LMSStandardAPI strStandard=SCORM

26:Tue Apr 30 18:15:46 UTC+0800 2013 - Calling Standard Initialize

27:Tue Apr 30 18:15:46 UTC+0800 2013 - In SCORM_Initialize

28:Tue Apr 30 18:15:46 UTC+0800 2013 - In SCORM_ClearErrorInfo

29:Tue Apr 30 18:15:46 UTC+0800 2013 - Grabbing API

30:Tue Apr 30 18:15:46 UTC+0800 2013 - In SCORM_GrabAPI

31:Tue Apr 30 18:15:46 UTC+0800 2013 - Searching with improved ADL algorithm

32:Tue Apr 30 18:15:46 UTC+0800 2013 - In SCORM_GetAPI

33:Tue Apr 30 18:15:46 UTC+0800 2013 - SCORM_GetAPI, searching opener

34:Tue Apr 30 18:15:46 UTC+0800 2013 - In SCORM_ScanParentsForApi, win=

35:Tue Apr 30 18:15:46 UTC+0800 2013 - Error grabbing 1.2 API-Error:Permission denied

36:Tue Apr 30 18:15:46 UTC+0800 2013 - Unable to acquire SCORM API:

37:Tue Apr 30 18:15:46 UTC+0800 2013 - SCORM_objAPI=object

38:Tue Apr 30 18:15:46 UTC+0800 2013 - In InitializeExecuted, blnSuccess=false, strErrorMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.

39:Tue Apr 30 18:15:46 UTC+0800 2013 - ERROR - LMS Initialize Failed

40:Tue Apr 30 18:15:46 UTC+0800 2013 - In DisplayError, strMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.

Many thanks for your advise.

7 Replies
Christine Hendrickson

Hi there Dicky! Welcome to E-Learning Heroes!

If you receive an "Unable to acquire LMS API" error when launching Articulate content in your LMS, this may be caused by the version of Java that you have installed.

Some LMS’s use a Java API object to load content.  Since content created in Articulate does not require Java, please do the following:

*  Contact your LMS provider and ensure that your installed version of Java is compatible with the version of the LMS you are using.
*  Ensure that you have published your content properly as described in the following article:
http://www.articulate.com/blog/publish-to-lms-with-studio-09/

If this issue persists, make the following modification to your player template, and test your content again:

1)  Open your presentation in PowerPoint.

2)  Go to Articulate > Player Templates.
3)  Select the "Other" tab.
4)  Deselect (uncheck) "Launch presentation in new window".
5)  Close the Player Template manager, and save the change when prompted.
6)  Publish your presentation for LMS using the newly saved player template, and test the content in your LMS.
Hopefully this will resolve the issue for you. Please let me know if you have any trouble with this, or if you have any questions.
Thanks and welcome again!
Christine
Dicky Hung

Hi Christine,

Many thanks for your reply.  I have asked our LMS administrator about the JAVA version of LMS in our company today.  They said we are using Studio ’09 Professional software, and it can communicate with our PeopleSoft LMS very well, the JAVA version and setting should be supportable to load the content.  They said it may be another reason...

However, I have follow your mentioned steps and I also go to read all relevant tutorials and find out many discussions in your forum, but the problem still cannot fixed.  I am very appreciated if you can solve my problem. I don't know what can I do now...  

Any suggestions, ideas, and advises are appreciated.  Thank you very much.

Christine Hendrickson

Hi Dicky,

Have you had a chance to test your course in SCORM Cloud, as Nancy suggested? This would help us determine if the issue is Articulate related or if it's on your LMS's side. 

If it appears in SCORM Cloud as well, we'd be happy to take a closer look at what might be going on.

If you can't replicate the issue in SCORM Cloud, it's probably an issue that you'd want to take to your LMS team. 

The articles here and here may also help clear up common LMS issues.

Let us know how it turns out.

Thanks!

Dicky Hung

Hi Christine and Nancy,

Many thanks for your advise, I have went to the SCORM Cloud http://scorm.com/scorm-solved/scorm-cloud-features/ and uploaded my content.  It can ran in SCORM Cloud very well and no any error message.  Below is the screenshot for your reference.

May I know what can I do now?  Many thanks in advance.

Christine Hendrickson

Hi Dicky,

If it runs well in SCORM Cloud, it may very well be a problem with the LMS. 

I did notice that you asked about JAVA in another thread, did you have any luck with your LMS team? They may want to check this and the information you saw in SCORM Cloud. If you can pass that information along to them, or a link to your course in SCORM Cloud, it may help them troubleshoot this.

Thanks!

Neil Bowman

Hi Dicky

We get the same error message as you are getting on our PCs where Java has not been installed completely. Sometimes we find it looks as if Java is installed but it is only partially  installed or corrupted in some way.

A site like http://java.com/en/download/help/testvm.xml   can help test whether Java is working correctly.

Everytime we re-install Java then this fixes the error . 

Regards

Neil