Urgent problem- lost content in story.html

Hi!

I'm just about to deliver a larger course to my customer made in storyline, today!!, when I realize that all graphic (Pictures buttons etc) are missing. I worked last time yesterday and everything seemed fine. When I open the story file this morning the file size was reduced from 76 900 Kb to 7800 Kb. When I open the Project all slides are empty besides a few text boxes. I have a back up but not for the latest version of the Project unfortenately.

Is there anything I can do to get the Project content back?

Thankful for urgent support!

Best regards

Maria

14 Replies
Ashley Terwilliger

Hi Maria,

You mentioned in the title that the items are missing within the story.html file? What about the .story file that you published from? Some items to check and could be why you've experience erratic behavior, lost of resources, or file corruption include:

  • Working on a network drive or a USB drive can cause erratic behavior, includingfile corruption, loss of audio, and other unexpected behavior. Work on your local drive (your C: drive) to prevent these issues.
  • You should also make sure the directory pathto your project files and your published output is less than 260 characters(for example C:\Articulate).
  • Avoid using special characters, accents orsymbols in your file names.

If your .story file is ok, I'd suggest republishing to your local drive, and then testing the published output within the intended environment to ensure all resources are there. 

Maria Jonsson

Thanks Ashley for your answer!

I meant the .story file but wrote by mistake the story.html file, my mistake sorry about that. . The loss of content is about the .story file unfortunately and if I search the html files within the Output folder they are all gone. So it feels very strange.

I always save locally on C: drive and I also have scheduled back up elsewhere but many hours of work was never saved on my back up storage. My latest version of the Project was saved by myself about 11 PM at night, although the .story file says it was saved by 5 PM the same night which is wrong. That´s the reason why the latest version never was included in my scheduled back up (by noon)

The directory path could be one issue because the path is quite long, not sure if it exceeds 260 characters though. I also use the underline symbol (_) in file names. Better stop doing that if that is one reason to this problem.

I have worked all day remaking yesterdays work but I hope I won't experience this again. This makes me worried about the stability of Storyline. I really don't want to change tool because I really like it.

I will follow your instructions but if there are any other things I and others can do to avoid this to happen again, please inform here and elsewhere in your forum. 

Thanks

Maria 

Ashley Terwilliger

Hi Maria,

Thanks for confirming those elements. Also, the _ underscore should not be causing you any difficulty, and you'd probably want to use that instead of a space within your file names. I'd suggest another good idea for right now is to conduct a repair of Storyline to solve any other odd behavior you're experiencing, and just make sure you've closed any open Storyline files before doing the repair. Additionally, there is not an autosave feature within Storyline, so it sounds like you've got some back up procedures in place - but I'd suggest saving more often if possible. 

Rebecca - I see your post now, and my apologies that it hasn't been replied to yet, it's been a busy week in the forums!  

Since you're able to see the images within the thumbnail, I'm curious if you'd be able to share your .story file here so that we could take a look and if you'd prefer to share it privately you can send it along to our team. 

Rebecca Aquino

Ashley, I'm uploading the file for the support team now. I'll also conduct a repair as you suggested above. I'd noticed yesterday that typing was delayed, but I don't know if that's related to this at all.

Maria, I do have a backup so I'm safe there, thankfully. I'm just hoping that this is something with just that one file and that it won't happen again. I wasn't too far along with that module, but if it had been another one it would have been really bad as it's a huge file.  Good luck to you!

Maria Jonsson

Ashley, since I have experienced several times that Storyline suddenly close down during work I'm used to save continuously but although I have done that the file wasn't saved. Yes, I will try to do a repair of Storyline.

By the way I was also able to see all graphic (pictures, buttons etc) on the miniature pictures within Storyline in Story view, exactly the same as for Rebecca.

Glad to hear Rebecca, that you didn't loose a lot of  work. I'm curious to find out whether the team could fix your problem after looking at your file, could you please let me know here?

Ashley Terwilliger

Thanks Maria - and I'll be able to update this thread as well as I follow along in Rebecca's case.  Also, since you had mentioned that you had already recreated your .story file, I didn't know if we'd be able to see any problems in it - but please always feel free to share the file here in the forums or by connecting with our Support team. 

Maria Jonsson

Thanks, I can share my file to your Support team.  I send it over. I tried to follow the steps for repair Storyline ( I run Windows 7) but when I right-click the storyline.exe file (I guess that is the correct file..) the program directly opens I never get the option to choose Repair. Should I be looking for another file than storyline.exe?

Jacob Henenberg

Maria,

As per the support article on how to repair Articulate Storyline, you'll need to right click on the installation file (I.e. the file you downloaded from the Articulate website and used to install the software), and not on Storyline.exe

After you right click on the installation file, you will see a menu. Choose Run as Administrator, and when the setup program launches, select the Repair option.

Ashley Terwilliger

Hi Rebecca,

I see that Regil did some additional testing of your files and shared the following, which I've provided here for the others following along:

Please be informed that this issue was reported to our Quality Assurance team for review and has a critical status. I cannot offer a time frame for when or if this issue will be addressed. I would recommend, at this time, to take a different approach so that you continue working on your project. 

While the cause for this reported issue is still unknown, we would like to encourage you to create backup your files to ensure that you won't lose your project. Here's our recommended backup method: 
http://www.articulate.com/rapid-elearning/heres-an-easy-way-to-back-up-your-e-learning-project-files 

Ideally, it would be nice to also include some kind of versioning as well. This should enable you to get back to an earlier version of your file, should there be a need to.